[DSDS][Dialer][Call log] Make call from call log via default SIM

RESOLVED DUPLICATE of bug 920011

Status

Firefox OS
Gaia::Dialer
P1
normal
RESOLVED DUPLICATE of bug 920011
4 years ago
3 years ago

People

(Reporter: WDM, Assigned: drs)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.0, tracking-b2g:backlog)

Details

(Whiteboard: [ucid:, 2.0, ft:comms])

(Reporter)

Description

4 years ago
As a user, when I tap a call log item I want the call to occur on the default SIM. 

Acceptance Criteria

AC1: I dont want to be taken to the dialer and press dial
AC2: I want to call the user back on his (same) number the caller dialled me from
AC3: I want to use the default SIM for calls even if user called me on a different SIM on my dual SIM device.
Summary: [DSDS] Make call from call log via default SIM → [DSDS][Dialer][Call log] Make call from call log via default SIM
Summary: [DSDS][Dialer][Call log] Make call from call log via default SIM → [DSDS][Dialer] Make call from call log via default SIM
Summary: [DSDS][Dialer] Make call from call log via default SIM → [DSDS][Dialer][Call log] Make call from call log via default SIM
Blocks: 942446
No longer blocks: 945641
blocking-b2g: 1.4+ → ---
blocking-b2g: --- → 1.5?
No longer blocks: 942446
this is one of the 1.5 committed feature for comms
Blocks: 985426
blocking-b2g: 1.5? → ---
Whiteboard: [ucid:, 1.5, ft:comms]
(Assignee)

Comment 2

4 years ago
This is being done in bug 920011. It's much easier to combine this, bug 920011, and bug 947136 into one patch.
thanks Doug, in such case, do you mind taking the bug? you may resolved fixed all 3 at the same time with one patch
Flags: needinfo?(drs+bugzilla)
(Assignee)

Updated

4 years ago
Assignee: nobody → drs+bugzilla
Flags: needinfo?(drs+bugzilla)
blocking-b2g: --- → backlog
Whiteboard: [ucid:, 1.5, ft:comms] → [ucid:, 2.0, ft:comms]
calling from call log will be worked on bug 920011.
add dependency
once bug 920011 lands, lets close this and verify the acceptance criteria
Depends on: 920011
Hi, Mathanaraj, In AC1, so a call is made through network, and the call page shown with number or name on it, is that right? No need to press dial.

(In reply to Wilfred  [:WDM] from comment #0)
> As a user, when I tap a call log item I want the call to occur on the
> default SIM. 
> 
> Acceptance Criteria
> 
> AC1: I dont want to be taken to the dialer and press dial
> AC2: I want to call the user back on his (same) number the caller dialled me
> from
> AC3: I want to use the default SIM for calls even if user called me on a
> different SIM on my dual SIM device.

The AC1 seems to contradict the user story in 920011, page 10 & 11 of "[Dialer] Call directly from 
Call log V3.pdf" in which the user is required tapping on the green call button.

(In reply to Joe Cheng [:jcheng] from comment #4)
> calling from call log will be worked on bug 920011.
> add dependency
> once bug 920011 lands, lets close this and verify the acceptance criteria
feature-b2g: --- → 2.0
Hi, Carrie, Could you help with this, thanks a lot..
Flags: needinfo?(cawang)
(In reply to Eric Chang [:ericcc] [:echang] from comment #6)
> Hi, Carrie, Could you help with this, thanks a lot..

AC1 from Wilfred looks correct. It's the point of dialing directly from call log.
I guess we just need a update on UX document.
No, the spec is correct. This is the special case that we deal with "long tap to select SIM" and "Call directly from call log". We've discussed this a while and reached the conclusion already. No need to change spec, but I think WDM may need to rephrase AC1 a bit for DSDS case. Thanks!
Flags: needinfo?(cawang) → needinfo?(wmathanaraj)
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 920011
(Reporter)

Updated

4 years ago
Flags: needinfo?(wmathanaraj)
Blocks: 1026943
No longer blocks: 1026943
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.