Last Comment Bug 947356 - On a dark/black toolbar, icons are too dark, need lighter color for more contrast (inverted icons?).
: On a dark/black toolbar, icons are too dark, need lighter color for more cont...
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Linux
-- normal with 3 votes (vote)
: Firefox 33
Assigned To: Dão Gottwald [:dao]
: Cornel Ionce [QA] (:cornel_ionce)
: Dão Gottwald [:dao]
Mentors:
: 947359 (view as bug list)
Depends on: 572485 637608 994623 1012629
Blocks: australis-cust australis-merge 874674
  Show dependency treegraph
 
Reported: 2013-12-06 10:57 PST by [:Aleksej]
Modified: 2014-06-30 05:34 PDT (History)
11 users (show)
mmucci: firefox‑backlog+
See Also:
Crash Signature:
(edit)
QA Whiteboard: [qa!]
Iteration: 33.2
Points: 2
Has Regression Range: ---
Has STR: ---


Attachments
screenshot: australis-2013-12-06-toolbar Shiki GTK theme, Default vs Black Fx theme (70.41 KB, image/png)
2013-12-06 10:57 PST, [:Aleksej]
no flags Details
remaining piece: the all tabs button (4.14 KB, patch)
2014-06-20 10:08 PDT, Dão Gottwald [:dao]
mdeboer: review+
Details | Diff | Splinter Review

Description User image [:Aleksej] 2013-12-06 10:57:53 PST
Created attachment 8343878 [details]
screenshot: australis-2013-12-06-toolbar Shiki GTK theme, Default vs Black Fx theme

2013-12-06-03-02-02-mozilla-central-firefox-28.0a1.en-US.linux-x86_64

The screenshots were made with a "Shiki" GTK theme.  The zoom control is text, so it is a separate issue (it works with Darklooks).
Comment 1 User image :Gijs 2014-01-15 15:09:25 PST
Which icons do you mean? The tabscrolling and tab list dropdown icons, or something else? In the screenshot, it seems all other icons are inverted...
Comment 2 User image [:Aleksej] 2014-01-16 01:32:16 PST
I think the "+", "−" and wrench icons are not inverted: they look wrong.
Comment 3 User image Justin Dolske [:Dolske] 2014-02-04 12:53:59 PST
*** Bug 947359 has been marked as a duplicate of this bug. ***
Comment 4 User image Justin Dolske [:Dolske] 2014-02-04 12:56:23 PST
I think this is basically unsolvable (for now) - no matter what icon color/inversion we use, there will be some GTK theme that matches it closely enough that it becomes low-contrast.

The long-term solution would be to use SVG icons so we can dynamically adjust the color of icons, but that's not going to happen soon.
Comment 5 User image Dão Gottwald [:dao] 2014-02-04 13:23:18 PST
Bug 764299 should have made SVG icons viable. What else is missing?
Comment 6 User image Mike Conley (:mconley) 2014-02-04 13:25:14 PST
I believe at least part of the problem was that it seemed like introducing SVG icons would regress us on ts_paint.

I wonder if it's possible to persist the cached SVG from session to session, and only invalidate it if we detect a system theme change?
Comment 7 User image :Gijs 2014-02-04 13:26:14 PST
How does using SVG fix the part where we need to determine the background color in order to pick colors for the icons?
Comment 8 User image Stephen Horlander [:shorlander] 2014-02-04 13:29:25 PST
(In reply to :Gijs Kruitbosch from comment #7)
> How does using SVG fix the part where we need to determine the background
> color in order to pick colors for the icons?

It would cover the system theme case because we have corresponding system to choose from. e.g. -moz-appearance:menubar / background-color: -moz-MenuBarText

So we wouldn't have to determine anything.
Comment 9 User image Dão Gottwald [:dao] 2014-06-20 10:08:36 PDT
Created attachment 8443577 [details] [diff] [review]
remaining piece: the all tabs button

After bug 994623 and bug 637608, the all tabs button is the remaining affected piece. Images and CSS adopted from the Windows theme.
Comment 10 User image Dão Gottwald [:dao] 2014-06-20 10:15:40 PDT
Marco, could you please add this to the current iteration?
Comment 11 User image Marco Mucci [:MarcoM] 2014-06-20 10:48:05 PDT
Added to Iteration 33.1
Comment 12 User image Mike de Boer [:mikedeboer] 2014-06-26 03:33:45 PDT
Comment on attachment 8443577 [details] [diff] [review]
remaining piece: the all tabs button

Review of attachment 8443577 [details] [diff] [review]:
-----------------------------------------------------------------

Alright, looks good to me!

Thanks Dão.

Apology for the review delay... many things on my plate atm.
Comment 13 User image Dão Gottwald [:dao] 2014-06-26 04:36:09 PDT
https://hg.mozilla.org/integration/fx-team/rev/4125eff7a185
Comment 14 User image Ryan VanderMeulen [:RyanVM] 2014-06-26 13:44:52 PDT
https://hg.mozilla.org/mozilla-central/rev/4125eff7a185
Comment 15 User image Cornel Ionce [QA] (:cornel_ionce) 2014-06-30 05:34:56 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0

Verified this issue as fixed using latest Firefox Nightly, build ID: 20140629030206 on Ubuntu 13.04 64bit.

Note You need to log in before you can comment on or make changes to this bug.