Closed Bug 994623 Opened 7 years ago Closed 6 years ago

Australis: Invert icons in the tabstrip and menubar on Ubuntu

Categories

(Firefox :: Theme, defect)

29 Branch
x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox 32
Tracking Status
firefox28 --- unaffected
firefox29 - affected
firefox30 - affected
firefox31 - affected

People

(Reporter: alice0775, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: ux-visual-hierarchy, Whiteboard: [Australis:P4+] fixed by bug 1012629)

Attachments

(2 files)

Attached image screenshot
Build Identifier:
https://hg.mozilla.org/releases/mozilla-beta/rev/71439d266704
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140407135746

Steps To Reproduce:
Move icon to tabstrip and menubar

Actual results:
Almost invisible
Severity: normal → major
Not tracking. Discussed with Gijs on IRC and it is blocked by GTK limitations.
I don't think we can fix this without either SVG icons or some way to check the background color of the menubar and/or tabstrip. I don't know that we have the latter. Anyway, marking in the Australis backlog so we get to this ASAP after we get 29 out the door.
Whiteboard: [Australis:P4+]
Updating the tracking flags wrt Gijs comment #2
Robert, do you know of a way to request the menubar/ tabstrip or window titlebar background color? I'm asking you, because I saw you (s-)r'd quite a number of GTK-related patches...

If we'd know this color value, we can set a property on the document when we're dealing with a dark background color (like on Ubuntu) and show inverted icons in that case.
Flags: needinfo?(roc)
Karl will know better
Flags: needinfo?(roc) → needinfo?(karlt)
I don't think we need to track this for 30/31, though we should fix it. We'll put it in the backlog.
Flags: firefox-backlog+
(In reply to Mike de Boer [:mikedeboer] from comment #4)
> do you know of a way to request the menubar/ tabstrip or window
> titlebar background color?

I'm guessing these colors come from -moz-appearance: toolbar.
I don't see anything in LookAndFeel::ColorID [1] that corresponds to this, though there is a eColorID__moz_menubartext for the foreground color.
There is not necessarily a single background color as the theme can draw the background in many ways.  Perhaps its better to use the text color as an indicator.

[1] http://hg.mozilla.org/mozilla-central/annotate/810c2b6a278d/widget/LookAndFeel.h#l25

> If we'd know this color value, we can set a property on the document when
> we're dealing with a dark background color (like on Ubuntu) and show
> inverted icons in that case.

Or perhaps the icons can be given sufficient borders so that they are visible on any background.

Or perhaps icons from the native theme can be used when the icons are on native toolbars.
Flags: needinfo?(karlt)
(In reply to Karl Tomlinson (:karlt, back May 5) from comment #7)
> (In reply to Mike de Boer [:mikedeboer] from comment #4)
> > do you know of a way to request the menubar/ tabstrip or window
> > titlebar background color?
> 
> I'm guessing these colors come from -moz-appearance: toolbar.

No, this is -moz-appearance: menubar.
Duplicate of this bug: 1008319
See Also: → 947356
Assignee: nobody → dao
Blocks: 947356
Depends on: 1012629
Whiteboard: [Australis:P4+] → [Australis:P4+] fixed by bug 1012629
Target Milestone: --- → Firefox 32
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
See Also: 947356
QA Whiteboard: [good first verify]
Attached image Icons
Build Identifier:
Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140710004005

As you can see in the attached screenshot, the icons in the menu bar are almost invisible, while the icons in the tabstrip are white.
(In reply to Teodora Vermesan (:TeoVermesan) from comment #10)
> Created attachment 8454359 [details]
> Icons
> 
> Build Identifier:
> Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
> ID:20140710004005
> 
> As you can see in the attached screenshot, the icons in the menu bar are
> almost invisible, while the icons in the tabstrip are white.

Please file a new bug.
Depends on: 1037411
You need to log in before you can comment on or make changes to this bug.