[User Story] Rocketbar: URL Bookmark Autocomplete

RESOLVED DUPLICATE of bug 948310

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 948310
4 years ago
4 years ago

People

(Reporter: pdol, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ucid:System77, 1.4:P2, ft:systems-fe])

(Reporter)

Description

4 years ago
User Story:
As a user, I want Rocketbar to autocomplete partial URLs that I enter for websites that I have bookmarked to make it much quicker to browse to my favorite sites.

Acceptance Criteria:
1. I can enter a partial string and my entry is autocompleted with the most relevant result from my bookmarks as is currently done in the Fennec Browser.
2. Pressing Return on the keyboard when an autocomplete result is displayed results in that page loading.

Assumptions: 
1. UX spec to clarify if this behavior is required. 
2. It is expected that the current Awesome Bar functionality is matched – that is, if there are multiple possible results, the autocomplete entry that is used is based on the existing algorithm.
(Reporter)

Updated

4 years ago
Blocks: 946452
I think this is a duplicate of bug 948310 as both history and bookmarks are "places" which is what is actually being autocompleted.

The only place I can think they might differ is if the UX spec specifies a different presentation for places.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 948310
You need to log in before you can comment on or make changes to this bug.