Closed Bug 948310 Opened 6 years ago Closed 6 years ago

[User Story] Rocketbar: Autocomplete

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: pdol, Unassigned)

References

Details

(Whiteboard: [ucid:System76, 1.4:P2, ft:systems-fe], [p=3])

User Story:
As a user, I want Rocketbar to autocomplete partial URLs that I enter for websites that I have visited in the past to make it much quicker to browse to sites I've previously visited.

Acceptance Criteria:
1. I can enter a partial string and my entry is autocompleted with the most relevant result from my history as is currently done in the Fennec Browser.
2. Pressing Return on the keyboard when an autocomplete result is displayed results in that page loading.

Assumptions: 
1. UX spec to clarify if this behavior is required. 
2. It is expected that the current Awesome Bar functionality is matched – that is, if there are multiple possible results, the autocomplete entry that is used is based on the existing algorithm.
Component: Gaia::System → Gaia::System::Browser Chrome
I *think* this is the right component, though the logic will be split between the system app and the search app. The search app will communicate the top result to the system app via the inter-app communications API and the Rocketbar in the system app will do the actual autocomplete.
Duplicate of this bug: 948312
No longer blocks: rocketbar-search-mvp
Duplicate of this bug: 948311
Autocomplete is not just for history results and not just for URLs, it may also be for app & bookmark results and include titles as well as URLs.
Summary: [User Story] Rocketbar: URL History Autocomplete → [User Story] Rocketbar: Autocomplete
Estimating as 3 points, just for the Browser Chrome part.
Whiteboard: [ucid:System76, 1.4:P2, ft:systems-fe] → [ucid:System76, 1.4:P2, ft:systems-fe], [p=3]
Component: Gaia::System::Browser Chrome → Gaia::Search
This has been removed from the spec for now. The reason being that the list of results serve the same purpose as the autocomplete would.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Blocks: 94645
No longer blocks: rocketbar-search-mvp
No longer blocks: 94645
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.