Closed Bug 948596 Opened 9 years ago Closed 9 years ago

[B2G][Gallery][Wallpaper] Wallpaper preview-page through the Gallery app has a gap on the top of the screen

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, firefox28 fixed, firefox29 fixed, b2g18 unaffected, b2g-v1.1hd unaffected, b2g-v1.2 unaffected, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
firefox28 --- fixed
firefox29 --- fixed
b2g18 --- unaffected
b2g-v1.1hd --- unaffected
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed

People

(Reporter: nkhristoforov, Assigned: alive)

References

Details

(Keywords: regression, Whiteboard: burirun1.3-1 [FT:System-Platform])

Attachments

(3 files)

Attached image Screenshot
When the user tries to change the wallpaper through the Gallery share option, a gap appears at the top of the page on the Wallpaper preview-page. The user can see the "Back" button on the previous screen through the gap and is able to select it. 

Repro Steps:
1) Updated Buri v1.3 to BuildID: 20131210004003
2) Make sure the Gallery app has images.
3) Open the Gallery app and select an image.
4) Select the Share button and select the Wallpaper option.
5) Verify the preview-page has a gap on the top.

Actual:
There is a gap on the top of the preview-page.

Expected:
The wallpaper preview image would take up the whole screen.

Environmental Variables:
Device: Buri v1.3 Moz RIL
BuildID: 20131210004003
Gaia: 3452fbdb5e1bed0cd27cc6173136537a03e8072f
Gecko: e0c328d99742
Version: 28.0a2
RIL Version: 01.02.00.019.102
Firmware Version: V1.2_20131115

Repro frequency: 100%
See attached: Screenshot and Logcat
Attached file Logcat
This bug does not repro on the latest 1.1 and 1.2 builds. The Wallpaper preview images take up the whole page.

Device: Buri v1.1 Moz RIL
BuildID: 20131210041202
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Gecko: 05117f42088f
Version: 18.0

Device: Buri v1.2 Moz RIL
BuildID: 20131210004008
Gaia: 3bede56043379283cb0f6673730f91be88018d13
Gecko: e535d93d88ad
Version: 26.0
This looks like a window manager bug.
blocking-b2g: --- → 1.3?
Component: Gaia::Gallery → Gaia::System::Window Mgmt
Whiteboard: burirun1.3-1 → burirun1.3-1 [FT:System-Platform]
QA Contact: nkhristoforov
The regression window for this bug is 10-31 to 11-01.

Last Working Build:
Device: (example: Buri v1.2 Mozilla RIL)
BuildID: 20131031040201
Gaia: 412fd463bcb81f0e8bebf6d32500d0c02712748d
Gecko: f0d363d72753
Version: 28.0a1

First Broken Build:
Device: Buri v1.3 Moz RIL
BuildID: 20131101040203
Gaia: ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
Gecko: abe6790a5dd8
Version: 28.0a1
Triage: regression.

Alive, please help on this issue.
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(alive)
Taken
Assignee: nobody → alive
Flags: needinfo?(alive)
On it.
Root cause: ActivityWindow doesn't copy size from parent when inited.
Override isFullScreen to make ActivityWindow happy live
Attachment #8347082 - Flags: review?(timdream)
Attachment #8347082 - Flags: review?(timdream) → review+
master

https://github.com/mozilla-b2g/gaia/commit/888f9df5515a47d2f5806efee77485e05e1e5416
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Depends on: 950136
comment 9 was backed out

[master 30a2d7f] Revert "Merge pull request #14632 from alivedise/bugzilla/948596_v2/activity-window-size-copy"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Backed out specifically for causing bug 950136.
(In reply to Jason Smith [:jsmith] from comment #11)
> Backed out specifically for causing bug 950136.

Apparently this wasn't caused by bug 950136. Hmm...there's something weird going on here.
Reland
https://github.com/mozilla-b2g/gaia/commit/acca1e61a03de1dbff0da325870a672b01ec6327
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
No longer depends on: 950136
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x -m1 acca1e61a03de1dbff0da325870a672b01ec6327
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(alive)
I will land manually.
Flags: needinfo?(alive)
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
Duplicate of this bug: 933572
Duplicate of this bug: 957481
You need to log in before you can comment on or make changes to this bug.