[CDMA] Settings supplementary services (SS) broken

RESOLVED FIXED in Firefox OS v1.4

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: m4, Assigned: arthurcc)

Tracking

unspecified
1.4 S4 (28mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

(Whiteboard: [cr 588549] [ETA: 3/28], URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
In CDMA, SS are performed via dial strings sent to the network as normal phone calls.  Although settings could initiate calls to perform SS operations, the lack of feedback from the NW results in a poor UX.  Please consider removing these supplementary service items from the Settings app.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 1.3?
Triage: We need a step to reproduce here. Flagging UX for consideration.
Flags: needinfo?(mschwart)
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 2

5 years ago
What M4 meant is to remove the CLIR and the call forwarding settings option from the UI for CDMA.

Comment 3

5 years ago
Flagging Neo on Settings.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(nhsieh)
(Reporter)

Comment 4

5 years ago
Steps to reproduce:
# Connect to a CDMA network
# Go to Settings app

Seen:
# GSM SS is available

Expected:
# GSM SS not visible
Flags: needinfo?(mschwart)

Comment 5

5 years ago
Hi. Is this caused by non-config file build ?
Flags: needinfo?(nhsieh) → needinfo?(mschwart)
(Reporter)

Comment 6

5 years ago
Sorry for the delay, on vacation.  Not sure what you mean by "non-config file build".  How can I check?
Flags: needinfo?(mschwart) → needinfo?(nhsieh)

Comment 7

4 years ago
last time I heard about this problem is caused by non-config file build. Means if user use CDMA device, system will hide GSM options. But for global version that will shows all optins (CDMA & GSM...) . 

And Tim discussed this topic with Gecko team, they will fix it. but I don't know if this can resolve this bug ?
Flags: needinfo?(nhsieh) → needinfo?(timdream)
You are confusing this issue with bug 950185 :'( This has nothing to do with that.
Flags: needinfo?(timdream) → needinfo?(nhsieh)
(Reporter)

Comment 9

4 years ago
Hi Neo, note that instead of removing the items, as recommended above, we could simply disable them if the current network type is CDMA.

Comment 10

4 years ago
Hi Enpei, Please help to doulble confirm that was caused by non-config file build problem then we can resolve it.
Flags: needinfo?(nhsieh) → needinfo?(echu)
Let me jump into the discussion here please. This is not caused by not having the config file in the build but the code itself. I mean some supplementary services such as the CLIR and the call forwarding settings have to be removed/hidden or whatever for CDMA devices (per comment #2) and as today we don't do that. So it this is needed we have to touch the code a bit.
José, does hide/show the menu depend on knowing the device capability? For example, only hide the entry if this is a CDMA-only phone ...
Flags: needinfo?(josea.olivera)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #12)
> José, does hide/show the menu depend on knowing the device capability? For
> example, only hide the entry if this is a CDMA-only phone ...

The setting app (call setting panel) shows/hides some menu item relaying on the telephony technology underneath (GSM, CDMA) such as voice privacy settings but not the CLIR and the call forwarding settings options.
Flags: needinfo?(josea.olivera)

Comment 14

4 years ago
This bug is duplicated to 950185 bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 950185

Comment 15

4 years ago
About UX wording, Please refer to https://bugzilla.mozilla.org/show_bug.cgi?id=950185
(In reply to Neo Hsieh from comment #14)
> This bug is duplicated to 950185 bug.
> 
> *** This bug has been marked as a duplicate of bug 950185 ***

IHMO this is not a duplicated of 950185 bug.

Updated

4 years ago
Flags: needinfo?(echu)
Going to reopen for tracking per comment 16
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Is this a regression from 1.2?
blocking-b2g: 1.3? → 1.3+
(In reply to Andrew Overholt [:overholt] from comment #18)
> Is this a regression from 1.2?

Not at all, somehow a new request.
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #19)
> (In reply to Andrew Overholt [:overholt] from comment #18)
> > Is this a regression from 1.2?
> 
> Not at all, somehow a new request.

Ah, that was the reason for 1.3+.  I'll move it back to a nom and ask Michael why he nommed it.
blocking-b2g: 1.3+ → 1.3?
Flags: needinfo?(mschwart)
(Reporter)

Comment 21

4 years ago
I think this bug is related to https://bugzilla.mozilla.org/show_bug.cgi?id=950185 but not necessarily a duplicate.  950185 is about what UX support be be there regardless of underlying phone support.  This CR is about what UX support will be there in different service state scenarios ie GSM SS Settings options should not be available while we have CDMA service.
Flags: needinfo?(mschwart)
Bug 952043 provides an API for checking the supported network types of the device. We should waiting for bug 952043 in order to have a solid fix.
Depends on: 952043
Hsin-yi, based on my understanding only roaming preference and voice privacy are limited to CDMA devices. Other call settings such as call forwarding should be supported by both CDMA and GSM devices. Could you help clarify what is GSM supplementary service?
Flags: needinfo?(htsai)

Updated

4 years ago
Duplicate of this bug: 941532
Hi Arthur,

In CDMA, we should hide the followings:
Call waiting, Caller ID and Call forwarding. 

As previous comments said, these supplementary features are supported by the network but user need to contact customer services by dialing a operator-specified string. It's unable to have UI menu for those settings.

In GSM, we should hide:
voice privacy mode and roaming preference while these two are CDMA limited features.

And regarding FDN... though as Enpei mentioned in bug 941532 comment#0, it's not normal on CDMA networks, FDN is, however, a SIM/ICC/UICC function, not related to network types. So, we don't hide this as default on CDMA product.

Hi m4 and jaoo,
Please let me know if we are still missing something. :)
Flags: needinfo?(htsai)
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #25)

> Hi m4 and jaoo,
> Please let me know if we are still missing something. :)

Cristal clear, thanks Hsin-Yi.

I will be happy to take the bug and work on it once bug 952043 gets landed (if nobody else is going to work on it).

Comment 27

4 years ago
CDMA is not advertised on 1.3 so marking it not blocking for 1.3
blocking-b2g: 1.3? → ---
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #25)
> In GSM, we should hide:
> voice privacy mode and roaming preference while these two are CDMA limited
> features.
> 

We should still land this on 1.3 or otherwise this will be a regression for GSM-only phones (dead feature being present in the settings).

José, I won't stop you if you want to fix this :) however you own too many 1.3+ bugs so I would advice you to make sure all of them could be addressed on time before taking another one.
blocking-b2g: --- → 1.3?
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #28)

> José, I won't stop you if you want to fix this :) however you own too many
> 1.3+ bugs so I would advice you to make sure all of them could be addressed
> on time before taking another one.

Yes, I meant to take this bug if nobody else wants to take once I finish all 1.3+ I own.
Minus for now. please renom if needed.
blocking-b2g: 1.3? → ---
Whiteboard: [cr 588549]

Comment 31

4 years ago
Requesting for 1.4 as this bug will improve the UI for CDMA voice call settings for 1.4.
blocking-b2g: --- → 1.4?

Updated

4 years ago
Blocks: 960372

Comment 32

4 years ago
Ivan, you may need to have someone into this bug.
Flags: needinfo?(itsay)
1.4+ for QC CS
blocking-b2g: 1.4? → 1.4+

Comment 34

4 years ago
(In reply to Ken Chang[:ken] from comment #32)
> Ivan, you may need to have someone into this bug.

Hi Ken,

Per discussion with Arthur, our gecko and gaia parts are ready to get the network type in order to show the correct supplementary service setting for CDMA or GSM. Please refer to the comment 63 in bug 952043 and ask our partner to add the similar property to see if the setting can be displayed correctly.
Flags: needinfo?(itsay) → needinfo?(kchang)

Comment 35

4 years ago
(In reply to Ivan Tsay (:ITsay) from comment #34)
> partner to add the similar property to see if the setting can be displayed
> correctly.
If device support world mode(GSM+CDMA), how do we handle this? Can we base on current network type to decide setting mane?
Flags: needinfo?(kchang)
Flags: needinfo?(itsay)
Flags: needinfo?(arthur.chen)
No, this case is not handled. The menu does not change on the fly.
Flags: needinfo?(arthur.chen)
Flags: needinfo?(itsay)
Assignee: nobody → arthur.chen

Comment 37

4 years ago
After offline discussing with Michael and Anshul, we don't need to fix this bug before 3/14. But we have to fix this bug before 3/28.
Whiteboard: [cr 588549] → [cr 588549] [ETA: 3/28]
Target Milestone: --- → 1.4 S4 (28mar)
Thanks Ken.
Flags: needinfo?(kchang)

Updated

4 years ago
Flags: needinfo?(kchang)

Comment 39

4 years ago
(In reply to Ken Chang[:ken] from comment #37)
> After offline discussing with Michael and Anshul, we don't need to fix this
> bug before 3/14. But we have to fix this bug before 3/28.
Need by date of 3/28 is okay.

Updated

4 years ago
Blocks: 984663

Updated

4 years ago
No longer blocks: 960372
Created attachment 8394012 [details]
WIP

Jose, could you have a look on the patch to see if it makes sense to you? I tried to show/hide the menus when connected network type changes, and then call to corresponding update functions. The update function early returns if the UI is hidden.

I only finished the part of call settings, will continue to add similar logic for data roaming.
Attachment #8394012 - Flags: feedback?(josea.olivera)
Comment on attachment 8394012 [details]
WIP

Hi Jose, sorry for all the patches.

I've finished the part of network operator settings and tested it on Inari(GSM) and Wasabi(CDMA) phones. Because I don't have world phones in hand, I will ask QA to see if the partner is able to test the patch for us. Thanks for your great help!
Attachment #8394012 - Flags: feedback?(josea.olivera) → review?(josea.olivera)

Comment 42

4 years ago
I will run some tests on Monday on a world mode phone and get back with the results.
Anshul, is there any chance a device to report a network voice type change (gsm/cdma) on the fly?, is that supposed to happen on an aforementioned world mode phone?
Flags: needinfo?(anshulj)
Anshul, I'm wondering also if FDN should be hidden for CDMA phones. Could you shed some light into it please? Thanks.
Comment on attachment 8394012 [details]
WIP

Arthur, thanks for the patch. Left some comments on the PR. Could you take a look a it please? Thanks!
Attachment #8394012 - Flags: review?(josea.olivera)

Comment 46

4 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #43)
> Anshul, is there any chance a device to report a network voice type change
> (gsm/cdma) on the fly?, is that supposed to happen on an aforementioned
> world mode phone?

Jose, yes a world mode phone can change the network from gsm/cdma on the fly if for example user selected a different network type. Let me find information about FDN and get back in some time.
Flags: needinfo?(anshulj)

Comment 47

4 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #44)
> Anshul, I'm wondering also if FDN should be hidden for CDMA phones. Could
> you shed some light into it please? Thanks.
Antonio, FDN is radio tech independent feature and so should be available for both GSM and CDMA family of radio techs.

Comment 48

4 years ago
Antonio and Arthur, I pulled in the patch and below are my observations.

What worked
1. With a SIM card with device registered on the network I am able to see GSM options correctly. 
2. With a SIM card with both USIM and RUIM app switching the network to CDMA now shows CDMA options on the fly.

What didn't work
3. If phone doesn't have service there are no data call and voice call settings specific to either GSM or CDMA that are shown even though the network selected is GSM and there is a SIM card present. The only Network Operator option I see in this case is Network Type and Call Setting is Voicemail and FDN. 
4. GSM settings disappeared when radio tech reported is hspa. I left a note in github pointing to the issue.
5. Once I saw that the Gaia wasn't making a request to get individual call settings from RIL. Due to the issue #4 I am finding it hard to reproduce the bug. I will fix that locally and reproduce this tomorrow.
Thanks for the test result.

(In reply to Anshul from comment #48)
> Antonio and Arthur, I pulled in the patch and below are my observations.
> 
> What worked
> 1. With a SIM card with device registered on the network I am able to see
> GSM options correctly. 
> 2. With a SIM card with both USIM and RUIM app switching the network to CDMA
> now shows CDMA options on the fly.
> 
> What didn't work
> 3. If phone doesn't have service there are no data call and voice call
> settings specific to either GSM or CDMA that are shown even though the
> network selected is GSM and there is a SIM card present. The only Network
> Operator option I see in this case is Network Type and Call Setting is
> Voicemail and FDN.
This is the current implementation whereas I'm not sure the correct behavior. If the connected voice type is unknown, the best choice seems to hide both CDMA and GSM options. Or I should ignore the change to no service, so that it keeps the last option?
 
> 4. GSM settings disappeared when radio tech reported is hspa. I left a note
> in github pointing to the issue.
Ok, I'll fix this.

> 5. Once I saw that the Gaia wasn't making a request to get individual call
> settings from RIL. Due to the issue #4 I am finding it hard to reproduce the
> bug. I will fix that locally and reproduce this tomorrow.
Patch updated. Will request a review when everything works well.
Status: REOPENED → ASSIGNED
Anshul, could you help test the patch again? Thanks!
Flags: needinfo?(anshulj)

Comment 52

4 years ago
I tested the latest patch and it seems to be working fine. Thanks for providing the fix.
Flags: needinfo?(anshulj)
Comment on attachment 8394012 [details]
WIP

Thanks anshul!

Jose, mind take a look at it again? Thanks!
Attachment #8394012 - Flags: review?(josea.olivera)
Comment on attachment 8394012 [details]
WIP

Arthur, thanks for the patch. I left a comment on the PR, please take a look. I've tested the patch on peak and everything seems to work correctly. I don't have a global phone to test the patch properly but Anshul does and told us everything works correctly (see comment #c52) so that's great (thanks Anshul). 

r=me
Attachment #8394012 - Flags: review?(josea.olivera) → review+
Jose, the line has been removed as you suggested, thanks!

master: 8697ff1031861b680140b96badfe37833fd21043
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → fixed
Resolution: --- → FIXED
Travis passed (https://github.com/mozilla-b2g/gaia/pull/18141)

v1.4: 4405ba39da4ffdabc9a7eb1c95a2a33b96b7e8c3
status-b2g-v1.4: affected → fixed

Updated

4 years ago
Depends on: 1022710

Comment 58

4 years ago
test case needs to be written for this
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(rmitchell)
Test case added to moztrap:

https://moztrap.mozilla.org/manage/case/14336/
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(rmitchell)
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.