Closed Bug 951290 Opened 6 years ago Closed 6 years ago

[B2G] [Browser] The first swipe after zooming has no effect

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
blocking-b2g 1.3+
Tracking Status
firefox27 --- unaffected
firefox28 --- fixed
firefox29 --- fixed
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed

People

(Reporter: ckreinbring, Assigned: vingtetun)

References

Details

(Whiteboard: [apz_testrun])

Attachments

(3 files)

Description:
After zooming in or out of a webpage, the first swipe made by the user to scroll the screen will be ignored.  The second and subsequent swipes do work normally.

Repro Steps:
1) Update Buri to Build ID: 20131216140918
2) Launch the Browser and navigate to a site that allows zooming (eg google.com).
3) Once the page loads, spread your fingers on the screen to zoom in.
4) Make a swipe gesture and observe the device's reaction.
5) Pinch your fingers on the screen to zoom back out to the original zoom.
6) Make a swipe gesture and observe the device's reaction.

Expected Results:
Making a swipe gesture after zooming in or out will scroll the screen in the direction of the swipe.

Actual Results:
Making a swipe gesture after zooming in or out does nothing.  A second swipe will work normally.

Additional Notes:
See attached video and logcat logs.
Occurs regardless of the APZ setting.

Environmental Variables:
Build : 
Gaia      504cf9a988cd84760b4040706ccc41e508a97fd2
Gecko     55b75ce2263e7d2a8cbfdabc7e5206d9caa89f98
BuildID   20131216140918
Version   28.0a2
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013
RIL Type : Mozilla RIL
OS Version: 1.3
Device: Buri
Blocks: gaia-apzc
Do you know if this is a regression or if it happens in the browser in 1.2 ?
(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #3)
> I wonder if this is a dupe of bug 951321?

Not the same root cause :/
Seems like the swipe gesture is in state 8. Like if we are still pinching.
Component: Gaia → Panning and Zooming
Product: Firefox OS → Core
Attachment #8349340 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/36ab8519a74c
Assignee: nobody → 21
Status: NEW → ASSIGNED
blocking-b2g: --- → 1.3+
Target Milestone: --- → mozilla28
https://hg.mozilla.org/mozilla-central/rev/36ab8519a74c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: mozilla28 → mozilla29
You need to log in before you can comment on or make changes to this bug.