Closed Bug 951436 Opened 6 years ago Closed 6 years ago

[B2G][WAP Push][Notification][Settings] APN settings are not stored in settings once received

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

VERIFIED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: lmauritson, Assigned: jaoo)

References

()

Details

(Whiteboard: burirun1.3-1)

Attachments

(5 files)

Description:
APN Settings accepted via WAP push messages will not show in the settings menu and cannot be selected.

Prerequisite: Using NowSMS(http://www.nowsms.com/) to send WAP Push messages to device.

Repro Steps: (Or see linked test cases)
1) Update a Buri to BuildID: 20131213004002

2) Enable WAP Push in Settings > Message setting on DUT.

3) Open NowSMS on PC, go to "OMA provisioning content". Fill in following items (please refer to the carrier's settings of your SIM card, following example is for CHT in Taiwan.) then send to DUT. 
   A.) Connection Type: GPRS 
   B.) Settings Name: CHT_emome 
   C.) GPRS Access Point Name: emome 
   D.) WAP Proxy IP Address : 10.1.1.1 
   E.) WAP Proxy Port: 8080 
   F.) Home Page URL: http://wap.emome.net/ 
   G.) OTA PIN:1234 
   H.) OTA PIN Type: Check User PIN

>>CP message is received with a configuration message notification.

4) Open the message.

>>A page required PIN code is opened.

5) Enter the PIN code and press Accept button.

>> Confirmation message with setting name "CHT_emome" shows(depending on the Settings Name you enter in step 2.)

6) Press "Store".

>>Successful message will be shown.

7) Go to Settings > Cellular & Data > Data settings on DUT.




Actual:
A message will prompt the user to store the new APN info but CHT_emome is not present in the settings menu. No new profiles can be seen.

Expected:
New profile (CHT_emome in this case) is created.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20131213004002
Gaia: 888f9df5515a47d2f5806efee77485e05e1e5416
Gecko: dfae9c83bfbc
Version: 28.0a2
RIL Version: 01.02.00.019.102
Firmware Version: V1.2_20131115


Notes: v1.2 does not receive the message at all.

Repro frequency: 100%
Link to failed test case:
https://moztrap.mozilla.org/manage/case/10628/
https://moztrap.mozilla.org/manage/case/10629/
Does this reproduce on 1.2?
Keywords: qawanted
As noted above v1.2 does not receive these OMA Provisioning Content (OMA OTA Settings) pushes at all, though it does receive regular WAP Pushes.
I've been told that it should be appearing in 1.2, though not in 1.1, is this correct?
Keywords: qawanted
Enpei - Can you triage this?
Flags: needinfo?(echu)
(In reply to Lionel Mauritson from comment #2)
> As noted above v1.2 does not receive these OMA Provisioning Content (OMA OTA
> Settings) pushes at all, though it does receive regular WAP Pushes.
> I've been told that it should be appearing in 1.2, though not in 1.1, is
> this correct?

This feature only landed in v1.3.
Flags: needinfo?(echu)
Hi Lionel,

Actually I cannot reproduce the bug on latest build. I can see new saved setting in Data setting right after I store the APN.
Buri
Gaia      a99b23e73fe5630a877004746d0e7fcec1b6d653
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/369bdbff6c38
BuildID   20131218004002
Version   28.0a2
ro.build.version.incremental=291

Could you try again with this build? If still fail, could you attach logcat log?
Flags: needinfo?(lmauritson)
Hi all,

I found the bug as well on Buri. It's 1.3? bug for sure. Something might break again from 1218 to 1222.

Gaia      5d31cfb04081605a5c4cddd97022ed3210e9bdd0
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/6c6fd43f57a4
BuildID   20131222004001
Version   28.0a2

Thanks.
blocking-b2g: --- → 1.3?
Flags: needinfo?(lmauritson)
Attached file time stamp: 14:23.
(In reply to Enpei from comment #7)
> Created attachment 8351123 [details]
> time stamp: 14:23.

14:23 open the message and accept it.
Switching component: this is related to WAP Push, an 1.3 Comms feature.
Component: Gaia::Settings → Gaia::System
Flags: needinfo?(jcheng)
Component: Gaia::System → Gaia
I believe this is tracked under the RIL team
Flags: needinfo?(jcheng) → needinfo?(whuang)
Hi Chuck, 
From comment 6 it seems like a regression. Do you know who would be the best person to take a look?
Flags: needinfo?(whuang) → needinfo?(chulee)
Hi Gabriele,

Can you help to check this bug?

Thanks.
Flags: needinfo?(gsvelto)
There is a object structure change in gecko(bug 947814) and corresponding gaia fix(bug 947826).
It seems 1.3 is using gaia-master, but bug 947814 is not landed into 1.3 gecko.
I think it's the cause of this bug.

A uplift of bug 947814 could do the work.
Flags: needinfo?(chulee)
(In reply to Enpei from comment #12)
> Can you help to check this bug?

I think that the missing patch mentioned by Chuck in comment 13 might be the solution you're looking for.

Alternatively the content provisioning code was written by Jose Antonio Olivera Ortega (:jaoo josea.olivera@gmail.com); he's certainly more knowledgeable than me about it so you might ask him if uplifting bug 947814 is not enough to fix the problem.
Flags: needinfo?(gsvelto)
Update latest status on Buri
Gaia      ae7d05689b6b9ac4ec6182217dfdef06be28e886
Gecko     04ee7a80ffcff5bdc03338b37ed1cc3b693c302e
BuildID   20140103161831
Version   28.0a2

Now after entering correct User PIN, it only leads to a page with only "OTA Access Point Configuration" message on it and a Finish button below, after press the button, nothing is saved still. UI is wrong at all which is worse than last build I tried.
(In reply to Enpei from comment #15)
> Now after entering correct User PIN, it only leads to a page with only "OTA
> Access Point Configuration" message on it and a Finish button below, after
> press the button, nothing is saved still. UI is wrong at all which is worse
> than last build I tried.

This is very strange, there's been no changes since November AFAIK. Jose can you help us out with this?
Flags: needinfo?(josea.olivera)
Attached image for comment 15
After discussed with Chucklee, the build I used today is built from my own repository with BRANCH=v1.3 ./config.sh hamachi command. And he said that both gaia and gecko are from v1.3 branch.
(In reply to Enpei from comment #18)
> After discussed with Chucklee, the build I used today is built from my own
> repository with BRANCH=v1.3 ./config.sh hamachi command. And he said that
> both gaia and gecko are from v1.3 branch.

BRNACH=v1.3 will set gecko and gaia into v1.3 branch, which only patch for gecko(bug 947814) is uplifted while patch for gaia(bug 947826) is not.

I originally thought gaia used in comment 6 is on master branch, but seems I made a mistake and it's also using gaia-v1.3. :(
Can anyone verify that?

If so, then object structure change in bug 947814 is not the cause of this bug, 
It need to be backed out(or uplift bug 947826) to sync the object structure between gecko and gaia.
Just a guess, maybe related to the support for DSDS in settings?
Go for it, I'll take care of it.
Flags: needinfo?(josea.olivera)
Assignee: nobody → josea.olivera
Just fyi, the problem is reproduced in latest 1.3 and master builds:

1.3:
Gecko-118cfbe
Gaia-ff5f06d

master:
Gecko-93fd08c
Gaia-1584816

As reported, the wap push message is received but the settings are not stored.
We must do a couple of things for having OMA CP support working correctly for v1.3. First one is to uplift bug 947814 to Gaia v1.3 branch. Second one is to touch a bit the logic for storing/loading the APNs from both WAP Push and Setting app due the DSDS support added for v1.3 release. This bug will be focused on the second one. I'll request uplift for bug 947814 once I have a path for this bug.
Attached patch 951436.patchSplinter Review
We need to know the MCC and MNC codes for the ICC card before storing the APN into the database. Since the format of the setting where those codes are stored has changed (due the changes added for multi ICC card devices) we need to change a bit the logic in the WAP PUSH app as well. Gabriele, this patch fixes the issue could you take a look please? Thanks.
Attachment #8356567 - Flags: review?(gsvelto)
Comment on attachment 8356567 [details] [diff] [review]
951436.patch

Review of attachment 8356567 [details] [diff] [review]:
-----------------------------------------------------------------

All good with the comment nit addressed :) If Travis is green merge at will.

::: apps/wappush/js/store.js
@@ +36,4 @@
>        return;
>      }
>  
> +    // TODO: Bug 947198

Nit: we would usually use XXX instead of TODO
Attachment #8356567 - Flags: review?(gsvelto) → review+
Thanks Gabriele!

Landed on Gaia master branch at:

https://github.com/mozilla-b2g/gaia/commit/b23813f55bb473cd015714f307a6f57166459d19


By landing this patch we fix the issues in master branch but we have to uplift both patches this one and the one from bug 947826 to v1.3 branch to have OMA CP working correctly on v1.3 release.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
blocking-b2g: 1.3? → 1.3+
John, could you please assit with the uplift to 1.3 ? Thanks in advance.
Flags: needinfo?(jhford)
Uplifted b23813f55bb473cd015714f307a6f57166459d19 to:
v1.3: 329aa07931749cb86871d8394ea15c2f33d8b4dc
Flags: needinfo?(jhford)
Verified on 01/10 v1.3 buri build:

Gecko-8f14407
Gaia-c3b1232

Message is received and settings are stored correctly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.