Long press on navigation buttons (i.e. back/forward) in app menu should bring up history list

VERIFIED FIXED in Firefox 40

Status

()

defect
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: mcomella, Assigned: mking, Mentored)

Tracking

(Blocks 1 bug)

unspecified
Firefox 40
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 verified, firefox41 verified, relnote-firefox 40+)

Details

(Whiteboard: [lang=java][good next bug])

Attachments

(1 attachment, 3 obsolete attachments)

Similar to the back button.

It seems bug 454880, which initially implemented this, did not implement this part of the feature (see bug 454880 comment 95).
Ian, can you confirm this is the expected behavior?
Flags: needinfo?(ibarlow)
Yes, it is. Speaking of expected behaviour, we still need to do some theming to this feature, in bug 847435 :)
Flags: needinfo?(ibarlow)
mcomella, is this a good mentor bug? Since we have the designs for bug 847435 done now, this should be easier.
Flags: needinfo?(michael.l.comella)
Currently, we show the history list for long press on the back button and long press on the tablet back/forward buttons. This is done via [1].

You should add the same functionality to the 3-dot menu in the browser toolbar. The place to start looking to add code is BrowserApp.onOptionsItemSelected.

[1]: https://mxr.mozilla.org/mozilla-central/source/mobile/android/base/toolbar/BrowserToolbarTabletBase.java?rev=086bd7b12b92#66
Mentor: michael.l.comella, vivekb.balakrishnan
Flags: needinfo?(michael.l.comella)
Summary: Long press on forward button in app menu should bring up forward history list → Long press on navigation buttons (i.e. back/forward) in app menu should bring up history list
Whiteboard: [lang=java][good next bug]

Updated

4 years ago
Duplicate of this bug: 1048970
Assignee

Comment 6

4 years ago
Hello, I'd like to take this bug with some mentoring. Thanks!
Sure thing, setting assignee
Assignee: nobody → mking
Status: NEW → ASSIGNED
Flags: needinfo?(michael.l.comella)
Hey again, Matt! Let me know if comment 4 does not have enough information to get you (and keep you!) going, or if you have any other questions!
Flags: needinfo?(michael.l.comella)
Assignee

Updated

4 years ago
Attachment #8592200 - Flags: review?(michael.l.comella)
Comment on attachment 8592200 [details] [diff] [review]
Long press on navigation buttons (i.e. back/forward) in app menu should bring up history list

Review of attachment 8592200 [details] [diff] [review]:
-----------------------------------------------------------------

Nice work, Matt! try above.
Attachment #8592200 - Flags: review?(michael.l.comella) → review+
Matt, if you'd like to work on something a bit more involved, perhaps bug 1105271 for some front-end tablet work or bug 1150983 for more back-end focused work.
Assignee

Comment 13

4 years ago
Updated after failing tests on Android 4.0 API11+ opt
Assignee

Updated

4 years ago
Attachment #8592200 - Attachment is obsolete: true
Assignee

Comment 14

4 years ago
Comment on attachment 8593926 [details] [diff] [review]
Long press on navigation buttons (i.e. back/forward) in app menu should bring up history list

Looks like some tests failed for Android 4.0 API11+ opt, so I submitted an updated patch.
Attachment #8593926 - Flags: review?(michael.l.comella)
Comment on attachment 8593926 [details] [diff] [review]
Long press on navigation buttons (i.e. back/forward) in app menu should bring up history list

Review of attachment 8593926 [details] [diff] [review]:
-----------------------------------------------------------------

D'oh - that getSelectedTab == null gets me more often than I'd like to admit. D:

try below!
Attachment #8593926 - Flags: review?(michael.l.comella) → review+
By the way, this latest patch needs to be rebased - do you mind taking care of that and reuploading the patch, Matt? Since you have an r+, you don't need to get another review.
Flags: needinfo?(mking)
Assignee

Updated

4 years ago
Attachment #8593926 - Attachment is obsolete: true
Assignee

Comment 19

4 years ago
Patch updated, let me know I need to do anything else. Meanwhile I'll pick up another bug that you mentioned.

Thanks so much for the help :mcomella!
Flags: needinfo?(mking)
Matt, it looks like there are some more try failures - do you mind taking a look?
Flags: needinfo?(mking)
Assignee

Updated

4 years ago
Attachment #8594720 - Attachment is obsolete: true
Assignee

Comment 22

4 years ago
Alright, another update submitted. Not sure how to see the next Try job (does it update automatically?)
Flags: needinfo?(mking)
(In reply to Matt King from comment #22)
> Alright, another update submitted. Not sure how to see the next Try job
> (does it update automatically?)

It has to be manually submitted via version control.

You can apply for try access (which I believe is level 1) at [1] if you'd like to make these pushes yourself. I'll vouch for you. :)

Let me know - if you don't want access right now, I can make the push for you. Otherwise, I'll wait and let you do it yourself!

[1]: https://www.mozilla.org/en-US/about/governance/policies/commit/
Flags: needinfo?(mking)
Assignee

Comment 24

4 years ago
Thanks Michael! I applied for access here: https://bugzilla.mozilla.org/show_bug.cgi?id=1157130

Let me know if you need anything else...
Flags: needinfo?(mking)
Vouched! Just waiting on the administrivia end...
Assignee

Comment 26

4 years ago
Okay, looks like I have an LDAP account, but not sure what to do next...
Assignee

Comment 28

4 years ago
Looks like a couple failed due to non-code reasons...I tried to retrigger but doesn't see to help.
(In reply to Matt King from comment #28)
> Looks like a couple failed due to non-code reasons...I tried to retrigger
> but doesn't see to help.

It worked for me! The retriggers do not replace previous failed runs but add runs to the right of the failed run. For example, you'll see 5 rc3 runs (one failed) and 3 rc6 runs (one failed).

Looks ready to check in!
Assignee

Comment 30

4 years ago
Ah, I didn't notice that. Thanks for the explanation. I'll go ahead and check in.
Assignee

Updated

4 years ago
Keywords: checkin-needed
Whiteboard: [lang=java][good next bug] → [lang=java][good next bug][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b4fd9967aa85
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [lang=java][good next bug][fixed-in-fx-team] → [lang=java][good next bug]
Target Milestone: --- → Firefox 40
Blocks: 1161073

Updated

4 years ago
Depends on: 1048969
Release Note Request (optional, but appreciated)
[Why is this notable]: Nice UI enhancement for users
[Suggested wording]: Long press on back/forward navigation buttons in app menu brings up history list
[Links (documentation, blog post, etc)]:
Load gmail.com, facebook.com, instagram.com, google.com, amazon.com in the same tab. 
Open app's menu, tap the back button one time and then long tap the forward button => A pop-up with the recent history is displayed with the focus on the current tab (google.com) and "amazon.com"
Open app's menu, tap once again the back button and long tap the forward button => the history list contains: the current tab (instagram.com), google.com and amazon.com.
So, verified as fixed using:
Device: Samsung S5 (Android 4.4.4)
Build: Firefox for Android 40.0a2 (2015-05-27) and Firefox for Android 41.0a1 (2015-05-26)
Status: RESOLVED → VERIFIED

Comment 35

2 years ago
No history on 54.0.1/OSX - maybe this needs to be reopened?
Hey cpohle – thanks for letting us know. This bug is for Firefox for Android but did you mean to file an issue on OS X (I'm guessing from from "54.0.1/OSX")? If so, please file a new issue or find an existing issue on OS X. Thanks!

Updated

2 years ago
See Also: → 1422089
You need to log in before you can comment on or make changes to this bug.