external api build bustage: ../../../mail/components/build/libmailcomps.a: No such file or directory

RESOLVED FIXED in Thunderbird 31.0

Status

Thunderbird
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Magnus Melin, Assigned: Magnus Melin)

Tracking

({regression})

unspecified
Thunderbird 31.0
All
Linux
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [external-api-bustage])

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

4 years ago
rm -f libxul.so
/opt/moz-objdir/mail/mozilla/_virtualenv/bin/python /opt/comm-central/src/mozilla/config/expandlibs_exec.py --depend .deps/libxul.so.pp --target libxul.so --uselist --  c++  -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIMMED -g -fno-omit-frame-pointer   -fPIC -shared -Wl,-z,defs -Wl,-h,libxul.so -o libxul.so  nsStaticXULComponents.o   -lpthread  -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id -B /opt/moz-objdir/mail/mozilla/build/unix/gold   -Wl,-rpath-link,/opt/moz-objdir/mail/mozilla/dist/bin -Wl,-rpath-link,/usr/local/lib    ../../media/kiss_fft/libmedia_kiss_fft.a ../../xpcom/build/libxpcom_core.a ../../modules/libpref/src/libmodules_libpref_src.a ../../intl/uconv/src/libintl_uconv_src.a ../../intl/build/libi18n.a ../../intl/unicharutil/util/internal/libintl_unicharutil_util_internal.a ../../netwerk/build/libnecko.a ../../extensions/auth/libextensions_auth.a ../../ipc/chromium/libipc_chromium.a ../../ipc/glue/libipc_glue.a ../../ipc/ipdl/libipc_ipdl.a ../../ipc/testshell/libipc_testshell.a ../../js/ipc/libjs_ipc.a ../../hal/libhal.a ../../intl/chardet/src/libintl_chardet_src.a ../../modules/libjar/libjar.a ../../modules/libjar/zipwriter/src/libmodules_libjar_zipwriter_src.a ../../storage/build/libstoragecomps.a ../../extensions/cookie/libextensions_cookie.a ../../extensions/permissions/libextensions_permissions.a ../../rdf/util/src/internal/librdf_util_src_internal.a ../../rdf/build/librdf.a ../../js/jsd/libjs_jsd.a ../../media/webrtc/signaling/signaling_sipcc/libsipcc.a ../../media/webrtc/signaling/signaling_ecc/libecc.a ../../media/mtransport/build/libmtransport.a ../../uriloader/base/liburiloader_base.a ../../uriloader/exthandler/liburiloader_exthandler.a ../../uriloader/prefetch/liburiloader_prefetch.a ../../parser/htmlparser/src/libhtmlpars.a ../../gfx/ycbcr/libgfx_ycbcr.a ../../gfx/src/libgfx_src.a ../../gfx/gl/libgfx_gl.a ../../gfx/thebes/libthebes.a ../../gfx/ipc/libgfx_ipc.a ../../image/build/libimglib2.a ../../image/decoders/icon/libimgicon.a ../../dom/bindings/libdom_bindings.a ../../dom/media/bridge/libdom_media_bridge.a ../../dom/plugins/base/libdom_plugins_base.a ../../dom/plugins/ipc/libdom_plugins_ipc.a ../../dom/ipc/libdom_ipc.a ../../widget/gtk/libwidget_gtk2.a ../../widget/gtkxtbin/libwidget_gtkxtbin.a ../../editor/txmgr/src/libeditor_txmgr_src.a ../../editor/composer/src/libeditor_composer_src.a ../../layout/build/libgklayout.a ../../layout/media/webrtc/libwebrtc.a ../../docshell/base/libdocshell_base.a ../../docshell/shistory/src/libdocshell_shistory_src.a ../../docshell/build/libdocshell_build.a ../../embedding/components/build/libembedcomponents.a ../../embedding/browser/build/libwebbrwsr.a ../../xpfe/appshell/src/libxpfe_appshell_src.a ../../extensions/universalchardet/src/xpcom/libuniversalchardet.a ../../accessible/src/atk/libaccessible_src_atk.a ../../accessible/src/base/libaccessible_src_base.a ../../accessible/src/generic/libaccessible_src_generic.a ../../accessible/src/html/libaccessible_src_html.a ../../accessible/src/xpcom/libaccessible_src_xpcom.a ../../accessible/src/xul/libaccessible_src_xul.a ../../tools/profiler/libtools_profiler.a ../../xpfe/components/windowds/libxpfe_components_windowds.a ../../xpfe/components/build/libappcomps.a ../../extensions/spellcheck/src/libspellchecker.a ../../security/manager/boot/src/libsecurity_manager_boot_src.a ../../security/manager/ssl/src/libsecurity_manager_ssl_src.a ../../security/manager/pki/src/libsecurity_manager_pki_src.a ../../toolkit/xre/libxulapp_s.a ../../toolkit/components/build/libtoolkitcomps.a ../../toolkit/components/remote/libtoolkit_components_remote.a ../../toolkit/components/commandlines/libtoolkit_components_commandlines.a ../../toolkit/components/diskspacewatcher/libtoolkit_components_diskspacewatcher.a ../../toolkit/components/filepicker/libtoolkit_components_filepicker.a ../../toolkit/components/mediasniffer/libtoolkit_components_mediasniffer.a ../../toolkit/components/perf/libtoolkit_components_perf.a ../../toolkit/components/places/libtoolkit_components_places.a ../../toolkit/components/reflect/libtoolkit_components_reflect.a ../../toolkit/components/telemetry/libtoolkit_components_telemetry.a ../../toolkit/components/ctypes/libtoolkit_components_ctypes.a ../../toolkit/components/autocomplete/libtoolkit_components_autocomplete.a ../../toolkit/components/satchel/libtoolkit_components_satchel.a ../../toolkit/devtools/server/libtoolkit_devtools_server.a ../../toolkit/identity/libtoolkit_identity.a ../../toolkit/system/unixproxy/libtoolkit_system_unixproxy.a ../../extensions/pref/autoconfig/src/libextensions_pref_autoconfig_src.a ../../services/crypto/component/libservices_crypto_component.a ../../startupcache/libstartupcache.a ../../js/ductwork/debugger/libjs_ductwork_debugger.a ../../other-licenses/snappy/libother-licenses_snappy.a ../../../mail/components/build/libmailcomps.a -Wl,-version-script,symverscript -L../../dist/bin -L../../dist/lib /opt/moz-objdir/mail/mozilla/dist/lib/libjs_static.a -L../../dist/bin -L../../dist/lib -lcrmf -lsmime3 -lssl3 -lnss3 -lnssutil3   -lXrender  ../../dist/lib/libmozsqlite3.a  /opt/moz-objdir/mail/mozilla/modules/zlib/src/libmozz.a ../../dist/lib/libgkmedias.a -lasound   -lrt -L../../dist/bin -L../../dist/lib -L/opt/moz-objdir/mail/mozilla/dist/lib -lnspr4 -lplc4 -lplds4 ../../dist/lib/libmozalloc.a -ldbus-glib-1 -ldbus-1 -lpthread -lrt -lgobject-2.0 -lglib-2.0   -lgtk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lfreetype -lfontconfig -lgdk-x11-2.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lpango-1.0 -lcairo -lgobject-2.0 -lglib-2.0     -lX11  -lXext  -lpangoft2-1.0 -lfreetype -lfontconfig -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lglib-2.0   -lXt -lgthread-2.0 -lfreetype   -lfontconfig    -ldl  -lrt     
Executing: c++ -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -fno-omit-frame-pointer -fPIC -shared -Wl,-z,defs -Wl,-h,libxul.so -o libxul.so /opt/moz-objdir/mail/mozilla/toolkit/library/tmpNGHq_7.list -lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id -B ../../build/unix/gold -Wl,-rpath-link,/opt/moz-objdir/mail/mozilla/dist/bin -Wl,-rpath-link,/usr/local/lib ../../xpcom/typelib/xpt/src/libxpt.a ../../intl/unicharutil/util/internal/libintl_unicharutil_util_internal.a ../../../mail/components/build/libmailcomps.a -Wl,-version-script,symverscript -L../../dist/bin -L../../dist/lib ../../dist/lib/libjs_static.a -L../../dist/bin -L../../dist/lib -lcrmf -lsmime3 -lssl3 -lnss3 -lnssutil3 -lXrender ../../dist/lib/libmozsqlite3.so -lasound -lrt -L../../dist/bin -L../../dist/lib -L/opt/moz-objdir/mail/mozilla/dist/lib -lnspr4 -lplc4 -lplds4 ../../dist/lib/libmozalloc.so -ldbus-glib-1 -ldbus-1 -lpthread -lrt -lgobject-2.0 -lglib-2.0 -lgtk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lfreetype -lfontconfig -lgdk-x11-2.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lpango-1.0 -lcairo -lgobject-2.0 -lglib-2.0 -lX11 -lXext -lpangoft2-1.0 -lfreetype -lfontconfig -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lglib-2.0 -lXt -lgthread-2.0 -lfreetype -lfontconfig -ldl -lrt
/opt/moz-objdir/mail/mozilla/toolkit/library/tmpNGHq_7.list:
    INPUT("nsStaticXULComponents.o")
    INPUT("../../media/kiss_fft/kiss_fft.o")
    INPUT("../../media/kiss_fft/kiss_fftr.o")
    INPUT("../../xpcom/build/PoisonIOInterposerStub.o")
    INPUT("../../xpcom/build/FileLocation.o")

[snip]

    INPUT("../../gfx/skia/Unified_cpp_gfx_skia13.o")
    INPUT("../../gfx/skia/Unified_cpp_gfx_skia14.o")
    INPUT("../../gfx/skia/Unified_cpp_gfx_skia15.o")
    INPUT("../../gfx/skia/Unified_cpp_gfx_skia16.o")

c++: error: ../../../mail/components/build/libmailcomps.a: No such file or directory
make[5]: *** [libxul.so] Error 1
make[5]: Leaving directory `/opt/moz-objdir/mail/mozilla/toolkit/library'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/opt/moz-objdir/mail/mozilla'
make[3]: *** [default] Error 2
make[3]: Leaving directory `/opt/moz-objdir/mail/mozilla'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/opt/moz-objdir/mail'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/opt/comm-central/src'
make: *** [build] Error 2

Comment 1

4 years ago
SeaMonkey doesn't have this problem because we always link our components as a separate external library. I don't know how mail components used to be linked before the introduction of FINAL_LIBRARY but I'm guessing it works the same way as import so you need to port the mailnews/import/build changes in bug 940204 to mail/components/build (possibly backing out the changes to mail/components/build made in bug 940204). If that's not your problem then I can't give you any other advice sorry.
(Assignee)

Comment 2

4 years ago
jcranmer, any ideas?

Just adding

ifdef MOZ_INCOMPLETE_EXTERNAL_LINKAGE
SHARED_LIBRARY_LIBS = ../../base/util/$(LIB_PREFIX)msgbsutl_s.$(LIB_SUFFIX)
endif

in mail/components/build/Makefile.in didn't help. (import had a MODULE_NAME there too, i have no idea about this stuff)

I didn't yet try to back out all the mail/components changes.
Blocks: 940204
Component: Build Config → Build Config
Keywords: regression
Product: MailNews Core → Thunderbird
(Assignee)

Updated

4 years ago
Flags: needinfo?(Pidgeot18)
(Assignee)

Comment 3

4 years ago
Backing out all mail/components changes from bug 940204 doesn't help either. Same error.
I think you want to alter mail/components/build/moz.build with an if statement in a similar way to what ldap/xpcom/src/moz.build has (near the end of file).
(Assignee)

Comment 5

4 years ago
Created attachment 8355197 [details] [diff] [review]
partly fix

Thx Mark, that and a few include changes makes it partly build. I actually get a running thunderbird with it... but I suppose not complete functionality. Errors below

l,-Bsymbolic -ldl
/opt/moz-objdir/mail/mail/components/build/tmpacq5dY.list:
    INPUT("nsMailComps.o")
    INPUT("../migration/src/nsMailProfileMigratorUtils.o")
    INPUT("../migration/src/nsNetscapeProfileMigratorBase.o")
    INPUT("../migration/src/nsProfileMigrator.o")
    INPUT("../migration/src/nsSeamonkeyProfileMigrator.o")
    INPUT("../shell/DirectoryProvider.o")
    INPUT("../shell/nsMailGNOMEIntegration.o")

../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsMailProfileMigratorUtils.o: requires dynamic R_X86_64_PC32 reloc against 'nsACString::RFindChar(char) const' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsMailProfileMigratorUtils.o: requires dynamic R_X86_64_PC32 reloc against 'nsACString::BeginReading() const' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsMailProfileMigratorUtils.o: requires dynamic R_X86_64_PC32 reloc against 'nsDependentCSubstring_external::nsDependentCSubstring_external(nsACString const&, unsigned int, unsigned int)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsMailProfileMigratorUtils.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsMailProfileMigratorUtils.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsACString::DefaultComparator(char const*, char const*, unsigned int)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsAString::BeginReading() const' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'vtable for nsCreateInstanceByContractID' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid_with_error(nsGetServiceByContractIDWithError const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'PL_DHashTableFinish' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_with_AddRef(nsISupports*)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_with_AddRef(nsISupports*)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'nsTArrayHeader::sEmptyHdr' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o: requires dynamic R_X86_64_PC32 reloc against 'PL_DHashTableInit' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid_with_error(nsGetServiceByContractIDWithError const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_with_AddRef(nsISupports*)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsSeamonkeyProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsSeamonkeyProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsDependentCSubstring_external::nsDependentCSubstring_external(nsACString const&, unsigned int, unsigned int)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsSeamonkeyProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsACString::Equals(nsACString const&, int (*)(char const*, char const*, unsigned int)) const' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsSeamonkeyProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'vtable for nsQueryArrayElementAt' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsSeamonkeyProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsSeamonkeyProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsSeamonkeyProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../migration/src/nsSeamonkeyProfileMigrator.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/DirectoryProvider.o: requires dynamic R_X86_64_PC32 reloc against 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/DirectoryProvider.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMArray_base::InsertObjectAt(nsISupports*, int)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/DirectoryProvider.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/DirectoryProvider.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMArray_base::~nsCOMArray_base()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/DirectoryProvider.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/nsMailGNOMEIntegration.o: requires dynamic R_X86_64_PC32 reloc against 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/nsMailGNOMEIntegration.o: requires dynamic R_X86_64_PC32 reloc against 'nsACString::SetLength(unsigned int)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/nsMailGNOMEIntegration.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid_with_error(nsGetServiceByContractIDWithError const&, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/nsMailGNOMEIntegration.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/nsMailGNOMEIntegration.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/nsMailGNOMEIntegration.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/../shell/nsMailGNOMEIntegration.o: requires dynamic R_X86_64_PC32 reloc against 'nsCOMPtr_base::begin_assignment()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: read-only segment has dynamic relocations
../../../mozilla/dist/include/mozilla/mozalloc.h:201: error: undefined reference to 'moz_xmalloc'
../../../mozilla/dist/include/mozilla/mozalloc.h:201: error: undefined reference to 'moz_xmalloc'
../../../mozilla/dist/include/mozilla/mozalloc.h:201: error: undefined reference to 'moz_xmalloc'
../../../mozilla/dist/include/mozilla/mozalloc.h:201: error: undefined reference to 'moz_xmalloc'
../../../mozilla/dist/include/nsISupportsImpl.h:56: error: undefined reference to 'PR_GetCurrentThread'
/opt/comm-central/src/mail/components/migration/src/nsMailProfileMigratorUtils.cpp:19: error: undefined reference to 'nsACString::RFindChar(char) const'
/opt/comm-central/src/mail/components/migration/src/nsMailProfileMigratorUtils.cpp:27: error: undefined reference to 'nsACString::ToInteger(tag_nsresult*, unsigned int) const'
/opt/comm-central/src/mail/components/migration/src/nsMailProfileMigratorUtils.cpp:43: error: undefined reference to 'nsACString::FindChar(char, unsigned int) const'
/opt/comm-central/src/mail/components/migration/src/nsMailProfileMigratorUtils.cpp:46: error: undefined reference to 'nsACString::DefaultComparator(char const*, char const*, unsigned int)'
/opt/comm-central/src/mail/components/migration/src/nsMailProfileMigratorUtils.cpp:46: error: undefined reference to 'nsACString::Equals(char const*, int (*)(char const*, char const*, unsigned int)) const'
/opt/comm-central/src/mail/components/migration/src/nsMailProfileMigratorUtils.cpp:75: error: undefined reference to 'NS_Free'
../../../../mozilla/dist/include/nsStringAPI.h:439: error: undefined reference to 'NS_CStringGetData'
../../../../mozilla/dist/include/nsStringAPI.h:492: error: undefined reference to 'NS_CStringGetData'
../../../../mozilla/dist/include/nsStringAPI.h:493: error: undefined reference to 'NS_CStringSetDataRange'
../../../../mozilla/dist/include/nsStringAPI.h:823: error: undefined reference to 'NS_StringContainerFinish'
../../../../mozilla/dist/include/nsStringAPI.h:847: error: undefined reference to 'NS_StringContainerInit2'
../../../../mozilla/dist/include/nsStringAPI.h:871: error: undefined reference to 'NS_CStringContainerInit'
../../../../mozilla/dist/include/nsStringAPI.h:872: error: undefined reference to 'NS_CStringCopy'
../../../../mozilla/dist/include/nsStringAPI.h:878: error: undefined reference to 'NS_CStringContainerInit'
../../../../mozilla/dist/include/nsStringAPI.h:879: error: undefined reference to 'NS_CStringSetData'
../../../../mozilla/dist/include/nsStringAPI.h:884: error: undefined reference to 'NS_CStringContainerFinish'
../../../../mozilla/dist/include/nsStringAPI.h:889: error: undefined reference to 'nsACString::BeginReading() const'
../../../../mozilla/dist/include/nsStringAPI.h:908: error: undefined reference to 'NS_CStringContainerInit2'
../../../../mozilla/dist/include/nsStringAPI.h:1242: error: undefined reference to 'NS_CStringContainerFinish'
../../../../mozilla/dist/include/nsStringAPI.h:1327: error: undefined reference to 'nsDependentCSubstring_external::nsDependentCSubstring_external(nsACString const&, unsigned int, unsigned int)'
../../../../mozilla/dist/include/nsCOMPtr.h:620: error: undefined reference to 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:851: error: undefined reference to 'nsCOMPtr_base::begin_assignment()'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:39: error: undefined reference to 'PR_GetCurrentThread'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:39: error: undefined reference to 'PR_GetCurrentThread'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:39: error: undefined reference to 'PR_GetCurrentThread'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:39: error: undefined reference to 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:62: error: undefined reference to 'nsINIParser::Init(nsIFile*)'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:72: error: undefined reference to 'nsACString::AppendInt(int, int)'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:74: error: undefined reference to 'nsINIParser::GetString(char const*, char const*, nsACString&)'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:79: error: undefined reference to 'nsINIParser::GetString(char const*, char const*, nsACString&)'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:85: error: undefined reference to 'nsINIParser::GetString(char const*, char const*, nsACString&)'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:92: error: undefined reference to 'NS_NewNativeLocalFile'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:255: error: undefined reference to 'CaseInsensitiveCompare(char const*, char const*, unsigned int)'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:255: error: undefined reference to 'nsACString::Equals(char const*, int (*)(char const*, char const*, unsigned int)) const'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:367: error: undefined reference to 'nsAString::AppendInt(int, int)'
/opt/comm-central/src/mail/components/migration/src/nsNetscapeProfileMigratorBase.cpp:389: error: undefined reference to 'nsAString::AppendInt(int, int)'
../../../../mozilla/dist/include/nsCOMPtr.h:1159: error: undefined reference to 'nsCOMPtr_base::begin_assignment()'
../../../../mozilla/dist/include/nsTArray.h:169: error: undefined reference to 'NS_DebugBreak'
../../../../mozilla/dist/include/nsTArray.h:208: error: undefined reference to 'moz_xrealloc'
../../../../mozilla/dist/include/nsTArray.h:212: error: undefined reference to 'moz_free'
../../../../mozilla/dist/include/nsStringAPI.h:608: error: undefined reference to 'nsACString::DefaultComparator(char const*, char const*, unsigned int)'
../../../../mozilla/dist/include/nsStringAPI.h:608: error: undefined reference to 'nsACString::Equals(char const*, int (*)(char const*, char const*, unsigned int)) const'
../../../../mozilla/dist/include/nsStringAPI.h:793: error: undefined reference to 'NS_StringContainerInit'
../../../../mozilla/dist/include/nsStringAPI.h:798: error: undefined reference to 'NS_StringContainerInit'
../../../../mozilla/dist/include/nsStringAPI.h:799: error: undefined reference to 'NS_StringCopy'
../../../../mozilla/dist/include/nsStringAPI.h:828: error: undefined reference to 'nsAString::BeginReading() const'
../../../../mozilla/dist/include/nsStringAPI.h:859: error: undefined reference to 'NS_CStringContainerInit'
../../../../mozilla/dist/include/nsStringAPI.h:1032: error: undefined reference to 'NS_CStringToUTF16'
../../../../mozilla/dist/include/nsStringAPI.h:1425: error: undefined reference to 'NS_CStringCloneData'
../../../../mozilla/dist/include/mozilla/mozalloc.h:225: error: undefined reference to 'moz_free'
../../../../mozilla/dist/include/mozilla/mozalloc.h:225: error: undefined reference to 'moz_free'
../../../../mozilla/dist/include/nsComponentManagerUtils.h:64: error: undefined reference to 'vtable for nsCreateInstanceByContractID'
../../../../mozilla/dist/include/nsCOMPtr.h:718: error: undefined reference to 'nsCOMPtr_base::assign_from_gs_contractid_with_error(nsGetServiceByContractIDWithError const&, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:588: error: undefined reference to 'nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&)'
../../../../mozilla/dist/include/nsTHashtable.h:388: error: undefined reference to 'PL_DHashTableFinish'
../../../../mozilla/dist/include/mozilla/mozalloc.h:237: error: undefined reference to 'moz_free'
../../../../mozilla/dist/include/nsCOMPtr.h:710: error: undefined reference to 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:637: error: undefined reference to 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:620: error: undefined reference to 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:588: error: undefined reference to 'nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:588: error: undefined reference to 'nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:648: error: undefined reference to 'nsCOMPtr_base::assign_with_AddRef(nsISupports*)'
../../../../mozilla/dist/include/nsCOMPtr.h:656: error: undefined reference to 'nsCOMPtr_base::assign_with_AddRef(nsISupports*)'
../../../../mozilla/dist/include/nsCOMPtr.h:727: error: undefined reference to 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:851: error: undefined reference to 'nsCOMPtr_base::begin_assignment()'
../../../../mozilla/dist/include/nsCOMPtr.h:851: error: undefined reference to 'nsCOMPtr_base::begin_assignment()'
../../../../mozilla/dist/include/nsTArray.h:503: error: undefined reference to 'nsTArrayHeader::sEmptyHdr'
../../../../mozilla/dist/include/nsTHashtable.h:407: error: undefined reference to 'PL_DHashTableInit'
/opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o:nsNetscapeProfileMigratorBase.cpp:function nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::Init(unsigned int)::sOps: error: undefined reference to 'PL_DHashAllocTable'
/opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o:nsNetscapeProfileMigratorBase.cpp:function nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::Init(unsigned int)::sOps: error: undefined reference to 'PL_DHashFreeTable'
/opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o:nsNetscapeProfileMigratorBase.cpp:function nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::Init(unsigned int)::sOps: error: undefined reference to 'PL_DHashMoveEntryStub'
/opt/moz-objdir/mail/mail/components/build/../migration/src/nsNetscapeProfileMigratorBase.o:nsNetscapeProfileMigratorBase.cpp:function nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::Init(unsigned int)::sOps: error: undefined reference to 'PL_DHashFinalizeStub'
/opt/comm-central/src/mail/components/migration/src/nsProfileMigrator.cpp:29: error: undefined reference to 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)'
../../../../mozilla/dist/include/nsStringAPI.h:458: error: undefined reference to 'NS_CStringCopy'
../../../../mozilla/dist/include/nsStringAPI.h:483: error: undefined reference to 'NS_CStringSetDataRange'
../../../../mozilla/dist/include/nsStringAPI.h:899: error: undefined reference to 'NS_CStringContainerFinish'
../../../../mozilla/dist/include/nsStringAPI.h:901: error: undefined reference to 'NS_CStringContainerInit2'
../../../../mozilla/dist/include/nsCOMPtr.h:637: error: undefined reference to 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:620: error: undefined reference to 'nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:637: error: undefined reference to 'nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:628: error: undefined reference to 'nsCOMPtr_base::assign_from_gs_contractid_with_error(nsGetServiceByContractIDWithError const&, nsID const&)'
../../../../mozilla/dist/include/nsCOMPtr.h:656: error: undefined reference to 'nsCOMPtr_base::assign_with_AddRef(nsISupports*)'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:47: error: undefined reference to 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:79: error: undefined reference to 'nsAString::AppendInt(int, int)'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:82: error: undefined reference to 'nsAString::AppendInt(int, int)'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:196: error: undefined reference to 'nsAString::DefaultComparator(char16_t const*, char16_t const*, unsigned int)'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:196: error: undefined reference to 'nsAString::Equals(char16_t const*, int (*)(char16_t const*, char16_t const*, unsigned int)) const'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:401: error: undefined reference to 'nsACString::DefaultComparator(char const*, char const*, unsigned int)'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:433: error: undefined reference to 'nsACString::DefaultComparator(char const*, char const*, unsigned int)'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:457: error: undefined reference to 'NS_Free'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:489: error: undefined reference to 'NS_Free'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:516: error: undefined reference to 'nsACString::Equals(char const*, int (*)(char const*, char const*, unsigned int)) const'
/opt/comm-central/src/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp:551: error: undefined reference to 'NS_Free'
../../../../mozilla/dist/include/nsStringAPI.h:996: error: undefined reference to 'NS_CStringToUTF16'
../../../../mozilla/dist/include/nsStringAPI.h:1010: error: undefined reference to 'NS_CStringToUTF16'
../../../../mozilla/dist/include/nsStringAPI.h:1039: error: undefined reference to 'NS_CStringToUTF16'
../../../../mozilla/dist/include/nsStringAPI.h:1354: error: undefined reference to 'nsDependentCSubstring_external::nsDependentCSubstring_external(nsACString const&, unsigned int, unsigned int)'
../../../../mozilla/dist/include/nsStringAPI.h:1387: error: undefined reference to 'nsACString::Equals(nsACString const&, int (*)(char const*, char const*, unsigned int)) const'
../../../../mozilla/dist/include/nsStringAPI.h:1431: error: undefined reference to 'NS_StringCloneData'
../../../../mozilla/dist/include/nsArrayUtils.h:20: error: undefined reference to 'vtable for nsQueryArrayElementAt'
/opt/comm-central/src/mail/components/shell/DirectoryProvider.cpp:27: error: undefined reference to 'NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)'
/opt/comm-central/src/mail/components/shell/DirectoryProvider.cpp:187: error: undefined reference to 'NS_NewArrayEnumerator(nsISimpleEnumerator**, nsCOMArray_base const&)'
/opt/comm-central/src/mail/components/shell/DirectoryProvider.cpp:204: error: undefined reference to 'NS_NewUnionEnumerator(nsISimpleEnumerator**, nsISimpleEnumerator*, nsISimpleEnumerator*)'
../../../mozilla/dist/include/nsCOMArray.h:70: error: undefined reference to 'nsCOMArray_base::InsertObjectAt(nsISupports*, int)'
../../../mozilla/dist/include/nsStringAPI.h:838: error: undefined reference to 'NS_StringContainerFinish'
../../../mozilla/dist/include/nsStringAPI.h:840: error: undefined reference to 'NS_StringContainerInit2'
../../../mozilla/dist/include/nsStringAPI.h:978: error: undefined reference to 'NS_UTF16ToCString'
../../../mozilla/dist/include/nsCOMArray.h:233: error: undefined reference to 'nsCOMArray_base::~nsCOMArray_base()'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:74: error: undefined reference to 'PR_GetEnv'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:98: error: undefined reference to 'PR_GetEnv'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:102: error: undefined reference to 'g_path_is_absolute'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:104: error: undefined reference to 'g_path_get_basename'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:105: error: undefined reference to 'g_find_program_in_path'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:109: error: undefined reference to 'g_free'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:111: error: undefined reference to 'g_find_program_in_path'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:118: error: undefined reference to 'g_free'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:185: error: undefined reference to 'g_filename_from_utf8'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:191: error: undefined reference to 'g_find_program_in_path'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:192: error: undefined reference to 'g_free'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:194: error: undefined reference to 'g_find_program_in_path'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:201: error: undefined reference to 'g_free'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:212: error: undefined reference to 'g_shell_parse_argv'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:214: error: undefined reference to 'g_strfreev'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:271: error: undefined reference to 'g_path_get_basename'
../../../mozilla/dist/include/nsStringAPI.h:462: error: undefined reference to 'NS_CStringSetData'
../../../mozilla/dist/include/nsStringAPI.h:514: error: undefined reference to 'nsACString::SetLength(unsigned int)'
../../../mozilla/dist/include/nsStringAPI.h:1054: error: undefined reference to 'NS_UTF16ToCString'
../../../mozilla/dist/include/mozilla/ServiceList.h:15: error: undefined reference to 'mozilla::services::_external_GetStringBundleService()'
../../../mozilla/dist/include/nsCOMPtr.h:628: error: undefined reference to 'nsCOMPtr_base::assign_from_gs_contractid_with_error(nsGetServiceByContractIDWithError const&, nsID const&)'
collect2: ld returned 1 exit status
make[7]: *** [libmailcomps.so] Error 1
make[6]: *** [libs] Error 2
make[5]: *** [libs] Error 2
make[4]: *** [libs] Error 2
make[3]: *** [default] Error 2
make[2]: *** [default] Error 2
make[1]: *** [build] Error 2
make: *** [build] Error 2
(Assignee)

Comment 6

4 years ago
Created attachment 8355898 [details] [diff] [review]
bug953102_ext_api_FINAL_LIBRARY_bustage_v2.patch

With this patch the only errors left are:

Executing: c++ -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -fno-omit-frame-pointer -fPIC -shared -Wl,-z,defs -Wl,-h,libmailcomps.so -o libmailcomps.so /opt/moz-objdir/mail/mail/components/build/tmpYp6yEj.list -lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id -B ../../../mozilla/build/unix/gold -Wl,-rpath-link,/opt/moz-objdir/mail/mozilla/dist/bin -Wl,-rpath-link,/usr/local/lib -Wl,--version-script -Wl,/opt/comm-central/src/mozilla/build/unix/gnu-ld-scripts/components-version-script -Wl,-Bsymbolic -ldl
/opt/moz-objdir/mail/mail/components/build/tmpYp6yEj.list:
    INPUT("nsMailComps.o")

../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/nsMailComps.o: requires dynamic R_X86_64_PC32 reloc against 'nsSeamonkeyProfileMigrator::nsSeamonkeyProfileMigrator()' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/nsMailComps.o: requires dynamic R_X86_64_PC32 reloc against 'vtable for nsProfileMigrator' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: /opt/moz-objdir/mail/mail/components/build/nsMailComps.o: requires dynamic R_X86_64_PC32 reloc against 'vtable for mozilla::mail::DirectoryProvider' which may overflow at runtime; recompile with -fPIC
../../../mozilla/build/unix/gold/ld: error: read-only segment has dynamic relocations
../../../mozilla/dist/include/mozilla/mozalloc.h:201: error: undefined reference to 'moz_xmalloc'
../../../mozilla/dist/include/mozilla/mozalloc.h:201: error: undefined reference to 'moz_xmalloc'
../../../mozilla/dist/include/mozilla/mozalloc.h:201: error: undefined reference to 'moz_xmalloc'
/opt/comm-central/src/mail/components/build/nsMailComps.cpp:16: error: undefined reference to 'nsSeamonkeyProfileMigrator::nsSeamonkeyProfileMigrator()'
../../../mozilla/dist/include/mozilla/mozalloc.h:201: error: undefined reference to 'moz_xmalloc'
/opt/comm-central/src/mail/components/build/nsMailComps.cpp:36: error: undefined reference to 'nsMailGNOMEIntegration::nsMailGNOMEIntegration()'
/opt/comm-central/src/mail/components/build/nsMailComps.cpp:36: error: undefined reference to 'nsMailGNOMEIntegration::Init()'
../../../mozilla/dist/include/nsISupportsImpl.h:56: error: undefined reference to 'PR_GetCurrentThread'
/opt/comm-central/src/mail/components/build/../migration/src/nsProfileMigrator.h:26: error: undefined reference to 'vtable for nsProfileMigrator'
/opt/comm-central/src/mail/components/build/../shell/DirectoryProvider.h:35: error: undefined reference to 'vtable for mozilla::mail::DirectoryProvider'
collect2: ld returned 1 exit status
make[7]: *** [libmailcomps.so] Error 1
make[6]: *** [libs] Error 2
make[5]: *** [libs] Error 2
make[4]: *** [libs] Error 2
make[3]: *** [default] Error 2
make[2]: *** [default] Error 2
make[1]: *** [build] Error 2
make: *** [build] Error 2
Comment on attachment 8355898 [details] [diff] [review]
bug953102_ext_api_FINAL_LIBRARY_bustage_v2.patch

Review of attachment 8355898 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/components/shell/moz.build
@@ +26,5 @@
> +if CONFIG['MOZ_INCOMPLETE_EXTERNAL_LINKAGE']:
> +    IS_COMPONENT = True
> +    FORCE_SHARED_LIB = True
> +else:
> +    FINAL_LIBRARY = 'mailcomps'

Are you sure this is right? If you make mail/components/build produce the conditionally-shared library, that should fix most of your remaining compiler errors...
Flags: needinfo?(Pidgeot18)
(Assignee)

Comment 8

4 years ago
You're right, the mail/components/shell/moz.build isn't needed. 
The one in migration I do think is necessary - the errors "requires dynamic R_X86_64_PC32 reloc against" errors I read has to do with trying to link dynamic to static (or was it the other way around).

What is your mail/components/build proposal? I'm mostly guessing so you'd have to spell it out for me...
(Assignee)

Comment 9

4 years ago
So, someone have anything I could try?

FWIW, commenting out LIBRARY_NAME = 'mailcomps' in mail/components/build/moz.build makes the build complete without errors, but then i don't have the functionality either.
(Assignee)

Comment 10

4 years ago
^^^
Flags: needinfo?(Pidgeot18)
You need the LIBRARY_NAME = 'mailcomps' in mail/components/build/moz.build to link the sublibraries that get into mailcomps. The only moz.build changes that ought to be necessary are conditionally not linking FINAL_LIBRARY='xul' for mail/components/build/moz.build. You may need to add in some SHARED_LIBRARY_LIBS to the Makefile.in to get it to link properly, I don't know offhand.
Flags: needinfo?(Pidgeot18)
(Assignee)

Comment 12

4 years ago
Created attachment 8384253 [details] [diff] [review]
wip3

Possibly some progress, but the glib functions aren't found

/opt/moz-objdir/mail/mail/components/build/tmp0RY8EM.list:
    INPUT("nsMailComps.o")
    INPUT("../migration/src/nsMailProfileMigratorUtils.o")
    INPUT("../migration/src/nsNetscapeProfileMigratorBase.o")
    INPUT("../migration/src/nsProfileMigrator.o")
    INPUT("../migration/src/nsSeamonkeyProfileMigrator.o")
    INPUT("../shell/DirectoryProvider.o")
    INPUT("../shell/nsMailGNOMEIntegration.o")

/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:114: error: undefined reference to 'g_path_is_absolute'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:116: error: undefined reference to 'g_path_get_basename'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:117: error: undefined reference to 'g_find_program_in_path'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:121: error: undefined reference to 'g_free'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:123: error: undefined reference to 'g_find_program_in_path'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:130: error: undefined reference to 'g_free'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:197: error: undefined reference to 'g_filename_from_utf8'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:203: error: undefined reference to 'g_find_program_in_path'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:204: error: undefined reference to 'g_free'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:206: error: undefined reference to 'g_find_program_in_path'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:213: error: undefined reference to 'g_free'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:224: error: undefined reference to 'g_shell_parse_argv'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:226: error: undefined reference to 'g_strfreev'
/opt/comm-central/src/mail/components/shell/nsMailGNOMEIntegration.cpp:283: error: undefined reference to 'g_path_get_basename'
collect2: error: ld returned 1 exit status
make[7]: *** [libmailcomps.so] Error 1
make[6]: *** [libs] Error 2
make[5]: *** [libs] Error 2
make[4]: *** [libs] Error 2
make[3]: *** [default] Error 2
make[2]: *** [default] Error 2
make[1]: *** [build] Error 2
make: *** [build] Error 2
Attachment #8355197 - Attachment is obsolete: true
Attachment #8355898 - Attachment is obsolete: true

Updated

4 years ago
Blocks: 980356

Updated

4 years ago
Blocks: 983711
(Assignee)

Comment 13

4 years ago
Created attachment 8394063 [details] [diff] [review]
proposed fix

It needed $(GLIB_LIBS) in EXTRA_DSO_LDOPTS
This builds correctly!
Assignee: nobody → mkmelin+mozilla
Attachment #8384253 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8394063 - Flags: review?(Pidgeot18)
Comment on attachment 8394063 [details] [diff] [review]
proposed fix

Review of attachment 8394063 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/components/build/Makefile.in
@@ +9,5 @@
>  
>  include $(DEPTH)/config/autoconf.mk
>  
> +ifdef MOZ_INCOMPLETE_EXTERNAL_LINKAGE
> +MODULE_NAME	= nsMailCompsModule

MODULE_NAME is basically unused at this point, although it appears I never bothered to remove the checks that uselessly require it.
Attachment #8394063 - Flags: review?(Pidgeot18) → review+
(Assignee)

Comment 15

4 years ago
https://hg.mozilla.org/comm-central/rev/51974b3f7cbc -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 31.0
You need to log in before you can comment on or make changes to this bug.