Closed Bug 953214 Opened 6 years ago Closed 6 years ago

error downloading update for Nokia Here Maps

Categories

(Firefox OS Graveyard :: Vendcom, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: a.vanloon, Unassigned, NeedInfo)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130917102605

Steps to reproduce:

I downloaded an update for Nokia HERE Maps on my Geeksphone Peak with Boot2Gecko 1.1.1.0hd-GP


Actual results:

The 3 MB update downloaded quickly over my WiFi, but a few seconds later it said there was an "error while downloading the update". This happened twice today already. If my memory serves me well, this also happened when it downloaded updates for other applications in the past.


Expected results:

What about not failing? And if it fails, give me the option to view a detailed error message so I can report some more useful information in this bug report?
Today I downloaded the 1.3 development image for my Geeksphone Peak, because it takes Geeksphone forever to release that as a stable version. I expected this bug with the update for HERE Maps to be fixed as well, but I can confirm it is still present. I tried this solution – http://mzl.la/13yCf0g – which is given for a similar issue on the ZTE Open, but that did not solve anything. If I cancel the download and then restart, the update notification just comes again.

Also, I'm very disappointed this bug hasn't even been triaged yet. It's been over four months since it was filed? My other four bugs haven't seen any response either.
Triaging via https://support.mozilla.org/en-US/questions/993813#answer-554347. I've filed Bug 921750 in the past.
Flags: needinfo?(nhirata.bugzilla)
It's up to the OEM to configure the GPS correctly.

https://wiki.mozilla.org/B2G/Geolocation

I don't recall which geolocation bug it was, but I ended up doing some hacking on the configs and making geolocation work on the device to prove that it's a OEM config issue.
Status: UNCONFIRMED → NEW
Component: General → Vendcom
Ever confirmed: true
Flags: needinfo?(nhirata.bugzilla) → needinfo?(gp)
actually : see bug 908151 and it's related bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 908151
Hmm.. I'm not sure if this is about geolocation or an error updating the app. I'll keep the bug closed for now till we get more info. Could your provide more details on the issue Alexander or does what Naoki reference too is correct? Keeping needinfo on GP.
Flags: needinfo?(a.vanloon)
I'm confused because I don't understand how this could have anything to do with Geolocation? Maybe I wasn't clear: my Geeksphone Peak says there is an update for the Nokia HERE Maps app. When I download this update it says a few seconds after completing the download that there was an "error while downloading the update". As a consequence it's impossible to update the HERE Maps app and my phone keeps giving me the notification that there is an update for that app. Other apps never had this issue. I'm on FFOS 1.3 now and also experienced this with FFOS 1.1.
Flags: needinfo?(a.vanloon)
I'm going to reopen this bug however, this is something Geeksphone should look into. They've been needinfo'ed.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This night I decided to update to a nightly build of 1.4 because of another issue I had with 1.3. When I flashed my phone I decided to remove my user data to start with a clean slate. As a result I had to download HERE Maps from the Marketplace again. It downloaded the latest version and I no longer get nag update notifications, so I can't reproduce the bug anymore.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.