Closed Bug 956101 Opened 6 years ago Closed 5 years ago

Thunderbird data is missing from telemetry.mozilla.org

Categories

(Thunderbird :: General, defect)

31 Branch
defect
Not set

Tracking

(thunderbird34 fixed, thunderbird35 fixed, thunderbird36 fixed, thunderbird_esr3134+ fixed)

RESOLVED FIXED
Thunderbird 36.0
Tracking Status
thunderbird34 --- fixed
thunderbird35 --- fixed
thunderbird36 --- fixed
thunderbird_esr31 34+ fixed

People

(Reporter: jonasfj, Assigned: jcranmer)

References

Details

Attachments

(1 file)

Thunderbird telemetry data seems to be missing on the telemetry-server side, see bug 956060. Once this is resolved we need to check if data for thunderbird appears on telemetry.mozilla.org, if not then this need to be fixed too.
I see data for Thunderbird here:
http://telemetry.mozilla.org/#nightly/29/CYCLE_COLLECTOR/saved_session/Thunderbird

I believe this showed up a while ago...

As in bug 956060 I see no data for release channels, if this is a bug, it should be addressed in telemetry-server. But from comment 2 on bug 956060 (https://bugzilla.mozilla.org/show_bug.cgi?id=956060#c2) it seems this might be a client issue.

I don't think this was ever an aggregation issue, so I'll resolve it invalid.
Basically, we don't have submissions from the release channel, only from nightly/29.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
I don't see Thunderbird data on http://telemetry.mozilla.org. Not for releases. Not for Earlybird.

What am I missing? Or has thing regressed?
I see data coming in for Thunderbird 28, and a few submissions from version 29. Nothing for more recent versions of Thunderbird in the past several days (since September 1st).
(In reply to Mark Reid [:mreid] from comment #3)
> I see data coming in for Thunderbird 28, and a few submissions from version
> 29. Nothing for more recent versions of Thunderbird in the past several days
> (since September 1st).

Any idea why this might be and how this could be fixed?

Reopening. If this is not a server problem, let's move this to a client component.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Mark, in https://bugzilla.mozilla.org/show_bug.cgi?id=956060#c2 you mentioned that a flag had been switched off for Thunderbird, and that was causing clients not to submit Telemetry data.  Has something happened to turn that switch off again?

Is it possible that Thunderbird is still trying to submit to data.mozilla.com instead of incoming.telemetry.mozilla.org?
Flags: needinfo?(standard8)
In theory, as far as I can tell, telemetry is still on in prefs and being submitted to incoming.telemetry.mozilla.org.
Flags: needinfo?(standard8)
I did a bit of poking around on this.

I found that Telemetry pings were not being saved to $profile_dir/saved-telemetry-pings/ on shutdown.

I was able to force a test submission to a local server using the error console, pasting:
Components.utils.import("resource://gre/modules/TelemetryPing.jsm"); TelemetryPing.testPing("http://localhost:8080");

After the test submission, a saved ping did appear in the above directory upon shutdown.

I think Telemetry is not being properly initialized in Thunderbird.
Component: Telemetry Dashboard → General
Product: Webtools → Thunderbird
Version: Trunk → 31
(In reply to Mark Reid [:mreid] from comment #7)

> 
> I think Telemetry is not being properly initialized in Thunderbird.


Is there a document about how to write/improve such iniialization Telemetry?

I tried to see if I could figure out by looking at MXR listing, etc., searches,
and read FAQs, etc. But the source code is not that helpful, and the
Document I searched are all related to the "USE" of already working 
feature in Firefox, and not implementation-specific.

If there is no documentation, then if only someone can point to where 
this "initialization" of telemetry
is taking pace in firefox by pointing out specific file and line, 
maybe someone can pitch in to help improve the TB situation 
(naybe, I am too optimistic.)
I'm not sure of the details on the client - I was pretty much just looking to rule out a problem on the server.

Irving, can you provide any leads to help track this down?
Flags: needinfo?(irving)
Not sure who the best person to inherit this is.
Flags: needinfo?(irving)
Huh. After doing some research, it appears that bug 913070 caused a drop-off in telemetry results, which was fixed by bug 962153... because the component that actually sends the pings on startup wasn't packaged.
Maybe this will do the trick?
Attachment #8522496 - Flags: review?(vdjeric)
Attachment #8522496 - Flags: feedback?(standard8)
(Note: if it does work, I plan to request uplift to aurora/beta/release/esr -- low risk and high value)
Comment on attachment 8522496 [details] [diff] [review]
Add telemetry to the TB package manifest

Review of attachment 8522496 [details] [diff] [review]:
-----------------------------------------------------------------

r+ if it creates pings in the saved-session-telemetry folder
Attachment #8522496 - Flags: review?(vdjeric) → review+
Comment on attachment 8522496 [details] [diff] [review]
Add telemetry to the TB package manifest

Looks fine to me, though I've not tested it.
Attachment #8522496 - Flags: feedback?(standard8) → feedback+
https://hg.mozilla.org/comm-central/rev/47be95d387af
Assignee: nobody → Pidgeot18
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
Comment on attachment 8522496 [details] [diff] [review]
Add telemetry to the TB package manifest

[Approval Request Comment]
Regression caused by (bug #): bug 913070
User impact if declined: No telemetry reports until TB 36 rides the trains
Testing completed (on c-c, etc.): Hopefully, by the time this approval is granted, we'll see telemetry results from nightly users.
Risk to taking this patch (and alternatives if risky): Basically none.
Attachment #8522496 - Flags: approval-comm-release?
Attachment #8522496 - Flags: approval-comm-esr31?
Attachment #8522496 - Flags: approval-comm-beta?
Attachment #8522496 - Flags: approval-comm-aurora?
Comment on attachment 8522496 [details] [diff] [review]
Add telemetry to the TB package manifest

Simple enough that a=Standard8 everywhere.
Attachment #8522496 - Flags: approval-comm-release?
Attachment #8522496 - Flags: approval-comm-esr31?
Attachment #8522496 - Flags: approval-comm-esr31+
Attachment #8522496 - Flags: approval-comm-beta?
Attachment #8522496 - Flags: approval-comm-beta+
Attachment #8522496 - Flags: approval-comm-aurora?
Attachment #8522496 - Flags: approval-comm-aurora+
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.