error on add-on upload: server rejects multipacked files like theme + extension

VERIFIED FIXED in 2014-07

Status

addons.mozilla.org Graveyard
Add-on Validation
P1
normal
VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: Aris, Assigned: mstriemer)

Tracking

unspecified
2014-07

Details

Attachments

(2 attachments, 2 obsolete attachments)

9.63 KB, image/png
Details
1.34 MB, application/x-xpinstall
Details
(Reporter)

Description

4 years ago
Created attachment 8356603 [details]
1.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140106141415

Steps to reproduce:

Tried to upload a new version of Noia 4.

How to reproduce:
- download Noia 4 v1.8.8 ( https://addons.mozilla.org/en-us/firefox/addon/noia-4 )
- open add-ons validator ( https://addons.mozilla.org/en-US/developers/addon/validate )
- upload file


Actual results:

Your add-on failed validation with 1 error.
There was a problem contacting the server.


Expected results:

Upload should work fine like always.
(Reporter)

Comment 1

4 years ago
Created attachment 8356606 [details]
noia4v189.xpi - I try to upload this file
(Reporter)

Comment 2

4 years ago
Uploadig single files from main xpi package works fine too.
(Reporter)

Comment 3

4 years ago
Tricked the validator by renaming main file to "something.jar" before uploading.

There is still something majorly wrong with add-ons validator.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

4 years ago
This bug is still not fixed. The renaming trick does not work anymore.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Can you attach the file that is failing to validate?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

4 years ago
Created attachment 8369918 [details]
noia4v200pre4.xpi
(Reporter)

Comment 7

4 years ago
Hey Jorge,

at the momemt add-ons validator rejects every multi packed theme I tried to upload.
Even already fully reviewed files ( noia4v189.xpi ) won't pass anymore.
(Assignee)

Comment 8

4 years ago
I confirmed the uploads are not working, I will look into it.
Priority: -- → P2
(Assignee)

Updated

4 years ago
Duplicate of this bug: 943761
Assignee: nobody → mstriemer
Priority: P2 → P1
(Reporter)

Comment 11

4 years ago
This bug is still present. Could somebody please fix add-ons validator or disable it?
(Assignee)

Comment 12

4 years ago
I "successfully" validated the noia4v200pre4.xpi file (and several other of the linked files) and got "Your add-on passed validation with no errors and 23 messages." Clicking through to the full validation report sporadically gives me an error though. Seems like it's probably a server configuration problem. I will talk to IT about how we can debug this.
(Assignee)

Comment 13

4 years ago
I no longer get sporadic failures, validation *should* be working properly right now. Who knows if that will continue to be the case. I've brought the issue up with IT and they are looking into some errors we were seeing.

I will leave this open - please comment if you encounter any errors or successes.
(Reporter)

Comment 14

4 years ago
Still getting same connection error.
Is it possible there are some regional restrictions or errors?
I'm uploading from Europe (Germany).

http://i57.tinypic.com/rhkavb.png
(Assignee)

Comment 15

4 years ago
So I uploaded again and got the error. It looks like the server drops the connection and the JS doesn't handle it very gracefully. I grabbed the URL that the JS was hitting and tried it manually, got connection terminated then tried again and got a JSON dump. Looks like validation is working fine, it is just returning the response that is the problem.
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 957633

Comment 17

4 years ago
Got the same error today trying to upload a non-multipacked theme. So things are getting worse from the looks of it.
(Reporter)

Comment 18

4 years ago
Sorry for posting again, but is anybody trying to fix this? It has been now almost four month since this one got reported.

If it is not possible to fix, please disable Add-ons validator for themes!
Mark, are you working on this bug?
Flags: needinfo?
Fixing needinfo.
Flags: needinfo? → needinfo?(mstriemer)
(Reporter)

Comment 21

4 years ago
Created attachment 8402946 [details]
Newer file I'm trying to upload.

It would be great, if someone coud force upload this file for me.
Attachment #8356606 - Attachment is obsolete: true
Attachment #8369918 - Attachment is obsolete: true
(Assignee)

Comment 22

4 years ago
This always seems to work on staging so I'm getting IT to look into if we're killing these connections prematurely. I reproduced this on production a couple times and now I can't reproduce it. It isn't ideal but maybe uploading it a few times in a row will warm-up the servers enough to complete the request in time.

You can eventually get a good validation by resending the status request but the page is still stuck in its invalid state. If IT can't resolve this then I'll try and fix the JS or find someone who can.

The relevant JS [1] can probably try again in this case instead of flagging the error.

[1] https://github.com/mozilla/olympia/blob/master/media/js/common/upload-addon.js#L272

Comment 23

4 years ago
Sorry for my ignorance, I'm not really much of a techie, but until december 2013 validation worked without a problem, then it suddenly stopped. So there must have been some change in the server configuration in about this stretch of time. Is it really so difficult to find out what was changed and who changed it in that time, and to roll it back to the state before?

For me it's not relevant anymore though, because with "Australis" my theming days are probably over anyway, so time has kinda outrun the bug for me. But I feel for people like Aris, who still puts a lot of work and energy in updating his Noia4, and can't upload it to the server now since months.

(And if I may add this small note here: Many thanks Aris also for your "Classic Theme Restorer", it will probably be the only way for me to keep using Firefox!)
(Reporter)

Comment 24

4 years ago
(In reply to Mark Striemer [:mstriemer] from comment #22)
> ... It isn't ideal but maybe
> uploading it a few times in a row will warm-up the servers enough to
> complete the request in time.
> 

Tried this a couple of times on different days, still no luck.
Is there any chance some countries are more often affected than others? I'm uploading from Germany.
(Reporter)

Comment 25

4 years ago
Afer a few more tests theme upload passes validator, if a small theme file is used.

Randomly removing files from theme package causes the theme not to work, but to pass add-ons validator. Does this make sense?

The main problem seems to be a faulty timeout inside the validator.

Can someone check this?

Comment 26

4 years ago
(In reply to Aris from comment #25)
> Afer a few more tests theme upload passes validator, if a small theme file
> is used.
> 
> Randomly removing files from theme package causes the theme not to work, but
> to pass add-ons validator. Does this make sense?
Yes, it makes sense. My Type 32 (multi package) themes have always uploaded and validated OK, but their filesize is very small. 

However, it is not filesize alone doing this bug - as a test, I uploaded a test version of a trivial extension of mine that uses a massive 4MB .wav file for an amusing effect...and it uploaded without problem and I then cancelled out. 

That would suggest it's a timeout bug hitting large filesize Type 32 only?

Comment 27

4 years ago
I can confirm that bug.
Mozo

Comment 28

4 years ago
Please do what you can to alleviate the pressure on the extension developers. They are a large part of  what makes Firefox so usable and many of them do so in their spare time. When tools no longer work or politics interfere with the process they will simply quit supporting their extensions, some of which are indispensable.

Thank you,

Olin

Comment 29

4 years ago
Yeah, and many quiting Firefox. Firefox is almost nithing without themes and extension developers.
(Assignee)

Comment 30

4 years ago
I've got a PR in that should suffice as a workaround in these cases. It isn't perfect but hopefully it will work until a real fix can be done.

https://github.com/mozilla/olympia/pull/90
Flags: needinfo?(mstriemer)
(Assignee)

Comment 31

4 years ago
https://github.com/mozilla/olympia/commit/8b78c7172ea2472c86ae4e6dc642dc5c2963b457
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-06
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1011596

Comment 33

4 years ago
I'm still able to reproduce this issue using the xpi file attached in comment 21.
The validation takes a long time and at the end there is this error message: "Your add-on failed validation with 1 error.    There was a problem contacting the server."
Please view this screencast: http://screencast.com/t/wUbOIoiTHj
Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 2014-06 → 2014-07
(Assignee)

Comment 34

4 years ago
PR to move some processing to celery: https://github.com/mozilla/olympia/pull/127.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 35

4 years ago
https://github.com/mozilla/olympia/commit/b2ab6efa30b7fa1662be5dfede081c852ad4e528

QA please verify that uploading addons still works everywhere that can be done (submission, standalone validation, new version).
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 36

4 years ago
test add-on from comment 1 completes validation without any errors. See https://addons.allizom.org/en-US/developers/upload/b46b2a951967484790d3b93c11a8f04f

This will be in production tomorrow.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1019895
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.