Closed Bug 959602 Opened 8 years ago Closed 8 years ago

Hamachi master can't connect to cell data

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 unaffected)

RESOLVED DUPLICATE of bug 959503
Tracking Status
b2g-v1.3 --- unaffected

People

(Reporter: Bebe, Unassigned)

Details

(Keywords: regression, smoketest, Whiteboard: [fromAutomation])

Attachments

(1 file)

Attached file logcat of the issue
STR:
1. Flash Hamachi with the latest master eng build
2. Dismiss the FTU app
3. Open settings app and enable Cellular data

Expected:
3. Cellular data is enabled a H , 3G etc. is shown on the status bar, User is able to connect to the web

Actual:
3. Cellular data is not enabled

Build:
Gaia      002cca258af8586859c6efb2dada2fcec36754a1
Gecko     http://hg.mozilla.org/mozilla-central/rev/34dddf6f7ec1
BuildID   20140114040616
Version   29.0a1
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013
reproduces manually as well, unable to browse using cell data or send/receive MMS

Device: Buri v1.4 (master) Mozilla RIL
BuildID: 20140114040616
Gaia: 002cca258af8586859c6efb2dada2fcec36754a1
Gecko: 34dddf6f7ec1
Version: 29.0a1
Firmware Version: v1.2-device
blocking-b2g: --- → 1.4?
It was working in yesterday's build.  So the regression range is today's build and yesterday's build.
What happens when you reset the device?  I had reset my device and it seems to work again...
Works

Gecko: 12d3ba62a599
Gaia: fd3b9a97cb3c41cfa56be387b46a51db136b4422

Broken

Gecko: 34dddf6f7ec1
Gaia: 002cca258af8586859c6efb2dada2fcec36754a1
Two RIL bugs in that regression range:

* bug 934125
* bug 958773

Vicamo - Can you weigh in what patch caused this regression? Can we get that patch backed out?
Flags: needinfo?(vyang)
Never mind.  it doesn't work at all.  Jsmith is right.
(In reply to Jason Smith [:jsmith] from comment #6)
> Vicamo - Can you weigh in what patch caused this regression? Can we get that
> patch backed out?

Bug 958773 has been backed-out, and re-landed with fix in bug 959503, but your log looks like a QCRIL one.  I don't know anything about QCRIL.
Flags: needinfo?(vyang)
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #8)
> (In reply to Jason Smith [:jsmith] from comment #6)
> > Vicamo - Can you weigh in what patch caused this regression? Can we get that
> > patch backed out?
> 
> Bug 958773 has been backed-out, and re-landed with fix in bug 959503, but
> your log looks like a QCRIL one.  I don't know anything about QCRIL.

Weird - this shouldn't be QC RIL, as QC no longer gives us RIL builds to test with for 1.3+.
Talked with Vicamo in person - this is fixed in bug 959503 per the above comment.
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 959503
You need to log in before you can comment on or make changes to this bug.