Closed Bug 961361 Opened 6 years ago Closed 5 years ago

[e10s] Flash video problems with sounds but no video output

Categories

(Core :: Plug-ins, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
e10s m4+ ---
firefox29 --- affected
firefox30 --- affected

People

(Reporter: cpeterson, Assigned: jimm)

References

(Blocks 1 open bug)

Details

(Keywords: flashplayer)

STR:
1. With e10s, try to play this CNN video:
http://www.cnn.com/video/data/2.0/video/bestoftv/2014/01/17/ac-ca-wildfires.cnn.html

RESULT:
The video does not play when e10s is enabled.
Blocks: core-e10s
No longer blocks: e10s-plugins
Version 	29.0a1
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0

The video isn't playing as stated.
I'm a newbie ... but I noticed
[Child 23969] WARNING: nsWindow::GetNativeData not implemented for this type: file mozilla-central/widget/xpwidgets/PuppetWidget.cpp, line 714
I can play Flash videos on YouTube, but I still can't play this CNN video. This video has a pre-roll ad, so there might be some interaction between the plugin and content.
tracking-e10s: --- → +
John, any thoughts on root cause here?
Blocks: e10s-m1
Flags: needinfo?(jschoenick)
If flash is deciding to use windowed mode it would fail, or it's possible some NPAPI path doesn't make sense from the context of the content process. Until bug 923746 and bug 997483 land, the plugin code is not expected to work right, so it's probably not worth investigating specific broken pages until then. (But worth tracking the bugs so we can revisit)
Depends on: 923746, 997483
Flags: needinfo?(jschoenick)
Blocks: e10s-plugins
No longer blocks: e10s-m1
Assignee: nobody → jmathies
Blocks: old-e10s-m2
Priority: -- → P2
Duplicate of this bug: 1043731
Moving old M2 P2 bugs to M4.
Move old M2's low-priority bugs to M6 milestone.
oops: old M2 P2 bugs should have been moved to new M4 milestone, not M6.
The link in comment 0 works for me on OSX 10.8.5 with Nightly 35.0a1 (2014-10-06)
The video comment 0 does not play. 
No video displays, sound only.

https://hg.mozilla.org/mozilla-central/rev/9ee9e193fc48
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20141007030202
(In reply to Alice0775 White from comment #10)
> The video comment 0 does not play. 
> No video displays, sound only.
> 
> https://hg.mozilla.org/mozilla-central/rev/9ee9e193fc48
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
> ID:20141007030202

same here, win7.
Duplicate of this bug: 1078090
Summary: [e10s] cnn.com videos do not play with e10s enabled → [e10s] Flash video problems with sounds but no video output
Duplicate of this bug: 1078086
See Also: → 1079677
Fixed by bug 669200.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
5 minutes ago I entered this video and first time tab has crashed. Second time was successful and so the others.
You need to log in before you can comment on or make changes to this bug.