Closed Bug 961378 Opened 9 years ago Closed 6 years ago

Compacting folders on demand

Categories

(Thunderbird :: Untriaged, enhancement)

24 Branch
x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 286888

People

(Reporter: andy.pearce2002, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

This is a feature suggestion, not a bug.

I have an old,slow PC and some very large mailbox folders. 
The default option of "Compacting folders automatically" meant that Thunderbird slowed to a crawl or did not allow me to access my mailboxes while compacting (for long periods) interrupting my work flow.

So I opted to be asked before compacting (set "mail.purge.ask" defaults to "true"). 
This works fine, but.....




Actual results:

The pop-up box asking if I want to compact folders now ONLY appears when I first open Thunderbird. It is not possible to move it out of the way or restore viewing focus to the main Thunderbird window, so I have to either dismiss it, or allow compacting to happen NOW.

In practice this means I never allow TB to do the compacting, because I open Thunderbird when I need to do something straight away.


Expected results:

It would be good if you could be ALERTED that compacting needs to be done, but allowed to delay the decision to start it until a more convenient time.

Possible ways to do that include:
1. Allow the pop-up box to be sent to the background, so you can get your urgent work done but it is still there on the desktop as a visible reminder.
2. Have an option to delay compacting until you close TB, and then be asked if it is OK for TB to compact and then close.
3. Make compacting less intrusive, so it runs in the background without disrupting normal operation so much.

I'm sure there are other possibilities too.
Nicely detailed bug report, and you've got several interesting points.  Taking your list in somewhat reverse order...

(In reply to Andy_P from comment #0)
> Expected results:
> 
> It would be good if you could be ALERTED that compacting needs to be done,
> but allowed to delay the decision to start it until a more convenient time.
> 
> Possible ways to do that include:
> 2. Have an option to delay compacting until you close TB, and then be asked
> if it is OK for TB to compact and then close.

THis is like bug 384092. The UX gods frown on this suggested behavior because we don't want a user during shutdown to be a) prompted, b) delayed by a process that runs some random, long amount of time.  ref: bug 384092 comment 2

> 3. Make compacting less intrusive, so it runs in the background without
> disrupting normal operation so much.

this is the premise of bug 286888

> 1. Allow the pop-up box to be sent to the background, so you can get your
> urgent work done but it is still there on the desktop as a visible reminder.

I'm quite sure we won't do that, but thanks for the suggestion.

> So I opted to be asked before compacting (set "mail.purge.ask" defaults to
> "true"). 
> This works fine, but.....

yeah, that's a pain.

> I have an old,slow PC and some very large mailbox folders. 
> The default option of "Compacting folders automatically" meant that
> Thunderbird slowed to a crawl or did not allow me to access my mailboxes
> while compacting (for long periods) interrupting my work flow.

Here, now, we get to your REAL problem. Which is the cost of compacting, especially on slow systems, can make compacting painful. And even worse on slow systems with combinations of bad factors such as slow disks, old processors, fragmented disks, overhead of AV software, etc.

Briefly, please 
- describe the specs of your system (mfgr, model, CPU, speed of disk if known, all AV software)
- size of disk drive, amount free, and whether the amount free space was ever below 10%
- size of thunderbird profile - go to help | troubleshooting | show folder | right click on the folder | properties ... how many folders, files, and GB space shown in properties?
Severity: normal → enhancement
Flags: needinfo?(andy.pearce2002)
Sorry for delay replying... 
Details requested for the system (please don't laugh TOO much!)

       Machine name: HP_COMPAQ HP d330 DT
   Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 
               BIOS: 786B2 v1.11
          Processor: Intel(R) Pentium(R) 4 CPU 2.40GHz
             Memory: 2048MB RAM

C Drive size: 120GB / 26GB free (Used for TB profile but not MyDocs) 
      Model: Maxtor 6Y120L0 (7200 RPM - NTFS)
D Drive size: 500GB / 116GB free (used for documents)
      Model: WDC WD5000AAKB (7200 RPM - NTFS)
Don't think free space has ever dipped below 10% on either drive

AV Software: Avast Free, Spybot S+D, MalwareBytes. Bog-standard Windows Firewall

Profile folder size: 2.68GB, 1552 Files, 252 Folders  (I have a huge archive of work-related tech. docs archived from an email discussion board)

I'm expecting Porche behaviour from a Model T Ford I guess?!?!
Flags: needinfo?(andy.pearce2002)
That's actually not bad hardware.

If it's still a problem for you suggest setting the automatic compact value to a number higher than the default. 100 or 200mb or more. Or even disable and always do it manually. Also, make certain your AV software isn't slowing things down - Thunderbird should be excluded from scanning.

We are not going to do #1 or #2. So duping to bug 286888
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286888
You need to log in before you can comment on or make changes to this bug.