Closed Bug 963859 Opened 10 years ago Closed 10 years ago

Firefox Accounts system app error overlay is blank

Categories

(Firefox OS Graveyard :: FxA, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 960130

People

(Reporter: jhirsch, Assigned: jhirsch)

References

Details

(Whiteboard: [qa+])

Attachments

(1 file)

STR:

on today's m-c and gaia, on a hamachi,

1. start fxa test app flow
2. enter an existing account email
3. enter the wrong password
4. you'll see an error overlay with an 'OK' button and a horizontal line, but no text

I guess something's up with the way the system app is filling in the error text, I will investigate unless someone steals this.
Assignee: nobody → 6a68
I think there might be more to it than this, working on STR
No longer blocks: 941723
Whiteboard: [qa+]
This is definitely a legit bug. I can still repro on today's m-c.

The obvious problem is that the error overlay isn't being displayed with error text. That's covered by this bug.

The more important problem, I think, is that the system app doesn't do a quick getAccounts() to check if we have a session already. If we do, it should show the success screen, which varies depending on whether the account is verified or unverified. I've opened 964417 to track this deeper bug.

STR:
1. Sign into FxA on device via fxa test app
2. Go through the signup flow, should work fine
3. Reopen the fxa flow
4. Sign in with the same account
5. After entering password, you're shown a panel with no error message.
Summary: System app showing blank overlay instead of "bad password" error → Firefox Accounts system app error overlay is blank
Blocks: 955952
No longer blocks: 941723
This is a dup of bug 960130. The reason of this blank screen is the absence of l10n keys removed in bug 961009
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.