Closed Bug 960130 Opened 8 years ago Closed 7 years ago

Review copy for Firefox Accounts

Categories

(Firefox OS Graveyard :: FxA, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog)

RESOLVED FIXED
tracking-b2g backlog

People

(Reporter: Pike, Assigned: jgruen)

References

Details

(Whiteboard: [qa+] [fxa4fxos2.0])

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #929388 +++

The strings landed in bug 929388 make me wonder, have those gone through UX and copy yet? https://github.com/mozilla-b2g/gaia/blob/master/apps/system/fxa/locales/fxa.en-US.properties are the strings, for reference.

Also, there are strings about lorem ipsum, I'm confident those are wrong. I'm also concerned around the wording and branding.

Do we really need to have TOS in our product, or can we load the TOS from the web? Those are usually localized by an external process due to legal constraints.

I don't think the strings here are ready for l10n, so this blocks a significant chunk of uplifts for l10n.

One way to unblock us would be to rename the file to something that's not picked up by the l10n conversion system, like apps/system/fxa/fxa.properties, and leave the app non-localized until it's actually ready.
Flags: needinfo?(firefoxos-ux-bugzilla)
Axel, we're moving the tree for 1.4; apologies for leaving the 1.3 tree around this long. Meantime I have marked this issue as an overall blocker for 1.4 and a blocker for the ToS bug. Feel free to split this bug or add children; whatever works best for you as long as we can see it under 941723.

Specific answers: I'm pretty sure we have not gone through copy; UX is working with us (John Gruen is lead). WRT ToS handling, we do not have engineering tasks set for that. Please reset needinfo if these answers aren't adequate. Thanks, Sam
Blocks: 941723, 949065
No longer blocks: fxos-accounts
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: [qa?]
Flagging John (UX for FxA) and Erin Lancaster (PM) for more info.
Flags: needinfo?(jgruen)
Flags: needinfo?(elancaster)
Blocks: 961009
Definitely keep me in the loop on this and let me know how I can help. Thanks.
Component: Gaia::System → FxA
Duplicate of this bug: 949102
Backlog - FxAccounts doesn't hit the QC needs list & DSDS needs list, so this doesn't block.
blocking-b2g: 1.4? → backlog
Duplicate of this bug: 963859
Fernando I have added this to nice to haves. I will do a mass promotion when we clear the current blockers.
Blocks: 974121
All, Matej and I reviewed strings in the spec document this morning. Working to update spec w/ his changes. Expect strings locked 2/27
Flags: needinfo?(jgruen)
jgruen I assume this is done? can we resolve?
Flags: needinfo?(jgruen)
Attached file FxA_FFOS_System_Flow.pdf (obsolete) —
I'm attaching the finalized 1.4 spec and closing out this bug.

I'll open bugs to handle UI changes (including string changes) under the bug tree rooted at bug 941723.
Flags: needinfo?(jgruen)
Flags: needinfo?(elancaster)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Jared, can you provide more concrete steps to get the issues fixed?

A massive tracking bug and an attachment in a closed bug aren't going to make sure we drive the issues to conclusion.

Reopening for now.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Yeah, the concrete steps are:

1. Now that 949051 has landed in master, I generate screenshots of all the screens
2. Compare the screenshots with the specs
3. File bugs, specifically under bug 974121
4. Fix, ship, rinse, repeat :-)

Does that provide a bit more assurance that this actually gets done?
Flags: needinfo?(l10n)
The point here is to get the specs to match expectations, and then drive the product into a ship-ready quality.

It's sad, but specs don't have the final copy, that's what a copy review is for.

If we don't have a specific task to drive our copy, we'll have crappy UI.
Flags: needinfo?(l10n)
Axel, I can ensure the specs have final copy. I am on the hook for copy reviews going forward, as well as the audit project that will ideally fix past mistakes and get us to a better baseline. Please flag me here if I can help achieve final copy - happy to do it.
I've opened bugs 987417, 987418, and 987419 to track work to update the copy in the firefox accounts gaia components (settings app, system app, and FTE, respectively).

Closing.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
also, just to be clear, per Comment 8 the spec attached does, in fact, have the final strings :-)
Whiteboard: [qa?] → [qa+]
Reopening because we need to handle a couple of missed screens/strings (see bug 987418 for so much detail)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: nobody → jgruen
Whiteboard: [qa+] → [qa+] [fxa4fxos2.0]
Uploading the updated spec with additional error strings spec'd.

Marking older spec as obsoleted.
Attachment #8395908 - Attachment is obsolete: true
Marking as closed, since we have the updated spec attached.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.