Closed Bug 964104 Opened 11 years ago Closed 11 years ago

Icon moves when activating toolbar buttons that show panels

Categories

(Firefox :: Theme, defect)

29 Branch
All
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: micmon, Assigned: Gijs)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 files)

There are two kinds of "buttons" which can be placed on the toolbar: those who just execute one action ("open new window") and those who show a menu. I am talking about the second kind here. This is true for the current Linux nighlty build, I am not sure if other platforms have similar problems.

Currently there seem to be four (!) ways a "button which shows a menu" can work:

1.) the menu opens on mouse-release, icon changes position a few pixels to bottom/right. This can be seen here:
- Encoding
- History
- Web developer tools
- Downloads

2.) the menu opens on mouse-press, the icon changes position a few pixels to bottom/right. Does not support activation of items by press-drag-release. This can be seen here:
- Customize and control


3.) the menu opens on mouse-press, icon does never changes position but menu changes postion a few pixels to the right after moving the mouse pointer to the menu. Does support activation of items by press-drag-release. This can be seen here:
- Bookmarks

4.) the menu opens on long-press, icon changes postion but only when moving mouse away from the button while keeping the mouse button down. This can be seen here:
- Back
- Forward

IMHO 1-3 menus should 
a) already open on mouse-press
b) support press-drag-release to activate contained items
c) not move the icon around

Case 4 is special, it works fine but the icon should not change position.
Some of these are known (e.g. the bookmarks menu moving is bug 940265), but what really concerns me is that you're seeing the icons move. I've not heard that before. Can you perhaps take a before/after screenshot?

Meanwhile, any ideas about this, Jared?
Flags: needinfo?(michael.monreal+moz)
Summary: Inconsistencies in default toolbar buttons → Icon moving and other inconsistencies in toolbar buttons that show panels
Whiteboard: [Australis:P3]
Flags: needinfo?(jaws)
Yes I had to work around this a little with my Linux toolbar buttons patch but I'm surprised it is still happening. I thought I had fixed them all. This is likely due to the buttons being implemented differently. Iirc, the margins on the icons may change in :hover:active.
Flags: needinfo?(jaws)
Attached image 1.png
This shows the problem on the menu button. The whole button actually moves one pixel to the right when pressed, the image seems to stay centered relative to the button borders.
Flags: needinfo?(michael.monreal+moz)
The bookmarks menu seems to be working exactly as I would expect now, all other points are still valid in today's v29 australis-enabled Aurora build
This fixes the buttons' states. Note that the downloads button needed an additional fix which is simply copied from the Windows theme - otherwise its dimensions were still off after having loaded the indicator overlay.
Attachment #8372885 - Flags: review?(MattN+bmo)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8372885 [details] [diff] [review]
fix icons moving when pressing down on Australis for Linux,

Review of attachment 8372885 [details] [diff] [review]:
-----------------------------------------------------------------

Punting to Jared. :-)
Attachment #8372885 - Flags: review?(MattN+bmo) → review?(jaws)
Comment on attachment 8372885 [details] [diff] [review]
fix icons moving when pressing down on Australis for Linux,

Review of attachment 8372885 [details] [diff] [review]:
-----------------------------------------------------------------

I tested out the padding change it looks good to me. rs=me on the downloads change.

::: browser/themes/linux/browser.css
@@ +559,5 @@
>  :-moz-any(#TabsToolbar, #nav-bar) .toolbarbutton-1 {
>    -moz-appearance: none;
>  }
>  
> +:-moz-any(#TabsToolbar, #nav-bar) .toolbarbutton-1[open="true"], 

nit, trailing whitespace
Attachment #8372885 - Flags: review?(jaws) → review+
Depends on: 971260
I've split off the press->move->activate stuff into bug 971260 so we can track things separately. The icons moving should be fixed on Fx-Team now, and will make its way down to a build near you in the usual manner.
Summary: Icon moving and other inconsistencies in toolbar buttons that show panels → Icon moves when activating toolbar buttons that show panels
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
Blocks: 971260
No longer depends on: 971260
https://hg.mozilla.org/mozilla-central/rev/b563dbb8da42
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
Comment on attachment 8372885 [details] [diff] [review]
fix icons moving when pressing down on Australis for Linux,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: some buttons move on Linux when clicked
Testing completed (on m-c, etc.): on m-c for a while
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8372885 - Flags: approval-mozilla-aurora?
Attachment #8372885 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: