Closed Bug 964315 Opened 6 years ago Closed 6 years ago

The panel menu doesn't have a drop shadow on Windows

Categories

(Firefox :: Theme, defect)

29 Branch
All
Windows 8.1
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: phlsa, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3+])

Attachments

(1 file)

All panels (e.g. Bookmarks, Downloads, History) have a nice and subtle drop shadow in Australis. The panel menu is the only one that hasn't.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 930064
Un-duping this one because it is actually a different issue on a different platform.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Thx for the clarification!
Status: REOPENED → NEW
Hardware: x86 → All
Whiteboard: [Australis:P4] → [Australis:P3]
Whiteboard: [Australis:P3] → [Australis:P3+]
Attached patch PatchSplinter Review
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8372752 - Flags: review?(MattN+bmo)
Comment on attachment 8372752 [details] [diff] [review]
Patch

OK, after thorough investigation it seems like this fixes bug 930064 too.
Attachment #8372752 - Flags: review?(MattN+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/a51b82553a27
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Duplicate of this bug: 972204
Comment on attachment 8372752 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 877684
User impact if declined: missing shadow on the menu panel
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8372752 - Flags: approval-mozilla-aurora?
Attachment #8372752 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: cornel.ionce
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.3; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Windows NT 6.3; rv:30.0) Gecko/20100101 Firefox/30.0

Verified as fixed on latest Aurora (build ID: 20140320004001) and Firefox 29 beta 1 (build ID: 20140318013849).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.