[B2G][Browser]Websites with side banner ads display inappropriately in browser, and frequently stop responding.

RESOLVED INVALID

Status

Tech Evangelism
Mobile
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Ross Kuhlman (rkuhlman@qanalydocs.com), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dogfood1.3)

Attachments

(2 attachments)

Created attachment 8367597 [details]
BannerAdWebpageCrash.txt

Some websites present advertisements that display in the extra space on the sides of the screen. These pages will display strangely on the device Browser. Pages will look appropriate in the orientation they are loaded in, but the width will not change when the orientation is changed. Going from portrait to landscape causes the page to look too narrow for the screen, going from landscape to portrait causes the page to look to wide for the screen. Changing view orientation will eventually cause the webpage to stop responding.

Some sites that display side banner ads: pcgamer.com, nfl.com, ign.com, twitch.tv

Repro Steps:
1) Updated Buri to BuildID: 20140122004001
2) Launch browser and navigate to 'pcgamer.com'.
3) After the page has loaded, change the orientation of the device.

Actual:
Page width does not adjust to display properly in new orientation.

Expected:
Page width always displays appropriately.

Environmental Variables:
Device: Buri v1.3 Moz RIL
BuildID: 20140127004002
Gaia: 25a45a836a4a21a30f63fa7b544b42e8b781180a
Gecko: c40099a42c1f
Version: 28.0a2
Firmware Version: v1.2-device.cfg

Notes:
twitch.tv is especially problematic. In addition to the issues mentioned above, page content on twitch.tv jumps around and flickers constantly.

Repro frequency: 100%
See attached: logcat and screenshots.
Created attachment 8367603 [details]
SideBannerAdOrientation.jpg

Issue also occurs in 1.2

Environmental Variables:
Device: Buri v1.2 Moz RIL
BuildID: 20140128004004
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: d10e1f965d0c
Version: 26.0
Firmware Version: v.2-device.cfg
Does this reproduce on 1.1?
Keywords: qawanted

Updated

4 years ago
QA Contact: pfield

Comment 3

4 years ago
Could not get this issue to reproduce on Buri V 1.1 

Environmental Variables:
Device: buri 1.1 com
BuildID: 20140130041201
Gaia: c434fe9a0e823029796805e141cfa983cda2d246
Gecko: 1b24a4178317
Version: 18.0
RIL Version: 01.01.00.019.281
Firmware Version: V1.2-device.cfg
Keywords: qawanted

Updated

4 years ago
blocking-b2g: --- → 1.3?
Component: Gaia::Browser → Layout
Keywords: regression, regressionwindow-wanted
Product: Firefox OS → Core
Version: unspecified → 26 Branch
What's the behavior on 1.1? Can you showcase some screenshots for comparison? Do we get the website not responding issue?
Flags: needinfo?(pfield)

Comment 5

4 years ago
After discussing with reporter offline, it was discovered that this issue only occurs with non-mobile sites. My statement previously was regarding mobile sites, therefore, after another look on the proper non mobile site, this issue IS occuring on 1.1.

Environmental Variables:
Device: buri 1.1 com
BuildID: 20140130041201
Gaia: c434fe9a0e823029796805e141cfa983cda2d246
Gecko: 1b24a4178317
Version: 18.0
RIL Version: 01.01.00.019.281
Firmware Version: V1.2-device.cfg

Apologies for any confusion.
Flags: needinfo?(pfield)
(In reply to pfield from comment #5)
> After discussing with reporter offline, it was discovered that this issue
> only occurs with non-mobile sites. My statement previously was regarding
> mobile sites, therefore, after another look on the proper non mobile site,
> this issue IS occuring on 1.1.

Okay, then we shouldn't block 1.3 on this so I'll clear the nom.  Thanks for following up!

> Apologies for any confusion.

No problem :)
blocking-b2g: 1.3? → ---

Updated

4 years ago
Component: Layout → Mobile
Keywords: regression, regressionwindow-wanted
Product: Core → Tech Evangelism
Version: 26 Branch → unspecified
I can't reproduce any layout problems on my device, other than what appears to be OOM-ish behavior and *very* slow painting from a media heavy desktop site. I'm going to close this as INVALID and open new bugs for each of the sites you reported though to make sure we get the mobile friendly sites, thanks!
I can't reproduce any layout problems on my device, other than what appears to be OOM-ish behavior and *very* slow painting from a media heavy desktop site. I'm going to close this as INVALID and open new bugs for each of the sites you reported though to make sure we get the mobile friendly sites, thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(there doesn't appear to be a mobile site for nfl.com in any browser I've tested in, so I haven't filed an issue for that one)
You need to log in before you can comment on or make changes to this bug.