Show Australis tour page upon update for en-US on Aurora

VERIFIED FIXED in Firefox 29

Status

()

defect
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: MattN, Assigned: MattN)

Tracking

Trunk
Firefox 29
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox29+ verified, firefox30 wontfix)

Details

()

Attachments

(3 attachments, 1 obsolete attachment)

We can possible use a variation of the patch in bug 950405 but perhaps just for the version change, not the build ID so that we don't need a pref.

Can we use the regular what's new URL but now with the version 29.0a2 for Aurora?
Flags: needinfo?(jbertsch)
Tested on a local en-US build of Nightly with the Aurora update channel & branding.
Attachment #8368373 - Flags: review?(gavin.sharp)
I'm going to modify the patch to skip Linux for Aurora due to bug 966068 and bug 966072. Gavin, feedback on the approach in the meantime is still welcome.

Thanks.
Patch looks good (I'd add some whitespace before/after the ifdefs for clarity though). I'll r+ with the no-Linux modification.

We should get the followup to back this out on file now, too.
Comment on attachment 8369565 [details] [diff] [review]
v.2 Override nsBrowserContentHandler for en-US on Aurora on Windows and OS X

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: No UI tour on Aurora
Testing completed (on m-c, etc.): N/A - only works on Aurora
Risk to taking this patch (and alternatives if risky): low, worst case is that a tour appears on startup when it shouldn't
String or IDL/UUID changes made by this patch: None
Attachment #8369565 - Flags: approval-mozilla-aurora?
Attachment #8369565 - Flags: review?(gavin.sharp)
Attachment #8369565 - Flags: review+
Attachment #8369565 - Flags: approval-mozilla-aurora?
Attachment #8369565 - Flags: approval-mozilla-aurora+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Posted patch test fixSplinter Review
This caused test bustage on the Aurora Nightly (where the update channel is set):
https://tbpl.mozilla.org/php/getParsedLog.php?id=34123288&tree=Mozilla-Aurora&full=1#error0

This patch should work around the bustage temporarily. I'm building now to test.
(Similar to http://hg.mozilla.org/releases/mozilla-aurora/rev/330b68ae1583, but manifests itself differently since the patch has different behavior WRT "showURL"/"openURL" snippet attributes.)
Fixes the bustage for me locally, pushed with a slight tweak: https://hg.mozilla.org/releases/mozilla-aurora/rev/799ec5c3c327

(couldn't put the code in test() since that runs after the BCH_TESTS object is initialized)
I upgraded to Firefox Aurora 29.0a2 (2014-02-07). The whatsnew page was launched after restart with an old profile.

https://www.mozilla.org/en-US/firefox/29.0a2/whatsnew/?oldversion=28.0a2
[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug
User impact if declined: No tour on Linux for upgrades
Testing completed (on m-c, etc.): QA tested the tour itself on Linux by going to the URL directly. The code has been working on Windows and OS X for Aurora AFAIK since yesterday.
Risk to taking this patch (and alternatives if risky): Low. Just removing the OS check.
String or IDL/UUID changes made by this patch: None
Attachment #8372884 - Flags: review?(gavin.sharp)
Attachment #8372884 - Flags: approval-mozilla-aurora?
Attachment #8372884 - Flags: review?(gavin.sharp)
Attachment #8372884 - Flags: review+
Attachment #8372884 - Flags: approval-mozilla-aurora?
Attachment #8372884 - Flags: approval-mozilla-aurora+
User Agents:
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Microsoft Surface Pro 2)
Mozilla/5.0 (Windows NT 6.3; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.0; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0


Verified as fixed on Firefox Aurora 29.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.