Closed Bug 966020 Opened 6 years ago Closed 6 years ago

Enable whatsnew survey page temporarily for Aurora builds with Australis

Categories

(Firefox :: General, defect)

29 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox29 --- verified
firefox30 --- wontfix

People

(Reporter: tdowner, Assigned: smacleod)

References

Details

(Whiteboard: p=2 s=it-30c-29a-28b.2 [Australis:P2] [qa!])

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #950405 +++

We'd like to do the same thing we did in Bug #950405 in Aurora roughly two weeks after uplift. We will have a new survey to link to that we will provide shortly.
I just filed bug 966014 to show the tour on Aurora from day one. I guess this bug can just be for webdev to add the survey link after two weeks?
No, this will be another survey, similar to the one we ran in 950405, that will show a what's new page to all en-us Aurora users after two weeks of Australis being on Aurora. It will be separate from the shorter, UI Tour specific surveys we run in 966014. This survey is more targeted to australis in general and will allow us to measure the impact that the education pieces + more polish have had on overall user perception after two weeks of usage.
Summary: enable whatsnew page temporarily for Aurora builds with Australis → Enable whatsnew survey page temporarily for Aurora builds with Australis
Depends on: 970957
Whiteboard: p=0 → p=0 [Australis:P2]
Assignee: nobody → smacleod
Status: NEW → ASSIGNED
Whiteboard: p=0 [Australis:P2] → p=2 s=it-30c-29a-28b.2 [Australis:P2]
Whiteboard: p=2 s=it-30c-29a-28b.2 [Australis:P2] → p=2 s=it-30c-29a-28b.2 [Australis:P2] [qa+]
QA Contact: cornel.ionce
Please get this live as soon as bug 970957 is fixed.
[Approval Request Comment]
Bug caused by (feature/regressing bug #): feature
User impact if declined: No survey
Testing completed (on m-c, etc.): Local build
Risk to taking this patch (and alternatives if risky): Low risk 
String or IDL/UUID changes made by this patch: None
Attachment #8382459 - Flags: review?(MattN+bmo)
Attachment #8382459 - Flags: approval-mozilla-aurora?
The survey web page is now live on to prod:

https://www.mozilla.org/en-US/firefox/aurora/up-to-date/
Fixed a small error in the patch I missed before testing with MOZ_UPDATE_CHANNEL == aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): feature
User impact if declined: No survey
Testing completed (on m-c, etc.): Local build
Risk to taking this patch (and alternatives if risky): Low risk 
String or IDL/UUID changes made by this patch: None
Attachment #8382459 - Attachment is obsolete: true
Attachment #8382459 - Flags: review?(MattN+bmo)
Attachment #8382459 - Flags: approval-mozilla-aurora?
Attachment #8382483 - Flags: review?(MattN+bmo)
Attachment #8382483 - Flags: approval-mozilla-aurora?
Attachment #8382483 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8382483 [details] [diff] [review]
Patch - Enable survey page temporarily for new Aurora builds with Australis v2

Review of attachment 8382483 [details] [diff] [review]:
-----------------------------------------------------------------

You should make sure you won't hit an issue like bug 966014 comment 10 at least locally (for browser/components/test/) with a build using the aurora update channel or on Try with a custom mozconfig[1].

I think putting this in build/mozconfig.common.override should be enough but I'm not sure:
ac_add_options --enable-update-channel=aurora
ac_add_options --enable-official-branding

Remember to only land on Aurora.

Thanks

[1] https://wiki.mozilla.org/ReleaseEngineering/TryServer#Using_a_custom_mozconfig

::: browser/components/nsBrowserContentHandler.js
@@ +618,5 @@
> +
> +            let showedAuroraAustralisSurvey = false;
> +            try {
> +              showedAuroraAustralisSurvey = Services.prefs.
> +                getBoolPref("browser.showedAuroraAustralisSurvey");

I think we should use the same pref from Nightly to avoid more "user set" pref pollution. I doubt we really care about the people who went between Nightly and Aurora since the last survey.
Attachment #8382483 - Flags: review?(MattN+bmo) → review+
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
User Agents:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Microsoft Surface Pro 2)
Mozilla/5.0 (Windows NT 6.3; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.0; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Verified this issue by updating Firefox Aurora to the latest version.
The survey page was properly displayed after the update on each tested environment.
Marking issue as verified.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 29
Hey everyone, I think we've got about as many responses as we can expect with this survey, so we can go ahead and take it down at your earliest convenience. Thanks!
Tyler, it will naturally stop launching in-product when Aurora becomes version 30 (~tomorrow). The page from bug 970957 can probably be taken down shortly after that.
Sounds perfect. Thanks!
I have filed bug 984507 to take the page down once Aurora becomes version 30. Thanks
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: p=2 s=it-30c-29a-28b.2 [Australis:P2] [qa+] → p=2 s=it-30c-29a-28b.2 [Australis:P2] [qa!]
You need to log in before you can comment on or make changes to this bug.