Closed Bug 966933 Opened 6 years ago Closed 6 years ago

UITour: Add a UI tour link in the Help menu

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: zfang, Assigned: Unfocused)

References

(Depends on 1 open bug)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 files, 1 obsolete file)

Add a link of the UI tour in the Help menu. There was a link in the help menu in the try build Blair provided us, and it worked really well. Some users actually went there to look for a tour. It would also benefit users who close the tour when they first saw it.
No longer blocks: 935823
This needs in-product strings. :-(
Whiteboard: [strings]
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
fang: Aurora is string-frozen - so generally we need to get any bugs that involve new strings landed *before* the merge to Aurora. In cases like this, we can land just the strings, and implement the actual functionality later on. But we really need to get the strings in one way or another, otherwise it makes it really difficult for the localizers.
Attached patch Strings patch v1Splinter Review
Would like to double check the strings here before this gets landed, so hopefully you get back from lunch in time, fang :) But the train may leave without you.

Menu item label: Firefox Tour
Access key: o
Attachment #8369364 - Flags: ui-review?(zfang)
Attachment #8369364 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8369364 [details] [diff] [review]
Strings patch v1

Review of attachment 8369364 [details] [diff] [review]:
-----------------------------------------------------------------

r=me as far as the code is concerned.
Attachment #8369364 - Flags: review?(gijskruitbosch+bugs) → review+
Attachment #8369364 - Flags: ui-review?(zfang) → ui-review+
Whiteboard: [strings] → [strings][leave open]
Depends on: 969221
We want to increase the priority of this so we can use it as a workaround for lack of bug 938079. Blair, are you able to get to this bug this week?
Flags: needinfo?(bmcbride)
Priority: P4 → --
Whiteboard: [strings][leave open] → [Australis:P3][strings][leave open]
Attached patch Patch v1 (obsolete) — Splinter Review
Alex: This is currently using the following URL:

  https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/whatsnew/

Which works fine for Firefox 29, but Firefox 30 currently doesn't get the tour. Could we either make the same URL for 30 result in the tour page, or use a different URL for when someone manually opens the tour? Something like:
  https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/tour/

(We can easily update this URL in future Firefox versions.)
Attachment #8385095 - Flags: review?(MattN+bmo)
Flags: needinfo?(bmcbride)
Erm. Alex, see comment 7.
Flags: needinfo?(agibson)
(In reply to Blair McBride [:Unfocused] from comment #7)
> Created attachment 8385095 [details] [diff] [review]
> Patch v1
> 
> Alex: This is currently using the following URL:
> 
>   https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/whatsnew/
> 
> Which works fine for Firefox 29, but Firefox 30 currently doesn't get the
> tour. Could we either make the same URL for 30 result in the tour page, or
> use a different URL for when someone manually opens the tour? Something like:
>   https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/tour/
> 
> (We can easily update this URL in future Firefox versions.)

Yeah we should really have the tour available at a secondary URL for this purpose, as I'm guessing in the future /whatsnew pages may not always be a tour.

I'll create a bug to implement something along the lines of https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/tour/.
Flags: needinfo?(agibson)
Comment on attachment 8385095 [details] [diff] [review]
Patch v1

Review of attachment 8385095 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #8385095 - Flags: review+
Depends on: 979217
Comment on attachment 8385095 [details] [diff] [review]
Patch v1

Thanks Gijs.

Will update the URL and land when bug 979217 goes live. Marking this patch obsolete to ensure no one accidentally lands it in the meantime.
Attachment #8385095 - Attachment is obsolete: true
Attachment #8385095 - Flags: review?(MattN+bmo)
Whiteboard: [Australis:P3][strings][leave open] → [Australis:P3][don't land until bug 979217 goes live]
Attachment #8369364 - Flags: checkin+
https://hg.mozilla.org/integration/fx-team/rev/50042889c775
Whiteboard: [Australis:P3][don't land until bug 979217 goes live] → [Australis:P3]
Comment on attachment 8386018 [details] [diff] [review]
Patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: No manual access to Australis tour, other than knowing the URL
Testing completed (on m-c, etc.): Manual testing
Risk to taking this patch (and alternatives if risky): Minimal. 
String or IDL/UUID changes made by this patch: None, strings already landed before Aurora merge
Attachment #8386018 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/50042889c775
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Attachment #8386018 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [Australis:P3] → [Australis:P3] [good first verify]
I can still see the static page on navigating to the Help --> Firefox tour."https://www.mozilla.org/en-US/firefox/29.0/tour/" as specified in the bug history it is expected to display the page with content as displayed in the page "https://www.mozilla.org/en-US/firefox/central/"

29 -> Not Fixed
30 -> Not Fixed
31 -> Not Fixed
All versions 29 and higher should show the interactive tour not, a page like /firefox/central/. Does this help?
[bugday-20140409]

status-firefox29.0b6 verified
status-firefox30.0a2 verified
status-firefox31.0a1 verified

Testing on x86 Mac OSX 10.9.2
  Firefox 29.0b6 (2014-04-07)
  Aurora 30.0a2 (2014-04-09)
  Firefox Nightly 31.0a1 (2014-04-09)

If I click Help > * Tour, I'm redirected to this URL with an interactive tour (for respective versions):
  https://www.mozilla.org/en-US/firefox/29.0/tour/
  https://www.mozilla.org/en-US/firefox/30.0a2/tour/
  https://www.mozilla.org/en-US/firefox/31.0a1/tour/

* - (Firefox, Aurora, Nightly)
As the previous commenter said, (comment 20), clicking on Help → Tour redirects me to the https://www.mozilla.org/en-US/firefox/$version/tour/ URL, where the tour starts.

Testing on x86_64 Linux (Debian Sid):

- verified on Nightly [Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140408030205 CSet: 8883360b1edb]

- verified on Aurora [Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140409004002 CSet: e450e07e3a58]

- verified on Beta [Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140407135746 CSet: 71439d266704]
Marking the bug as verified per comment 20 and comment 21.
Status: RESOLVED → VERIFIED
Whiteboard: [Australis:P3] [good first verify] → [Australis:P3]
You need to log in before you can comment on or make changes to this bug.