Add Makefile for communications

RESOLVED FIXED

Status

Firefox OS
Gaia::Build
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: yurenju, Assigned: yurenju)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

add a makefile for communications and migrate communications related code from applications-data.js, webapp-manifest.js and webapp-optimize.js.

we should build this app in build_stage because code snippet in webapp-manifest.js modify manifest.webapp of communications, or we will see some modification in git for each make
Assignee: nobody → yurenju.mozilla
Blocks: 968684
WIP here, https://github.com/yurenju/gaia/commit/308a51fdf78840e2c576c67ab14f03c358d3b43f

still need integration tests and addressing some nits.
Created attachment 8373934 [details] [review]
github PR: https://github.com/mozilla-b2g/gaia/pull/16166

Hi Tim and Albert, could you review this pull request? thank you :D
Attachment #8373934 - Flags: review?(timdream)
Attachment #8373934 - Flags: review?(acperez)
Comment on attachment 8373934 [details] [review]
github PR: https://github.com/mozilla-b2g/gaia/pull/16166

It's much clear on what you do with

https://github.com/mozilla-b2g/gaia/pull/16166/files?w=1

Please fix the nits on Github and make sure test passes before landing.
Attachment #8373934 - Flags: review?(timdream)
Attachment #8373934 - Flags: review?(acperez)
Attachment #8373934 - Flags: review+
merged.

https://github.com/mozilla-b2g/gaia/commit/e6f7bfd0c2f1e302375951d3a612c117e94a054c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
I had to back this out because it is breaking make install-gaia.

https://github.com/mozilla-b2g/gaia/commit/2e546129dd7860ee3e62b3f86ab222647dfcaae4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Rik, thanks for backout it, I'm investigating it
Rik, I can't reproduce on my mac, could you checkout commit e6f7bfd0c2f1e302375951d3a612c117e94a054c and paste log to me? thanks!
Flags: needinfo?(anthony)
Here is the output of make install-gaia:

adb remount
remount succeeded
XULrunner directory: xulrunner-sdk-26/xulrunner-sdk
run-js-command  preferences
Exception: TypeError: webapp is undefined
execute/<@resource://gre/modules/commonjs/toolkit/loader.js -> file:///Users/rik24d/code/gaia/build/preferences.js:29
execute@resource://gre/modules/commonjs/toolkit/loader.js -> file:///Users/rik24d/code/gaia/build/preferences.js:28
@-e:1

make: *** [preferences] Error 3
Flags: needinfo?(anthony)
okay I can reproduce it if create a directory with any name in apps/ and travis is green :-)

https://travis-ci.org/mozilla-b2g/gaia/builds/18777866
Created attachment 8375410 [details] [review]
github PR: https://github.com/mozilla-b2g/gaia/pull/16235

previous I used Array.map() to get all webapp in |utils-xpc.js:makeWebappsObject()| but I should filter webapp if it doesn't exist.

now using Array.forEach() and push webapp into apps if exists.
Attachment #8373934 - Attachment is obsolete: true
Attachment #8375410 - Flags: review?(timdream)
Attachment #8375410 - Flags: review?(timdream) → review+
Merged again.

https://github.com/mozilla-b2g/gaia/commit/0c44f595055203484d1e8a293d9724ab609f213f
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Depends on: 974376

Updated

4 years ago
Blocks: 975964
Component: Gaia → Gaia::Build
You need to log in before you can comment on or make changes to this bug.