[settings] add marionette test for Messaging Settings panel

RESOLVED FIXED in 2.0 S5 (4july)

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: gasolin, Assigned: eragonj, Mentored)

Tracking

(Blocks: 1 bug)

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p=2])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Overview Description:

Add marionette test for Messaging Settings panel


Steps to Reproduce:
1) run make test-perf APP=settings
2) run make test-integration APP=settings


Actual Results:

No such integration test for Messaging Settings panel


Expected Results:

Write that integration test and make test pass
(Reporter)

Comment 1

4 years ago
Reproducibility:

100%

Additional Information:

Please refer to bug 956210 for more information.
(Reporter)

Updated

4 years ago
Blocks: 973457

Updated

4 years ago
feature-b2g: --- → 2.0

Updated

4 years ago
feature-b2g: 2.0 → ---
Took this bug.
Assignee: nobody → ejchen
(Reporter)

Updated

3 years ago
Blocks: 969264
(Reporter)

Updated

3 years ago
No longer blocks: 956210
Created attachment 8438909 [details] [review]
patch on master
Comment on attachment 8438909 [details] [review]
patch on master

Hi Evan,

I just added the marionette test for message panel and they will be only run on real devices. 

Can you help me review them ? thanks :)
Attachment #8438909 - Flags: review?(evanxd)

Comment 5

3 years ago
Hi EJ,
I added comments for the PR.
Flags: needinfo?(ejchen)
@Evan I put some comments on the PR to respond your questions, can you check them ? 

Thanks !! (Please ni? me again after reading, thanks!)
Flags: needinfo?(ejchen)
Whiteboard: [p=2]

Comment 7

3 years ago
Hi EJ,

I add comments in the PR. And please make sure the test work well on the device. Thanks.b
Flags: needinfo?(ejpbruel)
Target Milestone: --- → 2.0 S5 (4july)
Evan, I just updated the patch, can you help me take a look again !?

Thanks for your reviewing :)
Flags: needinfo?(ejpbruel) → needinfo?(evanxd)

Comment 9

3 years ago
Hi EJ,

Please remove the useless method.

Thanks.
Flags: needinfo?(evanxd) → needinfo?(ejchen)
Comment on attachment 8438909 [details] [review]
patch on master

And I have a nit[1] for the patch. Then the patch looks good to me.

[1] https://github.com/mozilla-b2g/gaia/pull/20404/files#diff-53b9917eccadbda2e8703e017a078fcaR20
Attachment #8438909 - Flags: review?(evanxd) → review+
Ok just removed them ! Thanks Evan :]
Flags: needinfo?(ejchen)
Thanks all !

Just merged this into Gaia/master : d0c2cfb7e5b4fa4ef4d9db22d2daa7cfe7e4b05a
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 981523
Mentor: ejchen@mozilla.com
Duplicate of this bug: 981524
Duplicate of this bug: 981525
Duplicate of this bug: 981526
Duplicate of this bug: 981527
Duplicate of this bug: 981528
You need to log in before you can comment on or make changes to this bug.