Closed Bug 968679 Opened 7 years ago Closed 7 years ago

[settings] add marionette test for Sound panel

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S2 (28feb)

People

(Reporter: gasolin, Assigned: gasolin)

References

Details

(Whiteboard: [ft:system-platform])

Attachments

(1 file)

Overview Description:

Add marionette test for Sound panel


Steps to Reproduce:
1) run make test-perf APP=settings
2) run make test-integration APP=settings


Actual Results:

No such integration test for Sound panel


Expected Results:

Write that integration test and make test pass
Reproducibility:

100%

Additional Information:

Please refer to bug 956210 for more information.
Assignee: nobody → gasolin
Blocks: 969265
https://github.com/mozilla-b2g/gaia/pull/16112 wait for travis 30x result
remove the Audible touch tones select option test since it's come from fowardlock and not available in B2G desktop.
tests fails in calendar day view but looks fine for sound test
Attachment #8374584 - Flags: review?(evanxd)
Attachment #8374584 - Flags: review?(arthur.chen)
Test case: Change the "Vibrate" item.
>> Make sure the mozSettings value is correct.

Test case: Change the volume of the "Ringer & Notifications" item.
>> Make sure the mozSettings value is correct.

Test case: Change the volume of the "Alarm" item.
>> Make sure the mozSettings value is correct.

Test case: Change all of the "Other sounds" item.
>> Make sure the mozSettings value is correct.

If have any question, please discuss here.
Thanks. :)
Comment on attachment 8374584 [details] [review]
pull request redirect to github

Hi Gasolin,

We could review the patch, after we do the test case spec.
Thanks. :)
Attachment #8374584 - Flags: review?(evanxd)
Comment on attachment 8374584 [details] [review]
pull request redirect to github

filled checkedbox check, need do the slider check before review
Attachment #8374584 - Flags: review?(arthur.chen)
Blocks: 973445
Whiteboard: [ft:system-platform]
Target Milestone: --- → 1.4 S2 (28feb)
added slider test by monitoring slider tap action, which should change the current setting state
Comment on attachment 8374584 [details] [review]
pull request redirect to github

All green.

for marionette_js_stable_check it pass 20 times without error before timeout
https://api.travis-ci.org/jobs/19305299/log.txt?deansi=true

It's timeout for 50min because of there are too many test cases in sound panel.
Attachment #8374584 - Flags: review?(evanxd)
Attachment #8374584 - Flags: review?(arthur.chen)
Comment on attachment 8374584 [details] [review]
pull request redirect to github

r=me with the comments addressed, thanks!
Attachment #8374584 - Flags: review?(arthur.chen) → review+
merged to gaia-master https://github.com/mozilla-b2g/gaia/commit/e863025d0bcdd468011aa4604f25a0f720f99c7f
thanks!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8374584 [details] [review]
pull request redirect to github

Thanks for Arthur's review.
Attachment #8374584 - Flags: review?(evanxd)
You need to log in before you can comment on or make changes to this bug.