hamachi thinks it has no SIM running v1.3 (telephony/messages broken, mobile data still works) when "Network Type" is set to "Automatic"

RESOLVED DUPLICATE of bug 990383

Status

RESOLVED DUPLICATE of bug 990383
5 years ago
4 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

On Tuesday I flashed gecko and gaia to my hamchi with an updated self-built user build of v1.3.  So I'm running gecko 4227240a4d3e1e418ced160c2a48cb454d7b5645 and gaia bb36b4164d3e51ca04b612e507e1178f80bf240d.

On Wednesday afternoon, after a reboot, my phone went into a state where it shows the "no SIM card" icon, "(no SIM)" on the lockscreen, and a no SIM message after boot.  But mobile data still works fine.  Rebooting the phone again doesn't fix the problem.

I'm not 100% sure which RIL I'm using, since I've only ever flashed gecko and gaia to this device.  Though I think I'm using the commercial RIL, since adb logcat has messages like this in it:
D/QCRIL_RPC(  143): Enter qcril_sms_cfg_event_callback
D/QCRIL_RPC(  143): Exit qcril_sms_cfg_event_callback
D/QCRIL_RPC(  143): Enter qcril_sms_cfg_event_callback
D/QCRIL_RPC(  143): Exit qcril_sms_cfg_event_callback

Mobile data works fine.  Sending a text message does not work; receiving a phone call also does not work.
(I realize it's possible that this is because of a setting that I touched -- it was set to WCDMA, and I thought I'd bumped into it and accidentally changed it -- so I changed it back to Auto.  But I can't get back to that settings screen at all in the current state the phone is in.)
I rolled back the settings DB and rebooted, so that doesn't seem to be it.

Also, it turns out that I can make and receive phone calls, and receive texts (but not send them).  (Cell reception at my desk isn't very good -- probably why I didn't receive the call when I tested earlier.)
The phone went back to thinking it had a SIM very briefly today right after I updated it with a new build.  But then after a reboot, it went back to the no-SIM state.
Well, this makes a *little* more sense:

If I do "adb shell stop b2g" and then "adb shell start b2g", then the phone acts normal again (thinks it has a SIM card).

If I do "adb reboot" or use the reboot UI from a long press on the power button, then this bug's symptoms return.
But now that I can use the settings again, if I go to Settings -> Cellular & Data -> Network Type and set it back to "WCDMA preferred" rather than "Automatic", then the problem appears to be better.

So I think there are two problems here:

 (1) Choosing "Automatic" (which looks like the default) makes the phone think (in some ways) that it has no SIM card

 (2) when it's in that state, it's not possible to get back to the settings UI to undo the damage
Summary: hamachi thinks it has no SIM running v1.3 (telephony/messages broken, mobile data still works) → hamachi thinks it has no SIM running v1.3 (telephony/messages broken, mobile data still works) when "Network Type" is set to "Automatic"
Nominating to see if other people think this is something we should care about.
blocking-b2g: --- → 1.3?
Can someone check what the behavior is here for 1.1?
Keywords: qawanted

Comment 8

5 years ago
this bug is very similar to this issue bug 960327, if this is a dupe, than it reproduces on 1.1 as well

Updated

5 years ago
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 960327

Updated

5 years ago
Keywords: qawanted

Comment 10

5 years ago
To recover it,
1). Restart b2g by "adb shell stop b2g" and "adb shell start b2g".
2). Go to "Settings -> Cellular & Data -> Network Type".
3). Set "Network Type" back to "WCDMA preferred".
4). Reboot device.

Comment 11

5 years ago
Reopen it for tracking "Network Type" problem.

Please see bug 960327 comment #13.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 12

5 years ago
BTW I found airplane mode off/on can recover it.
But you need to change "Network Type" back to "WCDMA preferred", otherwise device won't detect sim again after reboot.

Comment 13

5 years ago
(In reply to Jason Smith [:jsmith] from comment #10)
> Ken - Is there anyone you could recommend here that could give input here on
> what a user could do workaround this problem? I want to see if we can get a
> user doc written up here on SUMO in case someone else hits this.

Hi Jason, answer you question here.
I found it can be recovered by airplane mode off/on, please see comment #12.

Thanks.

Comment 14

5 years ago
Created attachment 8387461 [details]
buri_network_type.txt

In "automatic" network type, modem of buri will report radio tech as "cdma" when we try to get radio tech, but it is a gsm card inserted, so gecko maps sim status to "null".

====
03-07 15:39:31.579   136   290 I Gecko   : RIL Worker[0]: Handling parcel as REQUEST_VOICE_RADIO_TECH
03-07 15:39:31.579   136   290 I Gecko   : RIL Worker[0]: Radio tech is set to: 1xrtt, it is a cdma technology

03-07 15:39:31.699   136   290 I Gecko   : RIL Worker[0]: iccStatus: {"cardState":1,"universalPINState":0,"gsmUmtsSubscriptionAppIndex":0,"cdmaSubscriptionAppIndex":-1,"imsSubscriptionAppIndex":-1,"apps":[{"app_type":2,"app_state":4,"perso_substate":2,"aid":"a0000000871002f886ff9289050b00ff","app_label":"434854","pin1_replaced":0,"pin1":3,"pin2":1}]}
03-07 15:39:31.709   136   136 I Gecko   : -*- RILContentHelper: Received message 'RIL:CardStateChanged': {"clientId":0,"data":{"rilMessageType":"cardstatechange","cardState":null}}
====

And the reason that restarting b2g or airplane mode works is because we can get correct radio tech via "REQUEST_VOICE_RADIO_TECH".

[1] https://github.com/mozilla-b2g/platform_hardware_ril/blob/master/include/telephony/ril.h#L3801-L3811

Comment 15

5 years ago
IMHO, Buri should show only "GSM" or "WCDMA" related option in "Network Type" [1] but it seems system properties doesn't be setup correctly. [2]

If the system properties set correctly, "Network Type" won't show invalid options and user won't have chance to select an invalid setting.

[1] Gaia will only show "supported" type in "Network Type", please see bug 950185.
[2] Please see bug 960906

Updated

5 years ago
Depends on: 950185, 960906

Comment 16

5 years ago
Hi sarsenyev,

Could you help test latest 1.3 again with following step?
1). If your device had this issue, please recover it by following comment #12.
2). Add one line, "ro.moz.ril.0.network_types=gsm,wcdma", in "/system/build.prop".
    ((This makes configuration correct))
3). Reboot device.
4). Test it again.

Thank you
Flags: needinfo?(sarsenyev)

Comment 17

5 years ago
This change is solve the problem, but a little bit tricky, after I pushed the file, the phone is switched to "Automatic" by default, but after restart it showed again "no SIM" error.
When I switched to "3G' network, the phone couldn't connect it, but when switched back to "Automatic" the issue no longer appeared or after restarting or after resetting the network is automatically connects to the network now
Also I tested on 1.4, this push immediately fixed the issue

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140307004004
Gaia: e8bf7326ce5ed63bc8ef8b2cff1eba094887b9bf
Gecko: 4efa30fe00e7
Version: 28.0
Firmware Version: v1.2-device.cfg
Flags: needinfo?(sarsenyev)

Comment 18

4 years ago
We change the default value of |supportedNetworkTypes| to "wcdma/gsm" in bug 990383. It can also fix this bug.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 990383

Updated

4 years ago
Blocks: 1092108
You need to log in before you can comment on or make changes to this bug.