Closed Bug 990383 Opened 6 years ago Closed 6 years ago

[B2G] [RIL] consider to set default value of 'supportedNetworkTypes' as 'wcdma/gsm'

Categories

(Firefox OS Graveyard :: RIL, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:1.4+, firefox29 wontfix, firefox30 fixed, firefox31 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: hsinyi, Assigned: edgar)

References

Details

Attachments

(1 file, 1 obsolete file)

We now use World phone as the default value of supportedNetworkTypes. According to the fact the number of wcdma/gsm phones is larger than world phones, maybe we should use 'wcdma/gsm' instead.
Assignee: nobody → echen
Before we change the default value, emulator needs to be configured with correct value first, otherwise the test case will fail.
Blocks: 990445
No longer blocks: 990445
Depends on: 990445
Attached patch Patch, v1 (obsolete) — Splinter Review
Attachment #8399857 - Flags: review?(htsai)
Comment on attachment 8399857 [details] [diff] [review]
Patch, v1

Review of attachment 8399857 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #8399857 - Flags: review?(htsai) → review+
Blocks: 988979
blocking-b2g: --- → 1.4?
Depends on: 985537
No longer depends on: 990445
Attached patch Patch, v2Splinter Review
Hi Hsinyi,

In this new version, I modify the test case to make it more robust.
1). Get system property configuration by "runEmulatorShell" which was introduced in bug 985537. (The default value will be the same as the one defined in ril_consts.js)
2). Running the tests based on the configuration.

Thank you
Attachment #8400437 - Flags: review?(htsai)
Attachment #8399857 - Attachment is obsolete: true
Comment on attachment 8400437 [details] [diff] [review]
Patch, v2

Review of attachment 8400437 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/mobileconnection/tests/marionette/test_mobile_preferred_network_type.js
@@ +70,2 @@
>  
> +  getSupportedNetworkTypesFromSystemProperties(0, function(testData) {

Truly nice! Thank you :)
Attachment #8400437 - Flags: review?(htsai) → review+
blocking-b2g: 1.4? → 1.4+
For 1.4 branch, we need uplift bug 985537 first.
https://hg.mozilla.org/mozilla-central/rev/d878334f3121
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S5 (11apr)
Depends on: 993066
No longer depends on: 993066
Duplicate of this bug: 969079
You need to log in before you can comment on or make changes to this bug.