Closed Bug 969227 Opened 6 years ago Closed 6 years ago

Handle X-Backoff headers

Categories

(Firefox for Android :: Android Sync, defect)

Firefox 29
All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
fennec 29+ ---

People

(Reporter: rnewman, Assigned: rnewman)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Response headers from the storage and token servers are currently a heady mix of X-Weave* and X-*.

We should handle both, just in case.

https://docs.services.mozilla.com/token/apis.html#response-headers
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Attached file Proposed patch. v1
Attachment #8374315 - Flags: review?(nalexander)
Comment on attachment 8374315 [details] [review]
Proposed patch. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Hurried FxA development.

User impact if declined: 
  Partial Sync implementation.

Testing completed (on m-c, etc.): 
  Automated tests.

Risk to taking this patch (and alternatives if risky): 
  Failure to deliver expected level of quality for Fx29.

String or IDL/UUID changes made by this patch:
  None.

Nick reviewed on GitHub. Landed with tests in a-s.

https://hg.mozilla.org/integration/fx-team/rev/e624202c4fdf
Attachment #8374315 - Flags: review?(nalexander)
Attachment #8374315 - Flags: review+
Attachment #8374315 - Flags: approval-mozilla-aurora?
This isn't something we can easily QA, so flagging qa- for now. If we have a chance to set up a staging token server and somehow point the client at it, then we can give it a shot, but this at least has automated tests.
Whiteboard: [qa-]
Target Milestone: --- → Firefox 30
Blocks: 958900
Well, we do have this: https://token-stage3.stage.mozaws.net
or some flavor of that depending on frequently OPs updates our TS Stage.
Will that work?
(In reply to James Bonacci [:jbonacci] from comment #4)
> Well, we do have this: https://token-stage3.stage.mozaws.net
> or some flavor of that depending on frequently OPs updates our TS Stage.
> Will that work?

If you have the FxA and Sync servers to go with it, so we can do a build of Firefox pointing to those URLs. Might not be wasted effort, because we can use that setup to test Bug 958900, too.
FYI, I will wait for your tests before uplifting the patch.
https://hg.mozilla.org/mozilla-central/rev/e624202c4fdf
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Drat, I accidentally checked in some non-pngcrushed resources here. Will fix.
Duplicate of this bug: 958795
This was tested with Services QA along with Bug 958900 and Bug 972613, Sylvestre. Please flag all three for uplift at your convenience.
Flags: needinfo?(sledru)
Attachment #8374315 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(sledru)
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.