Closed Bug 970929 Opened 7 years ago Closed 7 years ago

Customize network indicator by SIM displayed in Settings -> Cellular & Data -> Network operator -> Network Type

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S2 (28feb)

People

(Reporter: noemi, Assigned: macajc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
kaze
: review+
Details | Review
The list corresponding to the different network types, the specific text, appearing under Settings -> Cellular & Data -> Network operator -> Network type will be customized per operator (based on mcc/mnc). Please refer to Bug 923449.
Blocks: 952026
Depends on: 923449
nominating to 1.4? in order to have consistency on the Network mode shown across all the menus
blocking-b2g: --- → 1.4?
Won't take any feature in this stage for v1.4. Please talk to product team for them to plan it in the next release.
blocking-b2g: 1.4? → 1.5?
This is already in the backlog product for v1.4 as part of the feature: Single variant: Network Display Indicator customization by SIM (bug 923449), this bug covers one of the menus where this technology is displayed. We will implement it in v1.4 time to have the full feature properly set.
blocking-b2g: 1.5? → ---
Hi Bruce,

Could you help to confirm if we want to support this feature in v1.4? Thanks!
Flags: needinfo?(bhuang)
(In reply to Beatriz Rodríguez [:brg] from comment #3)
> This is already in the backlog product for v1.4 as part of the feature:
> Single variant: Network Display Indicator customization by SIM (bug 923449),
> this bug covers one of the menus where this technology is displayed. We will
> implement it in v1.4 time to have the full feature properly set.

Hi Beatriz,
Do you mean that there are already resources working on this?
Flags: needinfo?(brg)
(In reply to Bruce Huang [:bhuang] <bhuang@mozilla.com> from comment #5)
> (In reply to Beatriz Rodríguez [:brg] from comment #3)
> > This is already in the backlog product for v1.4 as part of the feature:
> > Single variant: Network Display Indicator customization by SIM (bug 923449),
> > this bug covers one of the menus where this technology is displayed. We will
> > implement it in v1.4 time to have the full feature properly set.
> 
> Hi Beatriz,
> Do you mean that there are already resources working on this?
Hi Bruce, our plan is to let Carmen implement this work. She is busy now with other topics but hopefully she will take it in the next sprint.
Flags: needinfo?(brg)
Assignee: nobody → cjc
Whiteboard: [systemsfe]
Target Milestone: --- → 1.4 S2 (28feb)
Duplicate of this bug: 975703
Attached file Proposed patch v1
Attachment #8380396 - Flags: review?(kaze)
This bug solution should behave similar to bug 969642. For this reason, the proposed patch follows the same philosophy
Comment on attachment 8380396 [details] [review]
Proposed patch v1

Looks good to me. Restarting Travis to get complete test results.
Kaze, Travis is green.
Comment on attachment 8380396 [details] [review]
Proposed patch v1

looks good to me, thanks!
Attachment #8380396 - Flags: review?(kaze) → review+
(In reply to Fabien Cazenave [:kaze] from comment #12)
> Comment on attachment 8380396 [details] [review]
> Proposed patch v1
> 
> looks good to me, thanks!

Thanks, are we ready to land?
Flags: needinfo?(cjc)
(In reply to Kevin Hu [:khu] from comment #13)
> (In reply to Fabien Cazenave [:kaze] from comment #12)
> > Comment on attachment 8380396 [details] [review]
> > Proposed patch v1
> > 
> > looks good to me, thanks!
> 
> Thanks, are we ready to land?

Yes, we are. Thanks to all!!
Flags: needinfo?(cjc)
Carmen: Is it possible to write some tests for this? I know Settings doesn't have a lot of coverage but we should improve that.

Reviewers: Please always ask why patches don't include tests.
Needinfo for comment 15.
Flags: needinfo?(cjc)
(In reply to Anthony Ricaud (:rik) from comment #15)
> Carmen: Is it possible to write some tests for this? I know Settings doesn't
> have a lot of coverage but we should improve that.
> 
> Reviewers: Please always ask why patches don't include tests.

Since the deadline is tomorrow, and as agreed between Noemi and Anthony Ricaud..., if you don't mind I'm going to create a followup bug to include the unit tests for this bug, and we can merge this one now. I'll finish the unit tests as soon as possible
Flags: needinfo?(cjc)
Flags: needinfo?(anthony)
Yes, it's reasonable to postpone landing the tests to meet the deadline. But the test work should be prioritised to land soon after. Thanks.
Flags: needinfo?(anthony)
The followup bug 977675 has been created for this bug
Flags: in-testsuite?
https://github.com/mozilla-b2g/gaia/commit/e141462fffe1759c5b4851ded06f130ae32fd88e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Flags: needinfo?(bhuang)
You need to log in before you can comment on or make changes to this bug.