Closed Bug 971029 Opened 6 years ago Closed 6 years ago

[B2G][FTU] Able to launch card view during FTU

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S1 (14feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: nkot, Assigned: kgrandon)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(2 files)

Attached image screenshot
Description:
Tapping in the top of the screen while running FTU will launch card view and the user will be able to close FTU.

Repro Steps:
1) Updated Buri to BuildID: 20140211040200
2) Reset device from Settings to run FTU
3) Tap in the top of the screen (can also try longpress and pull down)

Actual:
The user is able to launch FTU card view

Expected:
The user is unable to launch FTU card view

Environmental Variables:
Device: Buri v1.4 master build, Mozilla RIL
BuildID: 20140211040200
Gaia: 9fc36dde3a4a3c5ca200275b68ffb56b4173bec3
Gecko: d812f80a0f1d
Version: 30.0a1
Firmware Version: v1.2-devices.cfg

Notes:

Repro frequency: 100%
See attached screenshot
Summary: [B2G][FTU] Able to launch card during FTU → [B2G][FTU] Able to launch card view during FTU
This issue has been previously discussed, fixed, and verified in bug 810227, but can be reproduced again.
What happens on 1.1 & 1.3?
Component: Gaia → Gaia::System::Window Mgmt
Keywords: qawanted, regression
It's not happening on 1.3 or 1.1 - unable to launch FTU card view either by longpress home or the status bar area. I'm taking guess that this issue came along with the Rocketbar implementation.   

Buri 1.3
BuildID: 20140211004035
Gaia: 00cd1ae74dfe773a41b55275b0b468a62f35076d
Gecko: 873e98e750bf
Version: 28.0

Buri 1.1
BuildID: 20140207041202
Gaia: c5cb252e5d1aa45d14f3a2ea182e73e2271e4496
Gecko: adaf8883268e
Version: 18.0

Firmware: v1.2-devices.cfg
Keywords: qawanted
blocking-b2g: --- → 1.4?
To confirm, you have to swipe twice to enable the rocketbar in FTU? It looks like you can also activate the utility tray as well. Appears that this may be because of bug 958584.
Blocks: 958584
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
(In reply to Kevin Grandon :kgrandon from comment #4)
> To confirm, you have to swipe twice to enable the rocketbar in FTU? It looks
> like you can also activate the utility tray as well. Appears that this may
> be because of bug 958584.

Correct.
Attached file Github pull request
Attachment #8375061 - Flags: review?(etienne)
blocking-b2g: 1.4? → 1.4+
Whiteboard: [systemfe]
Comment on attachment 8375061 [details] [review]
Github pull request

Walk by and steal the r+ because of FtuLauncher love.
Attachment #8375061 - Flags: review?(etienne) → review+
Awesome, thanks!  Landed: https://github.com/mozilla-b2g/gaia/commit/79b247b3b4de395f5be01e29ee5db9e872f02180
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S1 (14feb)
Whiteboard: [systemfe] → [systemsfe]
You need to log in before you can comment on or make changes to this bug.