Closed Bug 971298 Opened 6 years ago Closed 6 years ago

Want to be able to split off back/fwd from URL bar

Categories

(Firefox :: Toolbars and Customization, defect)

All
Linux
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: glandium, Unassigned)

References

(Blocks 1 open bug)

Details

STR:
   - Start a build without australis with a fresh profile
   - Open the Customize toolbar dialog
   - Move the download button from its default location on the right end of the toolbar to between the back/forward button and the awesomebar/urlbar.
   - Quit
   - Start a build with australis
   - Download button is now at the left-most position.

And now that i wrote all that, I realized this is because the urlbar and the back button are now a single object. So I guess what i really want is, like before, being able to separate back/forward buttons from the urlbar.
Summary: Migration to Australis moves customized download toolbar button → Want to be able to split off back/fwd from URL bar
I'm sorry Mike, but we won't be revisiting the decision to merge the back/forward buttons with the urlbar.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Who do the thousands of us need to contact to tell them Australis is rubbish and actually be heard? Whoever made and performed the poll that made the UX team think this was a good idea seriously needs to learn how to do polls.
Marnick, I'd like to point out that this is bugtracker, not a forum. Please be aware of the Bugilla etiquette when you post a comment: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

If you would like to provide constructive feedback, please subscribe to the firefox-dev mailing list at https://mail.mozilla.org/listinfo/firefox-dev. This is list is moderated, only to prevent abuse and spam.

Thanks for your understanding.
(In reply to marnick.leau from comment #2)
> Who do the thousands of us need to contact to tell them Australis is rubbish
> and actually be heard? Whoever made and performed the poll that made the UX
> team think this was a good idea seriously needs to learn how to do polls.

As an alternative, I can recommend this add-on:

https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer

This add-on enables you to separate and move the back and forward buttons from the URL bar.
Note that "make customization more intuitive" is one of the things mentioned in bug 755598 comment 0, but i hardly see this as making customization more intuitive. In fact, there is no clear indication why you can't move something between the back button and the urlbar, you just see it won't happen. Kind of the same for the couple of buttons for bookmarks. Should I open a bug about making button groups more obvious during customization?
(In reply to Mike Hommey [:glandium] from comment #5)
> Note that "make customization more intuitive" is one of the things mentioned
> in bug 755598 comment 0, but i hardly see this as making customization more
> intuitive. In fact, there is no clear indication why you can't move
> something between the back button and the urlbar, you just see it won't
> happen. Kind of the same for the couple of buttons for bookmarks. Should I
> open a bug about making button groups more obvious during customization?

Are you looking at Aurora or Nightly?
Aurora
(In reply to Mike Hommey [:glandium] from comment #5)
> Should I open a bug about making button groups more obvious during customization?

Yes, please! Thanks for the feedback, Mike.

One thing we did do is bug 879981, which'll gray out the urlbar+buttons combo Customize Mode. But that might not be enough.
(In reply to Mike de Boer [:mikedeboer] from comment #8)
> (In reply to Mike Hommey [:glandium] from comment #5)
> > Should I open a bug about making button groups more obvious during customization?
> 
> Yes, please! Thanks for the feedback, Mike.
> 
> One thing we did do is bug 879981, which'll gray out the urlbar+buttons
> combo Customize Mode. But that might not be enough.

Err, actually, I'm pretty sure we already have a bug on file on making buttons with separators (like the star button) look more 'together'. Please search first.
I would like to echo Marnick's request above: where DOES one go to "participate" in countering the insanely stupid decisions that Firefox has been making, like this? Where DOES one go to be heard? Please direct us there. I'm sorry to violate bugzilla etiquette, but the FAQ does not cover this.
(In reply to bobbuun from comment #11)
> I would like to echo Marnick's request above: where DOES one go to
> "participate" in countering the insanely stupid decisions that Firefox has
> been making, like this? Where DOES one go to be heard? Please direct us
> there. I'm sorry to violate bugzilla etiquette, but the FAQ does not cover
> this.

You can join the discussions we have on the firefox-dev mailing list. See https://wiki.mozilla.org/Firefox/firefox-dev for more information.

Please note that:
- this debate has been had before, both on the aforementioned list, in meetings, and in some of the other bugs involved (non-exhaustive list: bug 755598, bug 940078, and their duplicates). The bar for revisiting is it very high.
- the list is moderated, and adopting a more constructive tone than calling things "insanely stupid" would significantly increase the chances of posts making it through to the list.
Duplicate of this bug: 992296
Duplicate of this bug: 1017151
You need to log in before you can comment on or make changes to this bug.