Closed Bug 97156 Opened 19 years ago Closed 16 years ago

Default search engine should not be Netscape Search

Categories

(SeaMonkey :: Preferences, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bt, Assigned: bugs)

References

()

Details

(Keywords: helpwanted)

The default value to the "Search Internet with" in the
Preferences->Internet_Search->Default_Search_Engine should be changed from
Netscape to Google, the main reasons are:
* Google is a more comprehensive search engine
* Nestscape search engine is full of adverisement and Mozilla shouldn't enforce
this.
* Most users prefer Google, and when not using Google they use AltaVista or
Yahoo, I never heard about someone who prefers netscape search.
* Mozilla isn' t a product from Netscape (although many developers are
@netscape). Let Netscape marketing for them.
has been defined in Bug 29591
Blocks: 14532
I would disagree with this statement: "Most users prefer Google, and when not
using Google they use AltaVista or Yahoo, I never heard about someone who
prefers netscape search."

Check out this page:
http://www.jmm.com/xp/jmm/press/mediaMetrixTop50.xml
(Note it does not break up the web as search engines directly)
It shows that the #1 visited property is "AOL Time Warner Network" - Netscape's
search engine would fall here.

Yahoo does show up as #2.
Google doesn't show up until #15.
Altavista barely creeps onto the list at #44.

A poll of your friends and family may agree with you, and sure I use google.com.
But a large portion of the Internet is aol.com users, and they use aol's search
engine, should we default to search.aol.com?
Status: UNCONFIRMED → NEW
Ever confirmed: true
> * Google is a more comprehensive search engine

Actually, that's wrong, since Netscape uses Google as backend (and even openly
admits so).

> Check out this page:
> http://www.jmm.com/xp/jmm/press/mediaMetrixTop50.xml
> (Note it does not break up the web as search engines directly)
> It shows that the #1 visited property is "AOL Time Warner Network" -
> Netscape's search engine would fall here.

AOL is only number one ISP/website by marketing, not quality.

> Google doesn't show up until #15.

If Google shows up at number 15, then the statistic is questionable.

Anyways, Google is the unquestioned number one in quality, and we should use it.
Netscape is out anyway, since it is just Google + ads + tracking.
Many things in the product have a different default for Netscape vs. Mozilla
since the two have very different audiences. It makes sense that the default
search engine may be one of those things if it's technically feasible.
QA Contact: sairuh → claudius
I found a breakdown by search engine
http://www.searchenginewatch.com/reports/mediametrix.html

#1 Yahoo
#2 MSN
#3 AOL
#4 Lycos
#5 Google
#6 Netscape
etc...

I would think that Yahoo would be a great search engine to start with,
especially since it uses Google for it's non-indexed pages.

I'd prefer if we'd use Dmoz. Why use the best, when you can use your own (and
make it the best)?
I think you guys are missing some important things here, the most important is
not which Search Engine has more hits but which one is best.
Being the best is a matter of content, usabilty and respect to the user. Since
many of the hit race leaders are backed by Google I think it's not that hard to
figure out which one has the most comprehensive content. Than when it comes to
usability or user respect, Google might not be perfect but it is much better
than Nestcape or Yahoo or AOL.
Other thing is that the default value is not a thing users will have to accept
for life, they can easily change it. The question is what is the feeling mozilla
will provide for starters, for ppl who uses the nightly builds (as me). Being
redirected to the Netscapes (or Yahoo or AOL) Search Engine is ot _my_ concept
of great user experience. Google should be the choice because of that.
for my two cents  - I say follow the standard product model and promote your own
dogfood. Just use dmoz as the default choice. Anyone using mozilla as their
browser rather than a branded derivative should know enough to be able to
express a different choice. People realize the default has to be something and
no one would balk if the mozilla organization's browser defaulted to the mozilla
organizations websearch engine.

Point of clarification: Netscape search is its own product - not just an 'N'
slapped over a google search. On the backend, if a netscape search doesn't find
satisfactory results it only then 'falls thorugh' to a Netscape branded google
search - for a more robust user experience. </marketing :-)>
if there's a developer who'd like to implement this, by all means do so!
Assignee: sgehani → nobody
Keywords: helpwanted
Everyone in their right mind agrees that the default on Netscape Search should
be thrown down the drain. Can we just change it to ANYTHING other than that and
later decide if Google or dmoz.org is the best choice?

Joseph Elwell, default to aol.com for search!? You must be joking. It's quiet
possible that the majority of people on the internet use those pages, but it's
not that part of the population that will use Mozilla. If you want that in
Netscape that's your call, but in mozilla aol.com or netscape search has no place.
Summary: "Search Internet with" default should be google → Default search engine should not be Netscape Search
André Dahlqvist : my only point is that google is just as proprietary as the
aol.com search engine. And someone had commented that Mozilla.org should point
to the most popular search engine on the net. And I pointed out that if we
should point to the most popular search engine on the net, then that search
engine is aol.com's.

There's absolutely no reason to say that Netscape or aol.com search engines have
no place in Mozilla when compared to other proprietary search engines.
Having Netscape stuff in mozilla will just create a bigger netscape vs. mozilla
confusion.
I talked to Asa and he said dmoz would be a good choice. And he also mentioned
lxr and bugzilla as alternative defaults.
Has any decision been made regarding this?
dmoz is no better then Netscape search. Last I checked, dmoz was just an AOL
owned yahoo competitor that stole their logo from a browser, and dictated harsh
listing policies on volunteer editors. Neither dmoz or netscape should even be
INCLUDED in the download.

The fix here is remove netscape, dmoz, and yet, even google. Default search to
bugzilla or LXR. Google and netscape and dmoz can detect browsers (like google
does already for MS IE) and offer the search plugin. It installs via JS. Simple.

We just need to make it store the search plugin *IN THE PROFILE*. I don't want
to do this every day, even if the user I run mozilla as DID have write access to
the install directory. Then you go to $FAVORITE_THIRD_PARTY_SEARCH_SERVICE once,
click a link, and you're set. No worries about mozilla.org favoritism.
Jeremy M. Dolan: Never everybody will be happy with the choice we make. I'd say
that bugzilla is a nonsense plugin, since it shows only the numbers in the
sidebar and what you search for is not the summary but the owner e-mail address.
LXR is something ownly developpers need, so I don't know why it should be
default. After all, there are a lot of _testers_ out there, who don't know what
LXR is.

My point is, let's use the plugin most of the people default to, that is Google.
If anyone has a doubt about that, I suggest to run a poll on Mozillazine. But
from the feedbacks I've got (as project owner of Mycroft
http://mycroft.mozdev.org ), it's Google.

Storing the search plugins in the profile is bug 123315
And for those who want Altavista or Yahoo, the plugins are available at mycroft.
The endless rants by some posters in this bug really hit my nerves. I would
title this bug "someone in Brazil with too much time on his hands".

Nobody is forcing anyone to use anything, YOU CAN CHANGE THE DEFAULT to whatever
you like/want.

Since mozilla.org is netscape.com's pet project, I think they deserve a MINIMUM
RIGHT to steer it and decide silly things as one little tiny default, among many
OPTIONS that the product provides.

In short, I'm tired of all the Netscape-bashing. AOL has spent a lot of money
developing Mozilla -- true, there's some amount of outside development, but the
bulk of it has been funded by AOL for use in their Netscape product. The least
you can do is lend a few kind words. 

Personally, I use the Netscape-branded browser on the windows, solaris and linux
platforms (Netscape 7 is a very good browser on all three platforms) and I use
their portal site. You should, too. 

All of this stupid Slashdotter groupthink of "Mozilla good, Netscape bad!"
completely ignores the fact that if there were no Netscape, there would be no
Mozilla. Or the more likely scenario -- if AOL hadn't acquired Netscape,
Netscape might have gone out of business without the backing of a big tech
player, and most of you would be using Mozilla 0.2 right now.

Give Netscape some credit, folks. They're trying to be a good open source
citizen. Don't disappoint them with a childish "take take take" attitude.
Perhaps it's time to look at this again.  

Netscape search is suboptimal, due to the extra bandwidth involved.

http://www.google.com/search?q=fish                      4873 bytes
http://search.netscape.com/nscp_results.adp?query=fish  23960 bytes

that's not counting images. The results are curiously different, 
but that is not in itself a bug.


->me
Assignee: nobody → asa
->default contacts
Assignee: asa → bugs
QA Contact: claudius → sairuh
This is kind of fixed by bug 225490. Netscape Search has already been removed,
some work is on the way to finalize the switch to Google.
Bug 225490 fixed this.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.