Closed Bug 971696 Opened 7 years ago Closed 7 years ago

[v1.3][Cost Control] No data usage is available in notification bar or app

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S1 (14feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: RobertC, Unassigned)

References

Details

(Keywords: regression, smoketest, Whiteboard: [fromAutomation][mwcdemo2014])

Attachments

(2 files)

Attached image data_usage_bar.png
No data usage information is available in the usage app or in the notification bar.

Steps to reproduce:
1. configure usage with default values.
2. turn on data alert
3. set alert limit to 0.1 MB
4. open the browser and navigate through soem sites

Expected result:
Alert is received and usage data is available

Actual result:
No alert is received and the usage application graph is missing.

Gaia      ce17d5eae7b1893ae4397c814b10ae598fcbdb58
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/ab07e61c2eb0
BuildID   20140212004003
Version   28.0
ro.build.version.incremental=eng.zxliu.20130911.142924
ro.build.date=Wed Sep 11 14:29:37 CST 2013
Attached image usage app
Whiteboard: [fromAutomation]
What device was this tested on?
Flags: needinfo?(robert.chira)
I tested this locally on hamachi.
Flags: needinfo?(robert.chira)
blocking-b2g: --- → 1.3?
blocking-b2g: 1.3? → 1.3+
Duplicate of this bug: 971783
Hi,

This bug is fixed with the uplift of bug 922926, which has landed just a minutes ago.

71bc87ffccaa
2013-11-15 11:29 +0800	John Shih - Bug 922926 - Part 2: Implementation. r=gene, r=albert, a=1.3+
Depends on: 922926
Keywords: qawanted
(In reply to Albert [:albert] from comment #5)
> Hi,
> 
> This bug is fixed with the uplift of bug 922926, which has landed just a
> minutes ago.
> 
> 71bc87ffccaa
> 2013-11-15 11:29 +0800	John Shih - Bug 922926 - Part 2: Implementation.
> r=gene, r=albert, a=1.3+

Don't know why that patch landed. That's a dangerous patch to take onto 1.3. I'm following up offline with Naomi about this - seems like something isn't right with the network stats API if large changes are landing this late in the game.
Whiteboard: [fromAutomation] → [fromAutomation][mwcdemo2014]
Hello Albert, what do you need checked from the QAWanted tag?
Flags: needinfo?(acperez)
(In reply to gbennett from comment #7)
> Hello Albert, what do you need checked from the QAWanted tag?

Retest this bug on tomorrow's build to see if it still reproduces.
Flags: needinfo?(acperez)
(In reply to Jason Smith [:jsmith] from comment #6)
> (In reply to Albert [:albert] from comment #5)
> > Hi,
> > 
> > This bug is fixed with the uplift of bug 922926, which has landed just a
> > minutes ago.
> > 
> > 71bc87ffccaa
> > 2013-11-15 11:29 +0800	John Shih - Bug 922926 - Part 2: Implementation.
> > r=gene, r=albert, a=1.3+
> 
> Don't know why that patch landed. That's a dangerous patch to take onto 1.3.
> I'm following up offline with Naomi about this - seems like something isn't
> right with the network stats API if large changes are landing this late in
> the game.

Fabrice & I have decided to back that patch out. We need a regression window to find the regressing patch here & back that out.
No longer depends on: 922926
Hi,

Once Bug 964270 has been backed out from v1.3 branch, this issue is not reproducible anymore, checked in the following scenario:
Device: Hamachi v1.3
BuildId: 20140213154520
Gecko: 2886bd9
Gaia: 58b3fb5
Platform: 28.0

Because of this  marking it as RESOLVED WORKSFORME
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Checked this on multiple devices and am currently still seeing this issue in the following scenario:

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140213004002
Gaia: 999808c18d2fc95f14d65b925f25237e78436f56
Gecko: 6279534238d8
Version: 28.0
Firmware Version: V1.2-device.cfg

Should I reopen this bug, wait to check it on tomorrow's build, or file a new one?
(In reply to Andrew Stole from comment #11)
> Checked this on multiple devices and am currently still seeing this issue in
> the following scenario:
> 
> Environmental Variables:
> Device: Buri v1.3 Mozilla RIL
> BuildID: 20140213004002
> Gaia: 999808c18d2fc95f14d65b925f25237e78436f56
> Gecko: 6279534238d8
> Version: 28.0
> Firmware Version: V1.2-device.cfg
> 
> Should I reopen this bug, wait to check it on tomorrow's build, or file a
> new one?

Could you please wait till tomorrow's build and re-check it?. We generated a new build after patch 964270 was backed out and it worked. Many thanks!
(In reply to Noemí Freire (:noemi) from comment #12)
> (In reply to Andrew Stole from comment #11)
> > Checked this on multiple devices and am currently still seeing this issue in
> > the following scenario:
> > 
> > Environmental Variables:
> > Device: Buri v1.3 Mozilla RIL
> > BuildID: 20140213004002
> > Gaia: 999808c18d2fc95f14d65b925f25237e78436f56
> > Gecko: 6279534238d8
> > Version: 28.0
> > Firmware Version: V1.2-device.cfg
> > 
> > Should I reopen this bug, wait to check it on tomorrow's build, or file a
> > new one?
> 
> Could you please wait till tomorrow's build and re-check it?. We generated a
> new build after patch 964270 was backed out and it worked. Many thanks!

Right - the backout happened post build, so it should reproduce today.

However - the backout here only happen on 1.3, not 1.4, so this isn't fixed. Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
blocking-b2g: 1.3+ → 1.4+
Actually disregard - realized the original dependency Albert cited landed on 1.4, so we should be fine here.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 971764
Tested on today's 1.3 so marking as verified fixed. The data usage is correctly displayed in the Cost Control app and notification bar.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140214004001
Gaia: 22e065f75193f569a78a8ec827b08e1ed520e1b2
Gecko: e3766683210c
Version: 28.0
Firmware Version: V1.2-device.cfg
Status: RESOLVED → VERIFIED
Target Milestone: --- → 1.4 S1 (14feb)
You need to log in before you can comment on or make changes to this bug.