Closed Bug 972327 Opened 6 years ago Closed 6 years ago

'Refresh' and 'Bookmark' buttons are hidden from the url bar; appear on menu-tap

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox27 --- unaffected
firefox28 --- unaffected
firefox29 --- unaffected
firefox30 - verified
fennec 30+ ---

People

(Reporter: cos_flaviu, Assigned: wesj)

References

Details

(Keywords: reproducible)

Attachments

(1 file)

Environment: 
Device: Asus Transformer Tab (Android 4.0.3);
Build: Nightly 30.0a1 (2014-02-13);

Steps to reproduce:
1. Launch fennec;
2. Verify if 'refresh' and 'bookmark' buttons are displayed.

Expected result:
'Refresh', 'Bookmark' and 'Options' buttons are displayed on the right side of the url bar.

Actual result:
Only the 'Options' button is displayed. 
'Refresh' and 'Bookmark' buttons are displayed only after tapping on the 'Options' button.

Note:
This bug is tablet specific.
tracking-fennec: --- → ?
Flags: needinfo?(flaviu.cos)
Last good revision: 1e9f169c9715 (2014-02-06)
First bad revision: dedf12c4e805 (2014-02-07)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1e9f169c9715&tochange=dedf12c4e805
Flags: needinfo?(flaviu.cos)
Keywords: reproducible
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8d7c0ce1b376&tochange=e3b700ce10fc

f69c9b69caab	Wes Johnston — Bug 961954 - Lazy load main menu. r=mfinkle
Summary: 'Refresh' and 'Bookmark' buttons are hidden from the url bar → 'Refresh' and 'Bookmark' buttons are hidden from the url bar; appear on menu-tap
Assignee: nobody → wjohnston
tracking-fennec: ? → 30+
Duplicate of this bug: 972586
Blocks: 961954
Attached patch Patch 1Splinter Review
I'm debating what to do here a little, but a big part of me wants to just explicitly add these items to the actionbar on tablets.

This is the alternative, just initialize the menu on tablet devices. Its simple and we can land it now to fix the regression.
Attachment #8376045 - Flags: review?(mark.finkle)
Comment on attachment 8376045 [details] [diff] [review]
Patch 1

This seems safe enough for now.
Attachment #8376045 - Flags: review?(mark.finkle) → review+
Flags: needinfo?(wjohnston)
(In reply to Wesley Johnston (:wesj) from comment #4)
> Created attachment 8376045 [details] [diff] [review]
> Patch 1
> 
> I'm debating what to do here a little, but a big part of me wants to just
> explicitly add these items to the actionbar on tablets.
> 
> This is the alternative, just initialize the menu on tablet devices. Its
> simple and we can land it now to fix the regression.

I get the following error trying to build with this patch:

/home/wag/mozilla/mozilla2/mobile/android/base/BrowserApp.java:896: cannot find symbol
symbol  : variable Window
location: class org.mozilla.gecko.BrowserApp
            onCreatePanelMenu(Window.FEATURE_OPTIONS_PANEL, null);
                              ^
Yeah. I'd been working on two different patches for this bug and that was in the second :)

https://hg.mozilla.org/integration/fx-team/rev/2f13d537fd49
Flags: needinfo?(wjohnston)
https://hg.mozilla.org/mozilla-central/rev/2f13d537fd49
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Verified as fixed in build Nightly 30.0a1 (2014-02-20);
Device: Google Nexus 7 (Android 4.4.2).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.