Closed Bug 972791 Opened 7 years ago Closed 7 years ago

[NFC] landscape NFC shrinking UI background has some issue

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
1.4 S5 (11apr)

People

(Reporter: wachen, Assigned: gweng)

References

Details

(Whiteboard: [mwcdemo2013])

Attachments

(6 files)

lastest(2/14) mako build on master branch

steps:
0. enable NFC
1. launch browser
2. turn the phone to landscape view, and tap phones together

expected result:
the shrinking UI background comes out without issues

actaul result:
the shrinking UI background divided into two image background

   -----------
   |    |    |
   |    |    |
   -----------

portrait mode background

   ---------
   |    |  |
   |    |  |
   |    |  |
   |    |  |
   |    |  |
   ---------
Please see bug 972729 for image reference
It is not blocking bug 894678. But, you can see the image in 894678 for background reference
No longer blocks: 894678
Summary: [NFC] landscape NFC shrinking UI has some issue → [NFC] landscape NFC shrinking UI background has some issue
Whiteboard: [mwcdemo2013]
blocking-b2g: --- → 1.5?
Greg, can you please take this bug?
Assignee: nobody → gweng
Blocks: NFC-Gaia
No longer blocks: b2g-NFC-2.0
I remember that this bug need to be solved *after* we define how the phone react (for NFC) while rotation. John and I had discussed this before, so I can paste the discussion here later.
I think for all UX design related issue, please get UX designer and/or visual designer for discussion.
NFC UX will be Juwei and I think Fang can provide a graph if she has some free time or so.
This issue is caused by we screenshoting the app as the sliding image, and the screenshot won't follow app to do rotation. I just confirm this with John that Alive has said that we should ban the rotation during NFC sharing (which is weird and a edge case) to solve this issue. But I'll confirm this with UX and post the conclusion here.
Oh wait. I paste comment on the wrong error...(they're both about rotation)...
The bug I mentioned is Bug 959052.
---
I've discussed this bug (972791) with Walter sever minutes ago. It would not happen on the current Gaia, but the background images seems got missed and only left black. I'll attach some images here.
Attached image Portrait1
Attached image Protrait2
Attached image Landscape1
Attached image Landscape2
I've found that this bug concerns two issues:

1. Homescreen now seems displayed behind the shrinking app's layer. If I set homescreen with |display:none|, the |background-image| would show the image again.

2. The background image need an one-line fix: |background-size: contain|. After applied this, the 'line' would disappear.
I would ask Alive how to solve the homescreen issue. Either we hide the homescreen during sharing or make a 'background' DOM element to display the background.
Hope this bug can be fixed before 5/9.
blocking-b2g: 1.5? → ---
Target Milestone: --- → 1.5 S1 (9may)
Attached file Patch
Add two methods on HomescreenWindow, and update the background CSS.

I've found the landscape background image missing the 1.5X file, so I would ask UX to provide it. I think I can update the patch to attach the new file, and it hinder no review.
Attachment #8399859 - Flags: review?(alive)
Comment on attachment 8399859 [details] [review]
Patch

r+ with nits
Attachment #8399859 - Flags: review?(alive) → review+
The patch updated. Now waiting the Travis.
And I found the original images. So there is no need to NI UX.
Well, no. I misunderstood. I still need the landscape 1.5x background image from UX.
Flags: needinfo?(jhuang)
Attached the landscape background graphics at 1.5x, Thanks!
Flags: needinfo?(jhuang)
Travis is green:

https://travis-ci.org/mozilla-b2g/gaia/builds/22073661

I'll land it after I push the patch with the image file.
master: https://github.com/mozilla-b2g/gaia/commit/8c79ddae58b5e15533707602fcc1d1d1fbcf215b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: 1.5 S1 (9may) → 1.4 S5 (11apr)
Verified on 2014/4/16 pvt build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.