Startup crash in mozilla::layers::Compositor::SetBackend(mozilla::layers::LayersBackend)

VERIFIED FIXED in Firefox 30

Status

()

--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: whimboo, Assigned: billm)

Tracking

({crash})

30 Branch
mozilla30
All
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(firefox30- verified)

Details

(Whiteboard: [mozmill], crash signature)

(Reporter)

Description

5 years ago
We are experiencing massive startup crashes of Firefox Nightly on our OS X machines today. Maybe a recent change is causing this. I will do some quick spotchecks and might have a pushlog in a bit.

report: bp-854c1bee-7e73-41b1-80d9-206312140214.

Crash Reason 	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address 	0x0

Frame 	Module 	Signature 	Source
0 	XUL 	mozilla::layers::Compositor::SetBackend(mozilla::layers::LayersBackend) 	gfx/layers/Compositor.cpp
1 	XUL 	mozilla::layers::CompositorParent::InitializeLayerManager(nsTArray<mozilla::layers::LayersBackend> const&) 	gfx/layers/ipc/CompositorParent.cpp
2 	XUL 	mozilla::layers::CompositorParent::AllocPLayerTransactionParent(nsTArray<mozilla::layers::LayersBackend> const&, unsigned long long const&, mozilla::layers::TextureFactoryIdentifier*, bool*) 	gfx/layers/ipc/CompositorParent.cpp
3 	XUL 	mozilla::layers::PCompositorParent::OnMessageReceived(IPC::Message const&, IPC::Message*&) 	obj-firefox/x86_64/ipc/ipdl/PCompositorParent.cpp
4 	XUL 	mozilla::ipc::MessageChannel::DispatchSyncMessage(IPC::Message const&) 	ipc/glue/MessageChannel.cpp
5 	XUL 	mozilla::ipc::MessageChannel::OnMaybeDequeueOne() 	ipc/glue/MessageChannel.cpp
6 	XUL 	MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) 	ipc/chromium/src/base/message_loop.cc
7 	XUL 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc
8 	XUL 	base::MessagePumpDefault::Run(base::MessagePump::Delegate*) 	ipc/chromium/src/base/message_pump_default.cc
9 	XUL 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
10 	XUL 	base::Thread::ThreadMain() 	ipc/chromium/src/base/thread.cc
11 	XUL 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc
12 	libSystem.B.dylib 	_pthread_start 	
13 	libSystem.B.dylib 	thread_start 	
14 	XUL 	XUL@0x2b38e0
(Reporter)

Comment 1

5 years ago
So yes, yesterdays build is working fine. But todays one is crashing on OS X 10.6 all the time with the above stack.

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a62bde1d6efe&tochange=d275eebfae04

This is a regression from bug 963952 which added this line:
http://hg.mozilla.org/mozilla-central/diff/f78468f352e4/gfx/layers/Compositor.cpp
status-firefox30: --- → affected
tracking-firefox30: --- → ?
(Reporter)

Updated

5 years ago
Blocks: 963952
(Reporter)

Comment 2

5 years ago
This might only happen on 10.6. Other versions (10.7 up to 10.9) don't seem to be affected. The machines we have are all Mac Mini's.
Henrik, I changed the assertion to a printf in https://bugzilla.mozilla.org/show_bug.cgi?id=963952#c20. It would be very helpful if you could test a build with that changeset. If you run in the Terminal, you should see a line like this:

ERROR: Changing compositor from X to Y.

It would help to know the values of X and Y that you see.
(Reporter)

Comment 4

5 years ago
Bill, I have filed my observation as bug 973523. The crash itself is gone with your latest backout on inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/b2fc3f9509b0
Assignee: nobody → wmccloskey
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox30: affected → fixed
Resolution: --- → FIXED
Whiteboard: [mozmill][qa-automation-blocked]
(Reporter)

Updated

5 years ago
Duplicate of this bug: 973071
(Reporter)

Updated

5 years ago
Whiteboard: [mozmill][qa-automation-blocked] → [mozmill]
Target Milestone: --- → mozilla30
crash stats shows reports for 20140214 and 20140215.
Status: RESOLVED → VERIFIED
status-firefox30: fixed → verified
tracking-firefox30: ? → -
You need to log in before you can comment on or make changes to this bug.