Closed Bug 973454 Opened 6 years ago Closed 6 years ago

[settings] refactor App permissions panel with AMD pattern

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S6 (25apr)

People

(Reporter: gasolin, Assigned: gduan)

References

Details

Attachments

(3 files)

Overview Description:

Refactor App permissions panel with AMD pattern referring to
https://github.com/crh0716/gaia/tree/settings2_iterative

to make it modularize and more easier to maintain

Steps to Reproduce:
1) run make test-perf APP=settings
2) run make test-integration APP=settings


Expected Results:

pass all settings test and act the same as original implementation

Additional Information:
Assignee: nobody → gduan
Status: NEW → ASSIGNED
Attached file PR to master
waiting for travis.
Comment on attachment 8402541 [details] [review]
PR to master

Hi Arthur,
could you help me to review this patch?
Thanks.
Attachment #8402541 - Flags: review?(arthur.chen)
Comment on attachment 8402541 [details] [review]
PR to master

Great work, George! Please check my github comments, thanks!
Attachment #8402541 - Flags: review?(arthur.chen)
Comment on attachment 8402541 [details] [review]
PR to master

Hi Arthur,
patch is updated as you suggested. Please kindly check again, thanks!
Attachment #8402541 - Flags: review?(arthur.chen)
Blocks: 956210
Target Milestone: --- → 1.4 S6 (25apr)
Comment on attachment 8402541 [details] [review]
PR to master

Thank you for working on this, George! Please check my comments in github.
Attachment #8402541 - Flags: review?(arthur.chen)
Comment on attachment 8402541 [details] [review]
PR to master

Hi Arthur,
thanks for your reviewing. I think all issues are already addressed. Thanks.
Please kindly check again.
Attachment #8402541 - Flags: review?(arthur.chen)
Comment on attachment 8402541 [details] [review]
PR to master

We are almost there. There are a few issue but should be easy to fix. Please check my comments, thanks!
Attachment #8402541 - Flags: review?(arthur.chen)
Comment on attachment 8402541 [details] [review]
PR to master

Hi Arthur,
thanks for your comments, I just addressed, plz kindly check again.
Attachment #8402541 - Flags: review?(arthur.chen)
Comment on attachment 8402541 [details] [review]
PR to master

r=me, thank you for the effort!
Attachment #8402541 - Flags: review?(arthur.chen) → review+
Thanks Arthur,
merge to master
https://github.com/mozilla-b2g/gaia/commit/fab96691c62543b0277cbb28bef195f9a0bd7595
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
sorry, had to revert this change because it might have caused https://tbpl.mozilla.org/php/getParsedLog.php?id=38308895&tree=B2g-Inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file PR to master 2
Previous pr has passed travis test.
It seems that tbpl has different gaia-ui test.
I'll put to try server later.
George, on TBPL the size of the font is different, sometimes makes the buttons different sized. Marionette may not be tapping on the menu option correctly.
merge to master again,
https://github.com/mozilla-b2g/gaia/pull/18565
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Sorry George, 

I have to revert your patch because yours got overlapped with mine (got backedout with one test failure).

Commit: 972ea2e91ed2938fc1a35672cc9047c0e51d4364
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Merge to master,
https://github.com/mozilla-b2g/gaia/commit/cadddcac2b8ce162a5e27e6dc105557b00a94478
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Depends on: 1024940
You need to log in before you can comment on or make changes to this bug.