Closed Bug 9737 Opened 21 years ago Closed 20 years ago

IMAP: Plain text editor adds extra ">" when replying to html msg

Categories

(MailNews Core :: Composition, defect, P3)

PowerPC
All
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: pmock, Assigned: rhp)

References

Details

Build Date & Platform Bug Found:
  Mac Seamonkey commercial build (1999-07-12-08) installed on PPC 9600 OS 8.5.1
  Win32 Seamonkey commercial build (1999-07-12-08) installed on win32 Win98
  Linux Seamonkey commercial build (1999-07-12-08) installed on Compaq P200 RH5.2

Overview Description:
  Under IMAP, when using the plain text editor to reply to a HTML message, the
entire message is quoted but it adds extra delimiters or ">" to the first line.
The rest of the message body does not have ">" added.  This problem occurs on
Win32, PPC, and Linux.  The behavior is the same on all platforms.

Steps to Reproduce:
0) Configure your Pref50.js to use a plain text editor
      user_pref("mail.identity.id1.compose_html", true);
   Your mail server is configured for IMAP
1) Start Apprunner
2) Open Messenger through the component bar or task menu
3) Select a rich text message
   The message should display in the message pane
   (Note: if you do not have a HTML message to quote, use Nova to send you a rich
text message then retrieve and select the rich text message)
4) Click on the reply button
   The entire message is quoted but it has extra ">" added to the first line.
The rest of the message body does not contain any ">" characters.

Actual Results:
  It adds delimiters ">" only to the first line of the message body.

Expected Results:
  The entire message should have been quoted with ">" characters

Additional Information:
  Under POP, the behavior is different.  It quotes only the message header and
fails to quote the message body. I have filed a separate bug 9736.
Assignee: ducarroz → rhp
Summary: IMAP: Plain text editor adds extra ">" when replying to html msg → IMAP: Plain text editor adds extra ">" when replying to html msg
reassign to Rich
Status: NEW → ASSIGNED
Target Milestone: M9
Will investigate.

- rhp
Blocks: 9539
Target Milestone: M9 → M10
Just an update:

This feature is dependent on bug #9539 and this won't be addressed until M10.
Also, what you are seeing behavior wise in this bug is from the hack we have in
place to get SOME text when quoting. All of this will change substantially when
we have the new quoting in place and the Ender team finishes their rework on
the Plain Text editor.

- rhp
Bulk move rhp bugs to M11 for now
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
This works for me now.
QA Contact: lchiang → huang
Change QA Contact to me.
Status: RESOLVED → VERIFIED
Verified on the 10-13-09-M11/all platforms/IMAP server:

Passed by retest on all the platforms!
The reply message already added the additional delimiters.
(In 5.0, it already changed to "|" instead of ">")
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.