Closed Bug 974232 Opened 7 years ago Closed 5 years ago

Playing <audio> that is attached to a MediaElementSourceNode causes popping noise initially

Categories

(Core :: Web Audio, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox28 --- unaffected
firefox29 --- affected
firefox30 --- affected

People

(Reporter: rfw, Unassigned)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached file testcase.html
When an <audio> element is attached to an AudioContext via a MediaElementSourceNode, calling play() on the element causes a loud popping noise when it initially starts playback.

It occurs consistently on the 2014-02-18 Nightly, but not on m-c d812f80a0f1d.
Attached audio small-shot.ogg
Sorry, here's small-shot.ogg which is just from content/media/webaudio/tests.
Here's a test case using the version of small-shot.ogg uploaded to Bugzilla. I can't actually seem to get it to play in Firefox, but it works in Chrome.
Same domain restrictions mean the testcase will only play when loaded from this bug's domain.  It don't hear any difference between my Linux build and Fx 27.
Anthony -- This may affect games.  Can you or someone on your team try to repro this on Mac or Windows?
Flags: needinfo?(anthony.s.hughes)
Keywords: qawanted
This may be Mac OSX only as I cannot reproduce a bug here on Windows 8.1. The testcase sounds exactly the same to me on today's Nightly as it does in Firefox 27.0.1. I'll give it a go on my Mac.
Flags: needinfo?(anthony.s.hughes)
I am able to reproduce a distinct "crackle" on Mac OSX and *only* on Mac OSX. I'll see if I can narrow down the regression window.
QA Contact: anthony.s.hughes
There's actually two phases to this bug. We start with no sound artifacts as of 2013-12-12, seriously degrade to prolonged crackling and stuttering starting on 2013-12-13, then marginally improve to a slight crackle on reload starting on 2014-02-04.

2014-12-12 [Firefox 29]: no sound artifacts
2014-12-13 [Firefox 29]: prolonged crackle and stuttering
2014-02-03 [Firefox 29]: prolonged crackle and stuttering
2014-02-04 [Firefox 30]: slight crackle on reload

Pushlog for 2013-12-12 to 2013-12-13:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1ad9af3a2ab8&tochange=8b5875dc7e31

Pushlog for 2013-02-03 to 2013-02-04:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=44ba69cacd7e&tochange=c150845d077d
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #7)
> Pushlog for 2013-02-03 to 2013-02-04:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=44ba69cacd7e&tochange=c150845d077d

The dates here should be 2014-02-03 to 2014-02-04 (sorry for the typo).
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #7)
> Pushlog for 2013-12-12 to 2013-12-13:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=1ad9af3a2ab8&tochange=8b5875dc7e31
> 
> Pushlog for 2013-02-03 to 2013-02-04:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=44ba69cacd7e&tochange=c150845d077d

I think we should be investigating the original regression since the goal here should be to get back to a known good state (Firefox 29.0a1 on 2013-12-12). Unfortunately this pushlog is rather large and the tinderbox builds only go back to January 18, 2014.
Thank you.  Changes in bug 944707 introduced bug 966867 during the regression range.  966867 was fixed during the improvement range.

It's possible that bug 966867 was responsible for the popping, but I don't know why the previous behaviour has not been restored.

Bug 848954 should fix some crackling that seems to happen most often soon after an AudioContext is created.
Blocks: 944707
Depends on: 848954
Depends on: 989907
The fix for bug 989907 may have helped here.
Trying this on a mac in Fx43, I don't hear any popping.  As such, I'm going to close this; please reopen if it's still an issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.