Closed Bug 989907 Opened 6 years ago Closed 6 years ago

initialize AudioNodeExternalInputStream output chunk even when first track has null output

Categories

(Core :: Web Audio, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: karlt, Assigned: karlt)

References

(Depends on 1 open bug)

Details

Attachments

(2 files)

Sometimes content/media/webaudio/test/test_mediaElementAudioSourceNode.html
content/media/test/crashtests/media-element-source-seek-1.html hit
http://hg.mozilla.org/mozilla-central/annotate/382f676d0ed9/content/media/AudioNodeExternalInputStream.cpp#l447
when i == 0, which would suggest uninitialized memory contributing to or in
mLastChunks.

This might be the cause of bug 974232 and the click reported in bug 944924 comment 6.
Attached patch patchSplinter Review
Attachment #8399269 - Flags: review?(roc)
I started making test_mediaElementAudioSourceNode.html more precise, which would detect one bad block here, but bug 983062 means that the output is too short and so the extra bad block is not detected.  There are other ways to be more precise but bug 983023 would then make such tests fail.  Let's try again once those bugs are fixed.
Depends on: 983023
Flags: in-testsuite?
Depends on: 983062
https://hg.mozilla.org/mozilla-central/rev/e8cf49d6d296
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.