Closed Bug 974261 Opened 6 years ago Closed 6 years ago

Volume buttons stucks

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S2 (28feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: timdream, Assigned: timdream)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #971495 +++

This is a regression of mine. I didn't make sure clearTimeout() gets called.
STR:

Press Volume UP and release

Expected:

1. volume goes up once.

Actual:

1. volume goes up all the way.
Comment on attachment 8378068 [details] [review]
mozilla-b2g:master PR#16436

This is sad because I didn't catch it in manual tests nor unit tests, even when the coverage is 89%....
Attachment #8378068 - Flags: review?(alive)
Comment on attachment 8378068 [details] [review]
mozilla-b2g:master PR#16436

++
Attachment #8378068 - Flags: review?(alive) → review+
Tree is closed so I will leave this open and marked it as checkin-needed.
Status: NEW → ASSIGNED
Keywords: checkin-needed
Regression.
blocking-b2g: --- → 1.4?
Duplicate of this bug: 974375
Keywords: smoketest
I thought my Nexus S was dying. This patches fixes the issue correctly :)
Flags: needinfo?(jhford)
We decided in #b2g that this bug was bad enough to merge onto the closed tree.

Master: 35365feace970bfc51276428f40a477c9c86b7bb
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jhford)
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
blocking-b2g: 1.4? → 1.4+
Duplicate of this bug: 975041
This fixed the issue on Geekpshone Keon.

Thanks!
Status: RESOLVED → VERIFIED
I can confirm that it is fixed.

Alcatel One Touch Fire (production version got from T-mobile Poland)
master 1.4
Platform Version 30.0a1
Build Identifier: 20140220160205
Git Commit info: 2014-02-20 16:12:28
You need to log in before you can comment on or make changes to this bug.