Tab overflow arrows always visible in private browsing

VERIFIED FIXED in Firefox 29

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ge3k0s, Assigned: Gijs)

Tracking

(Blocks 1 bug, {regression, reproducible})

Trunk
Firefox 30
All
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 unaffected, firefox29+ verified, firefox30+ verified)

Details

(Whiteboard: [Australis:P2])

Attachments

(2 attachments)

Since a few Nightlies the overflow arrows in the tab bar are always visible in private browsing, even with one tab open. I remember a bug about this appearing intermittently but I wasn't able to find it and the problem is permanent now.
Whiteboard: [Australis:P2]
Component: Theme → Tabbed Browser
Summary: Overflow arrows always visible in private browsing → Tab overflow arrows always visible in private browsing
Perhaps there is something in the browser console?
Don't see anything in it.
Opened a PB window and I don't see any overflow arrows here using Tinderbox hourly build based on cset: https://hg.mozilla.org/mozilla-central/rev/3762e1037b59

Win7 m-c win32 build
Posted file localstore.rdf
I can reproduce if copy the attached localstore.rdf to new profile.
And reproduce since Australis merge day(2013-11-18build).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Guillaume C. [:ge3k0s] from comment #0)
> Since a few Nightlies the overflow arrows in the tab bar are always visible
> in private browsing, even with one tab open. I remember a bug about this
> appearing intermittently but I wasn't able to find it and the problem is
> permanent now.

bug 962803 ?
(In reply to :Gijs Kruitbosch from comment #5)
> (In reply to Guillaume C. [:ge3k0s] from comment #0)
> > Since a few Nightlies the overflow arrows in the tab bar are always visible
> > in private browsing, even with one tab open. I remember a bug about this
> > appearing intermittently but I wasn't able to find it and the problem is
> > permanent now.
> 
> bug 962803 ?

Not exactly the same since it's permanent here. My private windows always have the arrows visible. Restored mode, maximized mode, one tab or hundred tabs. always here.
I found a STR with newly created profile.

Steps To Reproduce:
1. Start Firefox with newly created profile

2. Enter Customize mode
3. Move SearchBar between tab and [+] in TabBar
4. Exit Customize mode

5. Enter Customize mode
6. Restore Defaults
7. Exit Customize mode

8. Open New Private Window
   --- Problem happens

9. Quit Firefox
10. Restart Firefox
11. Open New Private Window
   --- Problem is persisted and permanent

Actual Results:
Tab overflow arrows appears in Private Window.


Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/e931763f41b5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140208031801
Bad:
https://hg.mozilla.org/mozilla-central/rev/8e51e2b148fd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140208124503
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e931763f41b5&tochange=8e51e2b148fd

Regression window(fx)
Good:
https://hg.mozilla.org/integration/fx-team/rev/167f977b7b9c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140207122201
Bad:
https://hg.mozilla.org/integration/fx-team/rev/a5b39323dc21
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140207130059
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=167f977b7b9c&tochange=a5b39323dc21

Regressed by:
Bug 968891 or Bug 966599
Blocks: 966599
Duplicate of this bug: 970180
Assignee: nobody → gijskruitbosch+bugs
This fixes things for me. Alice, thanks for the super-useful steps to reproduce from comment #7. Note that for step 3, any customization (that enables the 'restore defaults' button) will do.
Attachment #8379665 - Flags: review?(mconley)
Comment on attachment 8379665 [details] [diff] [review]
don't reset Australis' TabsToolbar collapsed state, add UI migration to fix this in existing profiles that may have used reset() since this was done,

Review of attachment 8379665 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good - let's just make sure to update the documentation for registerArea about defaultCollapsed.

::: browser/components/customizableui/src/CustomizableUI.jsm
@@ +224,5 @@
>          "new-tab-button",
>          "alltabs-button",
>          "tabs-closebutton",
>        ],
> +      defaultCollapsed: null,

Let's update the documentation for registerArea so that it's clear what setting this to null really does.
Attachment #8379665 - Flags: review?(mconley) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/f9dcf7171707

Updated the comment and updated MDN as well.
Status: NEW → ASSIGNED
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f9dcf7171707
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 30
Comment on attachment 8379665 [details] [diff] [review]
don't reset Australis' TabsToolbar collapsed state, add UI migration to fix this in existing profiles that may have used reset() since this was done,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis / bug 966599 
User impact if declined: private windows always show the tab overflow arrows
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low-ish, targeted regression fix. However, does come with a migration bump in nsBrowserGlue. Alternatives would be figuring out *why* the overflow state of the tabs toolbar breaks so easily, but throughout various bugs on the matter we haven't come close to doing that, so this is unlikely to be ready in the 29 timeframe.
String or IDL/UUID changes made by this patch: none
Attachment #8379665 - Flags: approval-mozilla-aurora?
Attachment #8379665 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: cornel.ionce
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Windows NT 6.1; rv:30.0) Gecko/20100101 Firefox/30.0

Verified as fixed on latest Aurora (build ID: 20140313004000) and latest Nightly (build ID: 20140313030202) using the STR provided by Alice in comment 7.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.