Default character coding setting is blank in pref

VERIFIED FIXED in mozilla0.9.5

Status

SeaMonkey
Preferences
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: doctor__j, Assigned: tao)

Tracking

({regression})

Trunk
mozilla0.9.5
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+)

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3+) Gecko/20010830
BuildID:    2001083005

Reproducible: Always
Steps to Reproduce:
1. Create a new profile.
2. Open Pref Menu -> Navigator -> Languages
3. Look at "Character Coding" section.
4. Default character coding setting is blank.  It should be "Western (ISO-8859-1)".
(Reporter)

Comment 1

17 years ago
Created attachment 47656 [details]
Screenshot
-> jbetak?

interestingly, i see this on mac and windows [regardless of theme],
2001.08.29-comm, but *not* on linux.
Assignee: sgehani → jbetak
Keywords: mozilla0.9.4, regression
hmm, interesting - doctor__j could you repost the screenshot please? For some 
reason, I can't see it. Have you tested this with a fresh profile?
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.5
(Reporter)

Comment 4

16 years ago
Read my repro steps #1: Create a new profile.

(Reporter)

Comment 5

16 years ago
Created attachment 47950 [details]
Screenshot (repost)
thanks doctor__j (and thanks for being so polite too).

This looks like a regression from my 08/16/2001 checkin, it starts with the 
08/17/2001 build. I think this is pretty bad - seems like 0.9.4 will ship like 
this, unless we get an emergency approval. I'll work on a patch and email asa 
and the drivers.
OS: Windows 98 → All
Hardware: PC → All
*** Bug 98631 has been marked as a duplicate of this bug. ***
OK, I'm getting closer: tao has checked in a change on August 28, which moved 
the default charset pref pref from "chrome://navigator/locale/navigator
.properties" to "chrome://navigator-platform/locale/navigator.properties". 

Cc'ing tao to solicit feedback - I think I'll have a patch in few minutes.
I'm currently testign Linux. I don't think it should appear there... 

Tao, do we need win/navigator.properties and mac/navigator.properties to make 
sure we find the pref default values on these platforms?
OK, this happens on Win and Mac only, since we don't have platform-specific 
navigator.properties files for these OSes yet.

At this point I see two ways to resolve this bug:

1) Create platform-specific navigator.properties for both Mac and Windows. If 
they are going to live in a separate jar file (I believe the Unix case sets a 
precedent here), it would require  an installer change. I think it's too late 
to get these kind of changes into 0.9.4, so we'd have to ship with a broken 
pref default for Win and Mac.

2) Revert the intl.charset.default location reference in all.js 
to "chrome://navigator/locale/navigator.properties". THis is a fairly minor 
change and could be slipped into the 0.9.4 build.
Created attachment 48608 [details] [diff] [review]
reverting intl.charset.default pref default to the platform-independent navigator.properties file
tao, what do you think? Would this break the thing you tried to fix on Linux? 
Would shipping 0.9.4 with a broken pref default be worse than what gets broken 
by this patch?
Whiteboard: have patch - need r/sr/a
(Assignee)

Comment 13

16 years ago
Looks like the description of 
http://bugscape.netscape.com/show_bug.cgi?id=8124 is not accurate:

  "Currently, intl.charset.default is set to Shift_JIS for Win and mac, but for
  linux it should be set to EUC-JP. This preference should be set in ja-unix.jar,
  since it affects only linux."

This prefs should be platform-dependent instead of unix-only. Please make the 
real fix in both branches but 

  1) for 0.9.5, check it in after r/sr.
  2) for 0.9.4, hold the change until moz0.9.4 is released.

Feel free to ask me for review or reassign to me if you like. 

Comment 14

16 years ago
Bad regression.  Nominating for nsbranch 0.9.4.
Keywords: nsbranch
Target Milestone: mozilla0.9.5 → mozilla0.9.4

Comment 15

16 years ago
marking nsbranch+, bad regression
Keywords: nsbranch → nsbranch+
per our offline discussion - reassigning to tao. Tao, please let me know if I 
can be of any assistance.
Assignee: jbetak → tao
Status: ASSIGNED → NEW
(Assignee)

Comment 17

16 years ago
Created attachment 49055 [details] [diff] [review]
mozilla: add navigator.proeprties to en-{win,mac}.jar
(Assignee)

Comment 18

16 years ago
Created attachment 49056 [details] [diff] [review]
ns: register navigator-platform
Comment on attachment 49056 [details] [diff] [review]
ns: register navigator-platform

sr=dveditz
Attachment #49056 - Flags: superreview+
Comment on attachment 49055 [details] [diff] [review]
mozilla: add navigator.proeprties to en-{win,mac}.jar

>Index: xpfe/browser/resources/locale/en-US/mac/Makefile.in
>===================================================================
>+# The contents of this file are subject to the Netscape Public
>+# License Version 1.1 (the "License"); you may not use this file

This should probably be the Mozilla license unless this entire file is
copied from elsewhere. In any case the copyright date needs updating

>Index: xpfe/browser/resources/locale/en-US/mac/jar.mn~
>===================================================================
>RCS file: jar.mn~
>diff -N jar.mn~

Please don't check in backup files. If this is showing up in a "cvs diff -N"
then you must have done a "cvs add" on it. Be careful and don't commit this.

>Index: xpfe/browser/resources/locale/en-US/win/Makefile.in
>===================================================================
>+# The contents of this file are subject to the Netscape Public

Ditto license comments above. Other files in this patch use the
Mozilla license and the correct copyright date.

With the above caveats, r=dveditz
Attachment #49055 - Flags: review+
(Assignee)

Comment 21

16 years ago
*** Bug 97705 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

16 years ago
Nomintae for PDT
Status: NEW → ASSIGNED
Whiteboard: have patch - need r/sr/a → PDT; have patch - need r/sr/a

Comment 23

16 years ago
0.9.4 is out the door.
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Updated

16 years ago
Blocks: 97997

Updated

16 years ago
No longer blocks: 97997

Comment 24

16 years ago
This would block bug# 97997 - the page https://easyweb.tdcanadatrust.com fails
to load when the charset is set to blank.

Comment 25

16 years ago
*** Bug 98908 has been marked as a duplicate of this bug. ***

Comment 26

16 years ago
This still needs an R for one patch, and SR for another patch. Pls get this one
ready.
(Assignee)

Comment 27

16 years ago
The new files you mentioned are in fact exact copies of some old files. I'll
resubmit a patch without the jar.mn~.
(Assignee)

Comment 28

16 years ago
Created attachment 49714 [details] [diff] [review]
(revised) mozilla: add navigator.proeprties to en-{win,mac}.jar
(Assignee)

Updated

16 years ago
Whiteboard: PDT; have patch - need r/sr/a → PDT; need r/sr
r=jbetak

I'm just wonderign: do the Mac-specific files need to be added to Codewarrior 
project files?

Comment 30

16 years ago
Tao - How close are we to getting an SR.
(Assignee)

Comment 31

16 years ago
thanks for the review. No, you don't need to update project files for chrome
files addition.
Whiteboard: PDT; need r/sr → PDT; need sr
(Assignee)

Comment 32

16 years ago
Comment on attachment 49056 [details] [diff] [review]
ns: register navigator-platform

per jbetak 2001-09-18 16:03
Attachment #49056 - Flags: review+
(Assignee)

Comment 33

16 years ago
note: tested on both win and mac.

Comment 34

16 years ago
Comment on attachment 49055 [details] [diff] [review]
mozilla: add navigator.proeprties to en-{win,mac}.jar

seems reasonable to me!
sr=alecf
Attachment #49055 - Flags: superreview+
(Assignee)

Comment 35

16 years ago
Comment on attachment 49714 [details] [diff] [review]
(revised) mozilla: add navigator.proeprties to en-{win,mac}.jar

r=dveditz,sr=alecf
Attachment #49714 - Flags: superreview+
Attachment #49714 - Flags: review+
(Assignee)

Comment 36

16 years ago
I'll see if I nedd to revise the license statement in the new files. If so, I'll
provide diffs (of the license statement) and then check it in.
Whiteboard: PDT; need sr → PDT;
(Assignee)

Comment 37

16 years ago
Based on the email discussion with Gerv, I am checking in the patches as it is.
thx!

--Q--
How do we handle exact copy of existing files? I am adding a few
directories/files into the tree. The new files are in fact exact copies of some
existing files in the tree. While some of these files have MPL, the others do
not have any license at all. Should I insert the triple license boilerplate into
those that don't have licenses yet? (Please refer the patches in
http://bugzilla.mozilla.org/show_bug.cgi?id=97606).

--A---
Unless the files are under the NPL, they should keep their original licenses. If
they have no license, then they should (for the moment) continue to have no license.

Gerv

Comment 38

16 years ago
check it into the branch and trunk - PDT+
Whiteboard: PDT; → PDT+
(Assignee)

Updated

16 years ago
Whiteboard: PDT+ → PDT+, (in trunk)
(Assignee)

Updated

16 years ago
Blocks: 99108

Comment 39

16 years ago
Check this in on the branch now.

Comment 40

16 years ago
*** Bug 100370 has been marked as a duplicate of this bug. ***

Comment 41

16 years ago
*** Bug 100925 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 42

16 years ago
in branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: PDT+, (in trunk) → PDT+

Comment 43

16 years ago
testcase for this bug:

1) visit http://www.paymybills.com
2) click on "Secure Login"

Expected Results

You get a login screen

Actual Results (in unpatched build)

You get "server 500" error
*** Bug 101568 has been marked as a duplicate of this bug. ***
vrfy fixed on winnt, mac os 9.1 and mac os 10.0.4 --using 2001.09.25-branch comm
bits.
Keywords: vtrunk
vrfy fixed using 2001.10.22.1x-trunk comm bits on linux rh6.2, mac 10.1 and winNT.
Status: RESOLVED → VERIFIED
Keywords: vtrunk
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.