Closed Bug 976375 Opened 6 years ago Closed 6 years ago

crash in android.content.res.Resources$NotFoundException: Resource is not a Drawable (color or path): TypedValue{t=0x1/d=0x7f0c0074 a=3 r=0x7f0c0074} at android.content.res.Resources.loadDrawable(Resources.java)

Categories

(Firefox for Android :: General, defect, critical)

All
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 987864
Tracking Status
fennec + ---

People

(Reporter: kbrosnan, Assigned: bnicholson)

References

Details

(Keywords: crash, topcrash-android-armv7, Whiteboard: [Samsung Galaxy Tab Plus])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-35446ec9-5b0c-4eed-a37f-2a6062140222.
=============================================================

Follow up from bug 970081.
Looks like some of the remaining crashes are in <video> playback. full screen? The other common site uses Geolocation. Would either of you look into if the fix for  bug 970081 would apply to those cases.
Flags: needinfo?(wjohnston)
Flags: needinfo?(bnicholson)
I have one of these devices now, so I'll try reproing when I get a chance.
One of the comments mention downloads crashing.
Crash Signature: [@ android.content.res.Resources$NotFoundException: Resource is not a Drawable (color or path): TypedValue{t=0x1/d=0x7f0c0074 a=3 r=0x7f0c0074} at android.content.res.Resources.loadDrawable(Resources.java)] → [@ android.content.res.Resources$NotFoundException: Resource is not a Drawable (color or path): TypedValue{t=0x1/d=0x7f0c0074 a=3 r=0x7f0c0074} at android.content.res.Resources.loadDrawable(Resources.java)] [@ android.content.res.Resources$NotFoundExcept…
Still only the GT-P6210?
I wonder if Android is getting confused by some custom styling we have for button toasts? I'm not sure how that could happen... Do we have any sort of regression range here? I'm curious if bug 950826 might have tickled something.
Flags: needinfo?(wjohnston)
This is a crash on a specific device that ends up as a top crash.
I have a GT-P1000N, which I don't see in any of the crash reports, so maybe I don't have the right device for this. It's also on Android 2.2, and these reports are showing 3.2, so this probably needs rooting/updating even if it is affected. Needless to say, I haven't had any success reproducing on this device with Android 2.2.
Flags: needinfo?(bnicholson)
We had already determined that this is device specific and that the GT-P1000 was unafected.
Wondering if we should block the GT-P6200 series on Google Play
This just results in ignoring the bug instead of fixing it. We already know the cause.
Duplicate of this bug: 1005872
Duplicate of this bug: 1005869
Whiteboard: [Samsung Galaxy Tab Plus]
As per the duplicates, the prevalence of interaction in the browser in which a toast notification can appear is rather common and the end result is a crash. Can an engineer request a device from Service Now?
See Also: → 1006631
This still happens

https://crash-stats.mozilla.com/report/list?signature=android.content.res.Resources%24NotFoundException%3A+Resource+is+not+a+Drawable+%28color+or+path%29%3A+TypedValue{t%3D0x1%2Fd%3D0x7f0d0077+a%3D3+r%3D0x7f0d0077}+at+android.content.res.Resources.loadDrawable%28Resources.java%29&product=FennecAndroid&query_type=contains&range_unit=weeks&process_type=any&hang_type=any&range_value=4#reports

https://crash-stats.mozilla.com/report/list?signature=android.content.res.Resources%24NotFoundException%3A+Resource+is+not+a+Drawable+%28color+or+path%29%3A+TypedValue{t%3D0x1%2Fd%3D0x7f0d0077+a%3D3+r%3D0x7f0d0077}+at+android.content.res.Resources.loadDrawable%28Resources.java%29&product=FennecAndroid&query_type=contains&range_unit=weeks&process_type=any&hang_type=any&range_value=4#reports
Crash Signature: [@ android.content.res.Resources$NotFoundException: Resource is not a Drawable (color or path): TypedValue{t=0x1/d=0x7f0c0074 a=3 r=0x7f0c0074} at android.content.res.Resources.loadDrawable(Resources.java)] [@ android.content.res.Resources$NotFoundExcept… → [@ android.content.res.Resources$NotFoundException: Resource is not a Drawable (color or path): TypedValue{t=0x1/d=0x7f0d0077 a=3 r=0x7f0d0077} at android.content.res.Resources.loadDrawable(Resources.java)] [@ android.content.res.Resources$NotFoundExcept…
Yes, and it's still entirely the Samsung Galaxy Tab Plus
tracking-fennec: --- → +
Assignee: nobody → bnicholson
Let's try fixing this like we did in bug 970081
I'm going to take a guess that this, bug 987864, and bug 1006631 are all dupes. The resource ID slowly changes over time, probably as we introduce new resources. Note how this bug was originally filed against the resource 0x7f0c0074, but those crashers are all gone now.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987864
Duplicate of this bug: 1043116
You need to log in before you can comment on or make changes to this bug.