Closed Bug 978404 Opened 6 years ago Closed 6 years ago

Switch the Tarako over to use the MLS provider

Categories

(Core :: DOM: Geolocation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed

People

(Reporter: dougt, Assigned: fabrice)

References

Details

Attachments

(2 files, 1 obsolete file)

Fabrice, please switch the Tarako specific preference files to point at our location service.  We've agreed on the API key via IRC.
Thinker,

Do you know where we set the device specific prefs for Tarako? I think it makes sense to have them under device/sprd/sp6821a_gonk and use the support from bug 945630.
Flags: needinfo?(tlee)
(In reply to Fabrice Desré [:fabrice] from comment #1)
> Thinker,
> 
> Do you know where we set the device specific prefs for Tarako? I think it
> makes sense to have them under device/sprd/sp6821a_gonk and use the support
> from bug 945630.

We set device specific prefs in device/sprd/sp6821a_gonk/dev-pref.js.
Flags: needinfo?(tlee)
Fabrice, wonder if you can update the status of this bug? thanks
Flags: needinfo?(fabrice)
(In reply to Joe Cheng [:jcheng] from comment #3)
> Fabrice, wonder if you can update the status of this bug? thanks

I'll provide a patch soon.
Flags: needinfo?(fabrice)
I have another patch for the mozconfig part.
Attachment #8392548 - Flags: review?(dougt)
Attached patch mls.patch (obsolete) — Splinter Review
mozconfig changes to make it possible to configure an API key for mls.
Attachment #8392569 - Flags: review?(mwu)
Attached patch mls.patchSplinter Review
Attachment #8392569 - Attachment is obsolete: true
Attachment #8392569 - Flags: review?(mwu)
Attachment #8392676 - Flags: review?(mwu)
Comment on attachment 8392548 [details] [diff] [review]
geoloc-config.patch

Review of attachment 8392548 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8392548 - Flags: review?(dougt) → review+
James, can you land attachment 8392548 [details] [diff] [review] on your device branch? thanks!
Flags: needinfo?(james.zhang)
commit 8a88ca86ee9ddb202375b824267b8f820ba708cd
Author: james.zhang <james.zhang@spreadtrum.com>
Date:   Wed Mar 19 11:20:08 2014 +0800

    Bug#269156 merge patch from mozilla, Bug 978404 - Switch the Tarako over to use the MLS provider
    
    Change-Id: If1f61ae5eaa042e960bc0e2c7f00274fbf5cfd60
Flags: needinfo?(james.zhang)
Comment on attachment 8392676 [details] [diff] [review]
mls.patch

r=me for v1.3t *only*
Attachment #8392676 - Flags: review?(mwu) → review+
landed as cd4b17765cc6caa1ffebc30a43eaee7cf4879ab1 in gonk-misc v1.3t
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
I had to revert this in https://github.com/mozilla-b2g/gonk-misc/commit/adfafeca79b9f32a05588bcd7d720a528cd91064 for breaking the 1.3t build on TBPL: 
https://tbpl.mozilla.org/php/getParsedLog.php?id=36406563&tree=Mozilla-B2g28-v1.3t


It's a bunch of different failures due to:
mv: cannot stat `build_stage/application.zip': No such file or directory
Flags: needinfo?(fabrice)
Hm, what really break us is not the zip errors but:
12:07:32    ERROR -  make[3]: *** [scripts/basic/fixdep] Error 2
12:07:32    ERROR -  make[2]: *** [scripts_basic] Error 2
12:07:32    ERROR -  make[1]: *** [sub-make] Error 2
12:07:32     INFO -  make[1]: Leaving directory `/builds/slave/b2g_m-b28_v1_3t_tko_eng_dep-00/build/kernel'
12:07:32     INFO -  make: *** [kernelheader] Error 2
12:07:32     INFO -  make: *** Waiting for unfinished jobs....
12:07:32     INFO -  Done

Not sure what's happening, I'll take a look tomorrow.
Flags: needinfo?(fabrice)
And of course I can't reproduce on a fresh local build...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
And the error from comment 14 is still happening intermittently. Wes, do you mind relanding?
Flags: needinfo?(kwierso)
Unreverted in https://github.com/mozilla-b2g/gonk-misc/commit/56bd55e0514a4daa61b036d223edb36e5ae9b1ec

We'll see how it goes.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(kwierso)
Resolution: --- → FIXED
How do you explain all the others exact same failures without this change? See a86cf28cc78a that was red on first build and green when restarted.
Flags: needinfo?(fabrice)
So, 2 greens and 2 reds on the push you reverted, and the backout is red. Clearly this patch is not the cause of the intermittent failure.
Re-relanded in https://github.com/mozilla-b2g/gonk-misc/commit/575204d5d39f8b9329fb47a80db616c2362bf488
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
We want a different way to set the mls key on 1.5. mwu, dougt and me know what to do.
(In reply to Fabrice Desré [:fabrice] from comment #22)
> We want a different way to set the mls key on 1.5. mwu, dougt and me know
> what to do.

:fabrice/:dougt, do we have a filed bug you can point me to for tracking purposes? Thanks !
Traige: Already have another bug 1009761 for partner to import the key. No need for v1.4
You need to log in before you can comment on or make changes to this bug.