Closed Bug 971637 Opened 6 years ago Closed 6 years ago

[Tarako] Support Geolocation (device has no GPS/A-GPS support)

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

RESOLVED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed

People

(Reporter: atsai, Assigned: dougt)

References

Details

(Whiteboard: [demo][tarako_only])

Attachments

(1 obsolete file)

** The case is by the testing on Tarako devices. It might not be able to reproduce on other mobile devices **

Since there's no GPS/A-GPS support, we should remove geolocation checking or related APIs do make sure we won't spend time on waiting for GPS response.
triage: 1.3T+ for the release to remove GPS/AGPS
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(fabrice)
Whiteboard: [demo] → [demo][tarako_only]
Doug will tell us what to do. Actually, he will do it for us!
Assignee: nobody → doug.turner
Flags: needinfo?(fabrice)
Kanru and I discussed tonight.  For the client bits:

1) Modify the location provider interface, and add a method "IsAbleToProvideLocation()" or some nicer name.

2) In the geolocation code, when we create the provider, call "IsAbleToProvideLocation()"
   --  If the response is false, then use the NetworkLocationProvider.js
   --  If the response is true, do what we do now.

3) The implementation of IsAbleToProvideLocation is probably:
    is GonkGPSGeolocationProvider::GetGPSInterface() != nullptr

4) For all B2G builds, we should point the preference geo.wifi.uri at our service.
 
We'll have to make the NetworkLocationProvider.js ship in all builds.  Then, using the magic of XPCOM, we can register a new contract id for this class so that we can always find it.
Assignee: doug.turner → rlb
Note that GetGPSInterface() is very slow on some device so you might need to design a async API.
Okay -- ignore comment 3 and 4.


Fabrice said that we can have device specific preferences.  If that is the case, just make the Tarako point at our location service:

https://mozilla-ichnaea.readthedocs.org/en/latest/api/geolocate.html

We should also fix bug 976396.
Summary: [Tarako] Disable Geolocation options due to no GPS/A-GPS support → [Tarako] Support Geolocation (device has no GPS/A-GPS support)
Assignee: rlb → dougt
(In reply to Doug Turner (:dougt) from comment #5)
> Okay -- ignore comment 3 and 4.
> 
> 
> Fabrice said that we can have device specific preferences.  If that is the
> case, just make the Tarako point at our location service:

That was bug 945630
Attached patch fallback-geoloc.patch (obsolete) — Splinter Review
Using a pref, that works on my tarako with Mozilla's geo.wifi.uri. Should we change to this one by default too instead of google's ?
Attachment #8381832 - Flags: feedback?(dougt)
Comment on attachment 8381832 [details] [diff] [review]
fallback-geoloc.patch

i'll put up my patch queue soon.  You'll need more than this.
Attachment #8381832 - Flags: feedback?(dougt) → feedback-
Depends on: 976452, 976455
Depends on: 977448
Depends on: 977454
Depends on: 977455
Depends on: 977456
Attachment #8381832 - Attachment is obsolete: true
Blocks: 977725
Depends on: 978404
Tarako has no GPS hardware, but I think AGPS is depend on network.
All work on this bug is effectively over.  Fabrice will be configuring Tarako to point at our location service provider.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Fabrice, is there a follow up bug for the configuration work? thanks
Flags: needinfo?(fabrice)
Yes, bug 978404
Flags: needinfo?(fabrice)
Hi Fabrice,
could advise if i could get this fix in today build and start verify geolocation related functions / apps?

BR,
Marvin
As soon as bug 978404 is reviewed I'll land the gonk-misc part and partners will take the device part. I let everyone know how to configure builds in bug 977456.

I tested today and it worked fine.
got it, thanks Fabrice! :)
We want a different way to set the mls key on 1.5. mwu, dougt and me know what to do.
Depends on: 1007953
Depends on: 1014916
Depends on: 1014924
You need to log in before you can comment on or make changes to this bug.