RESOLVED FIXED

Status

Developer Services
General
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: emorley, Assigned: emorley)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
See bug 968958 for context.

Steve similar to the other bugs, are you ok with this? :-)
(Assignee)

Comment 1

3 years ago
(In reply to Ed Morley [:edmorley UTC+0] from comment #0)
> Steve similar to the other bugs, are you ok with this? :-)

Oops, forgot the needinfo :-)
Flags: needinfo?(sphink)
(Assignee)

Comment 2

3 years ago
Steve am I ok to proceed? :-)
(Assignee)

Comment 3

3 years ago
I've decided to proceed with importing the repo - even if you would like to keep the bitbucket version we would likely still want the extension in version-control-tools - so the decision as to whether to depreciate the old repo is orthogonal to the import itself.
(Assignee)

Comment 4

3 years ago
[/c/src/vctools]$ /c/Users/Ed/Documents/code\ snippets/repo-import.sh ../mqext hgext/mqext
Import ../mqext into the subdirectory hgext/mqext? (y/n)?y
pulling from https://hg.mozilla.org/hgcustom/version-control-tools/
searching for changes
no changes found
pulling from https://bitbucket.org/sfink/mqext
searching for changes
no changes found
scanning source...
sorting...
converting...
59 Initial import of mqext extension.
spliced in ['eaa64fd26c3975e52f8291bfaf3d3f7c7e6b9229'] as parents of 738669dfb1bdeb1269736e135e96fd2afc13fd05
58 Inherit docstrings from wrapped functions
57 Added in qimport
56 Now make qimport work again
55 Add in qfinish
54 Bad error message with qref on empty queue
53 Add -p option to qtouched, fix cmd line handling
52 Add a global configuration rather than requiring every command add -Q
51 Make it stop properly, and fix up argument handling
50 Clean up some debugging output, restrict it to -v
49 Add a couple of commands to the list (they were already implemented)
48 Fix formatting of help message
47 Oops, turns out bitbucket uses the same formatting for the README as hg does
46 minor tweak to README.txt
45 Incorporate Blake Winton's getReviewer.py as a 'reviewers' extension.
44 Add to README, beef up docs
43 now actually try running it
42 Missing import
41 Remove qexport command. Will bring it back if there's any need for it.
40 Remove doc for qexport
39 Add somewhat hacky 'hg bugs' and 'hg components' commands for scanning
38 Better notification of what is being used, fix -f option for hg bugs, hg components, hg reviewers
37 Compatibility with newer hg versions. Also use pushbuffer/popbuffer instead
36 Make qshow use more built-in stuff so that color highlighting works
35 Remove cwd-dependence from hg reviewers/bugs/components -f
34 help messages do not seem to appreciated embedded newlines in default values
33 Fix problem where mqmessage would get set to None by the caller
32 -M should still take a message!
31 Overly conservative check for mq presence
30 Improve diagnostic when no patch source can be found
29 Implement 'qbackout' based on http://blog.bonardo.net/2011/11/22/even-easier-backouts-from-the-trees
28 Moved qbackout out of this extension over to https://bitbucket.org/sfink/qbackout
27 full_series -> fullseries version naming incompatibility (grr... older name is better anyway)
26 Also handle inaccessible bugs (due to security restrictions)
25 Move some of the verbose stuff to ui.debug
24 Remove lineage command. I never used it, and I still think there's probably
23 Add a 'urls' command for guessing commit URLs to paste into bugzilla
22 The qfold command also modifies the patch queue and should trigger an autocommit if desired.
21 make qfold check for mq repo existence before using it
20 Eliminate what appears to be dead code but is actually something the screws up an iterator
19 remove TODO for something that is now handled pretty well
18 Implement %Q option for mq commit logs, clean up the implementation, document new stuff
17 Use the 'extensions' package for adding commands
16 Autolog for qcrecord too
15 Remove the username from the urls generated by the |hg urls| command (they started getting escaped by more recent mercurials)
14 Handle new versions of mq extension, which changed initialization procedure.
13 Allow giving a main repo revision to qshow. Probably ought to guard this with a config option.
12 Default history depth not nearly enough when looking up components, reviewers, etc.
11 minor comment tweak
10 clean up imports
9 Implement experimental qrevert command. Probably not useful yet.
8 Add headers when qshow is used with a non-patch revision
7 Propagate error returns (apparently they are not exceptions!)
6 Speed up reviewers and components command, add --brief option
5 Speed up patch_changes
4 Sane limits for reviewers/bugs/component, and apply manually
3 default to relglob in patch_changes
2 I guess pulling reviewers from the last 1000 updates to a file is a little excessive
1 When gathering file history, do a relglob against the current manifest, then exact path matches on history
0 Handle failed file matches

Landed as:
https://hg.mozilla.org/hgcustom/version-control-tools/pushloghtml?changeset=ebe7730be010
Status: NEW → ASSIGNED
(Assignee)

Comment 5

3 years ago
(Waiting on bug 918979 before landing the mozilla-central change to use the vcs-tools copy)
(Assignee)

Updated

3 years ago
Depends on: 1056262
(Assignee)

Updated

2 years ago
Flags: needinfo?(sphink)
(Assignee)

Comment 6

2 years ago
Created attachment 8605761 [details] [diff] [review]
mach mercurial-setup: Use mqext from the version-control-tools repo
Attachment #8605761 - Flags: review?(gps)
(Assignee)

Updated

2 years ago
Component: Tools → General
Product: Release Engineering → Developer Services
QA Contact: hwine
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1056262
(Assignee)

Updated

2 years ago
No longer depends on: 1056262
(Assignee)

Updated

2 years ago
Attachment #8605761 - Attachment is patch: true

Comment 8

2 years ago
Comment on attachment 8605761 [details] [diff] [review]
mach mercurial-setup: Use mqext from the version-control-tools repo

Review of attachment 8605761 [details] [diff] [review]:
-----------------------------------------------------------------

Bugzilla is telling me there are Windows line endings in this patch. Please don't check those in.

::: tools/mercurial/hgsetup/wizard.py
@@ -172,5 @@
>          self.updater = MercurialUpdater(state_dir)
>  
>      def run(self, config_paths):
> -        try:
> -            os.makedirs(self.ext_dir)

Why did you remove this? Does the parent directory get created elsewhere? If so, r+. If not, please leave it in (it should be harmless).
Attachment #8605761 - Flags: review?(gps) → review+
(Assignee)

Comment 9

2 years ago
(In reply to Gregory Szorc [:gps] from comment #8)
> Bugzilla is telling me there are Windows line endings in this patch. Please
> don't check those in.

There are none locally, I just had to use paste as attachment, since bzexport wasn't working.

> ::: tools/mercurial/hgsetup/wizard.py
> @@ -172,5 @@
> >          self.updater = MercurialUpdater(state_dir)
> >  
> >      def run(self, config_paths):
> > -        try:
> > -            os.makedirs(self.ext_dir)
> 
> Why did you remove this?

Explanation in the commit message.

> Does the parent directory get created elsewhere? If
> so, r+. If not, please leave it in (it should be harmless).

The parent directory (<state-dir>/mercurial/) isn't created elsewhere, so I was going to update the patch to just create that (and not also the extensions subdirectory within), but then bug 1164812 comment 2 implies we might have other extensions in there in the future, so I've just left it for now.
(Assignee)

Comment 10

2 years ago
Created attachment 8607121 [details] [diff] [review]
mach mercurial-setup: Use mqext from the version-control-tools repo

Now with the changes mentioned above, and I also noticed update.py needed mqext references removing too.
(Assignee)

Updated

2 years ago
Attachment #8605761 - Attachment is obsolete: true

Comment 11

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/633b03e19372
https://hg.mozilla.org/mozilla-central/rev/633b03e19372
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.